Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-11-2009, 10:27 AM   #401
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by EVL1 View Post
Celly, keep us posted. I get mine back on Thursday/Friday, waiting impaitiently to do so. Did you get any "goodwill" form SoA on yours? Still waiting to hear back if they'll extend me a 100K, transferable warranty because of this malfunction. Whatever happens, I got to get out of this stupid Yaris. Good luck.
Well, you'll have the same issues that I had... In Florida it's illegal for them to give us extended warranties...

*shrug* we'll see....
* Registered users of the site do not see these ads.
Celly is offline   Reply With Quote
Old 08-11-2009, 10:31 AM   #402
Quik265
Scooby Specialist
 
Member#: 189662
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2012 S4
Monsoon

Default

^illegal?? Well you tell them you'll give them $5 for the 100k warrenty and considering the circumstances you think thats fair. They dont have to 'give' it to you... i can believe they dick you around after an engine malfunction in a brand new car..
Quik265 is offline   Reply With Quote
Old 08-11-2009, 10:36 AM   #403
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by Celly View Post
Well, you'll have the same issues that I had... In Florida it's illegal for them to give us extended warranties...

*shrug* we'll see....
When I used to sell warranties, we weren't allowed to discount anything Florida, as it took away tax money for the state government, so part of me thinks this is true. Still, they should be able to pay for the warranty, including tax, for you. Any word on when you're getting a new block?
peglegsteve is offline   Reply With Quote
Old 08-11-2009, 10:53 AM   #404
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by peglegsteve View Post
When I used to sell warranties, we weren't allowed to discount anything Florida, as it took away tax money for the state government, so part of me thinks this is true. Still, they should be able to pay for the warranty, including tax, for you. Any word on when you're getting a new block?
Well, I got the car back yesterday.... It just doesn't feel like it has any Mojo to it...

It's really a catch 22.... I need to re-break in an engine, but at the same time, I wanna make sure the car is 'right' -- so I can't really give it the juice... And seeing that I put less than 500 miles a month on my car... It means it'll take 2 months to for me to really break it in...

So, I guess time will tell...
Celly is offline   Reply With Quote
Old 08-11-2009, 11:04 AM   #405
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Quote:
Originally Posted by Celly View Post
Well, I got the car back yesterday.... It just doesn't feel like it has any Mojo to it...

It's really a catch 22.... I need to re-break in an engine, but at the same time, I wanna make sure the car is 'right' -- so I can't really give it the juice... And seeing that I put less than 500 miles a month on my car... It means it'll take 2 months to for me to really break it in...

So, I guess time will tell...
Don't know if I'm just overlooking it, but whatever happened with the first replacement engine?
peglegsteve is offline   Reply With Quote
Old 08-11-2009, 11:39 AM   #406
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by peglegsteve View Post
Don't know if I'm just overlooking it, but whatever happened with the first replacement engine?
It went boom...

I really never got into the greasy details of what happened with it... I mean the fact that it popped on start-up pretty much points to it not being right from the factory... Some could say it was install error -- but the guy who did mine is really good -- and you would have to majorly f' up to pop an engine on startup... I mean, even without oil, an engine will run for a while... *Shrug* -- It happens. Better at the dealer, than on my way home.
Celly is offline   Reply With Quote
Old 08-11-2009, 02:22 PM   #407
The Crowd
Scooby Newbie
 
Member#: 189231
Join Date: Sep 2008
Location: SoCal
Vehicle:
2009 WRX Hatch
Silver

Default

Anyone in SoCal have his problem on their 09 WRX? I'm thinking if this happens to me (build date July 08), then I want to take my car to a dealership who has already seen this problem, to negate any hassle.



Thank you in advance.

Also, please PM me.
The Crowd is offline   Reply With Quote
Old 08-11-2009, 02:33 PM   #408
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by The Crowd View Post
Anyone in SoCal have his problem on their 09 WRX? I'm thinking if this happens to me (build date July 08), then I want to take my car to a dealership who has already seen this problem, to negate any hassle.
Unless you have some drastic mods... There will be no hassle... SOA is pretty much a giant Longblock pez dispenser...

And if you do get hassle -- call customer service... They'll know what you're talking about. (And, they are some super nice people over there too) -- ask for 'Jennifer' -- She sounds really cute.

...just saying
Celly is offline   Reply With Quote
Old 08-11-2009, 03:20 PM   #409
The Crowd
Scooby Newbie
 
Member#: 189231
Join Date: Sep 2008
Location: SoCal
Vehicle:
2009 WRX Hatch
Silver

Default

Quote:
Originally Posted by Celly View Post
Unless you have some drastic mods... There will be no hassle... SOA is pretty much a giant Longblock pez dispenser...

And if you do get hassle -- call customer service... They'll know what you're talking about. (And, they are some super nice people over there too) -- ask for 'Jennifer' -- She sounds really cute.

...just saying

Stage II mods even you think is possible they would not try to deny a spun rod bearing?
The Crowd is offline   Reply With Quote
Old 08-11-2009, 03:31 PM   #410
Quik265
Scooby Specialist
 
Member#: 189662
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2012 S4
Monsoon

Default

Quote:
Originally Posted by The Crowd View Post
Stage II mods even you think is possible they would not try to deny a spun rod bearing?
Thats what i'm hoping and will be fighting for if happens to me and my August build date...

Thing is, i shouldnt have to sacrifice having fun with my car and driving it with that horrid stock tune, for fear my engine will blow up,.. thats why you buy a brand new car with a supposed excellent reputation and standard for quality, so that you dont worry about it exploding in year 1,... whatever, i love my stage 2 and the car drives amazing,..
Quik265 is offline   Reply With Quote
Old 08-11-2009, 03:33 PM   #411
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

If you can't get jennifer at soa, ask for Gretchen. She was extremely friendly and helped me out. And of course she sounded cute
peglegsteve is offline   Reply With Quote
Old 08-11-2009, 03:35 PM   #412
Quik265
Scooby Specialist
 
Member#: 189662
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2012 S4
Monsoon

Default

^ well with a name like Gretchen..............
Quik265 is offline   Reply With Quote
Old 08-11-2009, 03:37 PM   #413
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by The Crowd View Post
Stage II mods even you think is possible they would not try to deny a spun rod bearing?
Seriously, it's a really tough call... At that point it's the discretion of SOA and might take some/a lot of fight. Either way, so far, I don't think any of the failures came w/ stage II mods -- seeing that most owners have been scared out of their minds and left the cars stock... So we don't have any incidents to reference to say how they turned out.

Perhaps Tea Cups can chime in since he is building the list (he leaves off people w/ modded cars) -- He might know of someone you can talk to.
Celly is offline   Reply With Quote
Old 08-11-2009, 03:42 PM   #414
Quik265
Scooby Specialist
 
Member#: 189662
Join Date: Sep 2008
Chapter/Region: W. Canada
Location: Canada
Vehicle:
2012 S4
Monsoon

Default

^ that is intersting, i've follwing this thread for awhile and the other '2009 wrx motor issues' or something along those lines and i dont remeber reading a single post from someone with mods of any kind and there engine blowing. I know in the survey they weren't to be included but at least you think we would have seen a post,.. there are tons of poeple that are stage 2 with this car and not a word of any engine failure,.. i could be wrong and there are lots and i just missed them,.. but if that was correct that no reported stage 1 or 2 cars with failed engines were out there,... it would be something else to say the least..
Quik265 is offline   Reply With Quote
Old 08-11-2009, 03:43 PM   #415
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

So far, even those with modded cars haven't had any problems getting warranty work, except for at least one guy with a catback where the dealer gave him crap until they talked to SOA presumably not knowing of the failures until they did. Really hard to say, though, as it is going to depend a lot on the dealership. But, if the dealer gives you trouble, a call to SOA will probably work in your favor.
Tea cups is offline   Reply With Quote
Old 08-11-2009, 04:49 PM   #416
The Crowd
Scooby Newbie
 
Member#: 189231
Join Date: Sep 2008
Location: SoCal
Vehicle:
2009 WRX Hatch
Silver

Default

Quote:
Originally Posted by Tea cups View Post
So far, even those with modded cars haven't had any problems getting warranty work, except for at least one guy with a catback where the dealer gave him crap until they talked to SOA presumably not knowing of the failures until they did. Really hard to say, though, as it is going to depend a lot on the dealership. But, if the dealer gives you trouble, a call to SOA will probably work in your favor.

Thanks everyone.
The Crowd is offline   Reply With Quote
Old 08-11-2009, 05:06 PM   #417
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by Quik265 View Post
^ that is intersting, i've follwing this thread for awhile and the other '2009 wrx motor issues' or something along those lines and i dont remeber reading a single post from someone with mods of any kind and there engine blowing. I know in the survey they weren't to be included but at least you think we would have seen a post,.. there are tons of poeple that are stage 2 with this car and not a word of any engine failure,.. i could be wrong and there are lots and i just missed them,.. but if that was correct that no reported stage 1 or 2 cars with failed engines were out there,... it would be something else to say the least..
Yeah -- this might also have to do with people being a lil less open about mods these days. Everyone is afraid that SOA is reading everything just to bust you..

But, in my opinion, it's good that they read these threads.... Perhaps someone at SOA will see this and introduce me to Jennifer...
Celly is offline   Reply With Quote
Old 08-11-2009, 05:31 PM   #418
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Celly View Post
Well, I got the car back yesterday.... It just doesn't feel like it has any Mojo to it...

It's really a catch 22.... I need to re-break in an engine, but at the same time, I wanna make sure the car is 'right' -- so I can't really give it the juice... And seeing that I put less than 500 miles a month on my car... It means it'll take 2 months to for me to really break it in...

So, I guess time will tell...
If your experience was similar to mine your vehicle will never be the same again.
AshJWilliams is offline   Reply With Quote
Old 08-11-2009, 06:01 PM   #419
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by AshJWilliams View Post
If your experience was similar to mine your vehicle will never be the same again.
Well, because of this exact reason I have decided not to drive my car for the next couple of days. Here is why:

I want to flush out all the preconceived notions I have -- and honestly go out and drive the car with an open mind, and an honest foot. I mean we have all been through a ton -- and I know I'm being biased.. When I went back to the dealer, the first words out of my mouth were "It's not the same..." -- And I honestly hope it's my mind playing tricks on me.

You have to think think of it this way... Remember that one girl/guy you really liked... And then you found out that they slept with some douche bag / ass hat / sexual deviant / awkward inanimate object... And those feelings were never the same for that person again? I mean, the person was the same -- Just your mental image of that person changed... I think that is what is going on with me..

I bought this car to have something fun to drive, and if I can't get past those feelings, I'm pissing away money... So, for my sake... And for the sake of my car... We're going to spend some time apart..

So -- In a few days... With a fresh objective mind... I'm going to give her another chance... I'm hoping for the best... We'll see...
Celly is offline   Reply With Quote
Old 08-11-2009, 07:58 PM   #420
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Celly View Post
Well, because of this exact reason I have decided not to drive my car for the next couple of days. Here is why:

I want to flush out all the preconceived notions I have -- and honestly go out and drive the car with an open mind, and an honest foot. I mean we have all been through a ton -- and I know I'm being biased.. When I went back to the dealer, the first words out of my mouth were "It's not the same..." -- And I honestly hope it's my mind playing tricks on me.

You have to think think of it this way... Remember that one girl/guy you really liked... And then you found out that they slept with some douche bag / ass hat / sexual deviant / awkward inanimate object... And those feelings were never the same for that person again? I mean, the person was the same -- Just your mental image of that person changed... I think that is what is going on with me..

I bought this car to have something fun to drive, and if I can't get past those feelings, I'm pissing away money... So, for my sake... And for the sake of my car... We're going to spend some time apart..

So -- In a few days... With a fresh objective mind... I'm going to give her another chance... I'm hoping for the best... We'll see...
I didn't mean psychologically. I mean that if you drove it and it felt amiss there are probably very real problems with your vehicle (especially considering that your dealership botched an engine install so badly that it self destructed immediately upon start-up).

Since last December I have had a spun rod bearing cause catastrophic engine failure requiring long block replacement. Ever since then I have noticed an occasional severe hesitation during acceleration, which persists to the present day (as well as a few other abnormalities probably all a result of the factory ECU tune). I have driven for 2 months with intermittent CEL's requiring 4 different trips to my local dealer to presumably resolve (one trip to diagnose, one completely unsuccessful, one to replace secondary air injection valve, one to conduct service on wiring harness/relay/fuses related to secondary air injection valve system). I have made 2 trips to my local dealer for service relating to what I believed to be use or loss of engine coolant; service adviser hypothesized that engine coolant was lost due to specific service procedure conducted and engine coolant level was not restored at the conclusion of service. Upon receiving my vehicle back from the secondary air injection valve replacement service the vehicle was returned to me with an apparent boost leak (or other abnormal high frequency noise from engine bay after turbo spool up), a damaged intercooler, and literally 7 other different pieces of equipment that were not installed properly (not clear to me if defects originated from factory and had not been observed or otherwise originated from dealer service). Bolts were literally missing, fasteners were not fastened, etc.

At that point I documented (including pictures) all of my problems and contacted SOA. Vehicle was returned to dealer for service. Dealer resolved a few of the existing issues but I still have a damaged intercooler, I still have an apparent boost leak (or other abnormal high frequency noise from engine bay after turbo spool up; I've also confirmed this abnormality by driving another 09 WRX Sedan since), and believe it or not (even though I provided pictures demonstrating exactly what defects existed in regard to improperly installed equipment) not all equipment was installed properly!

It's become obvious that my local dealer will be unable to remedy my problems but I'm not sure any other dealers will want to deal with them either. And regardless of that I have developed extremely valid concerns about the reliability and longevity of this vehicle. I have attempted to remain cordial while trying to work with SOA to assist in putting me in another 09 WRX or other Subaru but I'm beginning to feel like they've recently developed a policy of ignoring me. I honestly have no idea how to proceed at this point and I am beginning to feel like my only option is to lawyer up.

Thus the comment "if your experience was similar to mine your vehicle will never be the same again."
AshJWilliams is offline   Reply With Quote
Old 08-11-2009, 08:33 PM   #421
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Celly/Ash,
Damn...I just begininning to look forward to getting mine back tommorrow. Now I'm stressing again. I really hope I don't have to go down that road your talking about too....but I can if I must. Just sucks, I drive 600-700 miles a week and wanted something to enjoy the ride with. Now I get to pucker up every time I fire the engineup....oh well. I guess our only recourse in FL then is the Lemon Laws...
EVL1 is offline   Reply With Quote
Old 08-11-2009, 09:28 PM   #422
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by AshJWilliams View Post
I didn't mean psychologically. I mean that if you drove it and it felt amiss there are probably very real problems with your vehicle (especially considering that your dealership botched an engine install so badly that it self destructed immediately upon start-up).
I don't blame the dealer on that. I know the guys who did it, and they are top notch... For an engine to gernade that quickly... It was a dud to begin with...
Quote:
Since last December I have had a spun rod bearing cause catastrophic engine failure requiring long block replacement.

...

Thus the comment "if your experience was similar to mine your vehicle will never be the same again."
Agreed... I really hope no one has to go through that... That seriously sucks.

Quote:
Originally Posted by EVL1 View Post
Celly/Ash,
Damn...I just begininning to look forward to getting mine back tommorrow. Now I'm stressing again. I really hope I don't have to go down that road your talking about too....but I can if I must. Just sucks, I drive 600-700 miles a week and wanted something to enjoy the ride with. Now I get to pucker up every time I fire the engineup....oh well. I guess our only recourse in FL then is the Lemon Laws...
Nah -- Don't worry man... Just pick it up with an open mind. The only thing I recommend is to ask to test drive it before you sign anything. Even better if a tech goes with you.

I'm guessing your car is at SOJax.. And from what I have heard they are pretty top notch over there...

Oh -- And when they call and tell you it's ready to be picked up -- I don't think it's out of line if you request a quick car wash / vaccuum... Makes it nice to start with a nice clean car.
Celly is offline   Reply With Quote
Old 08-11-2009, 09:29 PM   #423
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by EVL1 View Post
Celly/Ash,
Damn...I just begininning to look forward to getting mine back tommorrow. Now I'm stressing again. I really hope I don't have to go down that road your talking about too....but I can if I must. Just sucks, I drive 600-700 miles a week and wanted something to enjoy the ride with. Now I get to pucker up every time I fire the engineup....oh well. I guess our only recourse in FL then is the Lemon Laws...
Man don't worry about it. Unless you are having problems there's no need too. It just worked out that Celly and I have had particularly bad experiences.
AshJWilliams is offline   Reply With Quote
Old 08-11-2009, 09:32 PM   #424
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Celly View Post
I don't blame the dealer on that. I know the guys who did it, and they are top notch... For an engine to gernade that quickly... It was a dud to begin with...


Agreed... I really hope no one has to go through that... That seriously sucks.



Nah -- Don't worry man... Just pick it up with an open mind. The only thing I recommend is to ask to test drive it before you sign anything. Even better if a tech goes with you.

I'm guessing your car is at SOJax.. And from what I have heard they are pretty top notch over there...

Oh -- And when they call and tell you it's ready to be picked up -- I don't think it's out of line if you request a quick car wash / vaccuum... Makes it nice to start with a nice clean car.
I'm just saying...new engines don't go boom on start up. Not even 07/08 to 09/08 builds LOL!
AshJWilliams is offline   Reply With Quote
Old 08-11-2009, 10:11 PM   #425
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Celly/Ash,
Thanks for the sentiment. I just want this to be over. You're right Celly, the guys as SoJAx are supposed to be good. Still don't know how many of these they've done or if I'm the first. I do plan on taking the tech on a test drive and I think they already cleaned it for me...I went by today to check in on them and show off my awesome YAris loaner. They said it was pretty much ready but they ran out of super coolant and were waiting on a fed-ex delivery. Said it should be ready in the morning. Thanks again guys. I'll have it broken in pretty quicky, a few weeks at most. Nice and easy for the next little bit....by the way, stupid question here.....do they reset the odometer? Like I said, I know it's a stupid question, but I was just wondering.
EVL1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 201 07-12-2014 07:54 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 10:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.