Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-13-2009, 04:53 AM   #1
Soukyoku
Scooby Newbie
 
Member#: 201492
Join Date: Jan 2009
Chapter/Region: MAIC
Location: Hampton, VA
Vehicle:
2003 Baja
Silver

Default My Baja is dying o me... :(

I don't drive a impreza but a 03 Baja... Hope yall can help me figure out whats wrong with my truck.

Two weeks ago my car got into serious jam. Took in water after driving through a foot and half high flood and an 18 wheeler drove past me so fast pushing water over my hood and the intake sucked in a lot water.

After 2 days of drying and cleaning. Car came back alive.... BUT began acting funny. Battery dying quick. Tested stock alternator and turn out to be bad and replaced it.

Seemed to work better BUT still experiencing random problem like I cant start it and had to have it jumped. Dashboard info (trip and clock) would reset to zero/random time. Headlights seem to struggle to have full power. Just like flashlight on weak battery.

Took it to Advance Auto and have them test it.... Everything passed including my battery.

Lately I've been unplugging gps from the 12v adapter... turning off head light (Including hand brake for DLR) before turning off the engine... Disabled celling light... So I wont have to ask around for jumps again...

I'm dumbfounded.. Help me anyone?
Soukyoku is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Computer is Dying! Is there software to fix it? Nightwing Off-Topic 17 10-08-2008 10:10 PM
My baja is scaring me 2003Baja Baja Forum 3 09-02-2005 01:24 PM
Gotta leave my baja behind for 4 weeks :( 2003Baja Baja Forum 3 07-26-2005 01:42 PM
My car just died on me, ***? Capt Crunch Mid Atlantic Impreza Club -- MAIC 19 07-08-2005 01:05 PM
Ok, my car keeps dying on me...what's up? Sauginius Southern California Impreza Club Forum -- SCIC 6 11-07-2000 12:01 AM


All times are GMT -4. The time now is 03:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.