Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-05-2009, 12:20 PM   #1
2.5rsDOHC
Scooby Newbie
 
Member#: 54820
Join Date: Feb 2004
Chapter/Region: South East
Location: western N.C.
Vehicle:
1998 2.4 RS-T
hybrid\stroker

Default 98rs which EMS should I run?

Im currently running E-manage ult but I believe this could be causing me my problems

I've posted on here about my problems in the past:
"ok so awhile back my car got to where it was running pretty rough and started to stall out for no apparent reason so after a lil bit of down time and after I installed an ewg I start it up and I notice its running extremely rich (even for my car) and I try to rev it up a bit but it wont rev over 3k and once it gets to 3k it all irratic like its about to stall and it deffinitly isnt drivable so I take it to a shop they run a compression check & leak down test both of which are negative, so they tell me the only thing left for them to do is pull the motor check the internals and sort through all the wiring, all of which is at an $80 per hour rate an I dont have that kind of $ to spend right now

so I asked them in your perfesional opinion what do you believe it to be and they said that its prob out of time due to a jumped timing belt if not they said it has to be in the wiring, so a $120 gates timing belt and a $160 tensioner later it runs exactly as it did before..."


So this is what I posted awhile back and nothing has changed since Im still thinking that this is a EMS issue considering everything else seems to be solid unless its a injector issue like has been mentioned to me in the past


If anynody has some imput go right on ahead but what Im looking for right now is suggestions for a EMS replacement, whats a good choice?
2.5rsDOHC is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which wheels should I buy/run? WRXLEP Texas Impreza Club Forum -- TXIC 6 11-30-2006 06:29 PM
Which Ems if money were not an issue? CFoD Engine Management & Tuning 4 11-13-2005 10:39 PM
High Low inpedance Injectors, Which EMS can do both? jared nelson Engine Management & Tuning 13 12-17-2004 10:02 AM
which EMS are absolutely compatible with 2005 wrx's VideoGameWrx Engine Management & Tuning 1 12-06-2004 08:12 PM
Which Ems To Use. dasubaruguy Factory 2.0L Turbo Powertrain 10 08-01-2002 10:57 PM


All times are GMT -4. The time now is 03:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.