Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-06-2010, 06:35 PM   #1
genkidama20
Scooby Newbie
 
Member#: 73635
Join Date: Nov 2004
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
04 WRX
WRB Wingless

Default A/C Compressor Squeaks and Stops

Ok, it's warming up in NC so I started using my A/C today. Well, turns out I'm having some issues.

The Problem
With air conditioning turned on, the vehicle chirps and loses power for a split second. This concerned me, so today after work, I took pictures and video to see if anyone could help me figure out what's going on.

At first I thought it was because my belts were lose. Since I had just replaced my worn belts with new Gates A/C and Alternator belts.

This video shows the belt with lots of vibration. Is that too loose? Should the belt not vibrate that much?


But then, as I was watching the belt, I noticed something. The part with the red arrow stops spinning, as if it gets stuck.


Here's a video of that part stopping (I think it's the A/C Compressor):



Is this bad? Is it something I can fix myself?



---------------------------

UPDATE
I'm a doofus. The compressor stops normally. LOL.

But, I did find out what was wrong. My A/C slider bolt bracket was broken. Thus, nothing was left to keep tension on the belt but the pulley. Need to buy a new bracket.

Part #24 in this picture... anyone know where to get it?
* Registered users of the site do not see these ads.

Last edited by genkidama20; 04-06-2010 at 08:14 PM.
genkidama20 is offline   Reply With Quote
Old 04-06-2010, 10:33 PM   #2
joec wrx
Scooby Newbie
 
Member#: 112359
Join Date: Apr 2006
Chapter/Region: BAIC
Location: Central Valley,CA
Default

I've ordered OEM parts from here a few times and never had any problems.

http://www.trademotion.com/partlocat...?siteid=214857
joec wrx is offline   Reply With Quote
Old 04-07-2010, 12:51 AM   #3
Dans Rex
Scooby Newbie
 
Member#: 227583
Join Date: Oct 2009
Chapter/Region: BAIC
Location: San Francisco Bay Area
Vehicle:
2002 WRX
PSM

Default

at my local dealer, when i replaced my accessory belts, i had to get the new #22 which included 23 and 24.

oh and I have used subarugenuineparts (dot) com, and use their OEM catalog

side note: it was crazy, i had the original from factory #22 which had worn and caused the belt to jump and grind into my timing cover so when replacing both belts, i had to buy the updated #22.
Dans Rex is offline   Reply With Quote
Old 04-07-2010, 01:40 AM   #4
txl146
Scooby Guru
 
Member#: 32459
Join Date: Feb 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX VF34
Junior Tuned 301whp

Default

A lot of people seem to be having similar issue - common fix is replacing #22-24.
txl146 is offline   Reply With Quote
Old 04-07-2010, 09:25 AM   #5
genkidama20
Scooby Newbie
 
Member#: 73635
Join Date: Nov 2004
Chapter/Region: South East
Location: Asheville, NC
Vehicle:
04 WRX
WRB Wingless

Default

I just bought #24 for now.

#22 was spinning perfectly fine. I probably should have bought it too. But, I will have to take a look at it again.

Last edited by genkidama20; 04-07-2010 at 09:55 AM.
genkidama20 is offline   Reply With Quote
Old 04-11-2011, 09:48 PM   #6
2002Dubx
Scooby Specialist
 
Member#: 177337
Join Date: Apr 2008
Chapter/Region: South East
Location: OT from 9-5
Vehicle:
2002 0<->0

Default

Sorry to bump an old thread, but I took a quick video of the sound. (Sorry for the crappy quality) All belts are newly installed by a local Subaru dealer as of a year ago. The whine started about a month ago and it seems to be getting slightly worse. A/C compressor, compressor bearings, idler pulley? Any conclusions???

- My a/c blows cold and hard.
- WD-40 has been tried

- A/C is blowing strong
- Like a supercharger sound with any acceleration


2002Dubx is offline   Reply With Quote
Old 04-15-2011, 08:19 PM   #7
2002Dubx
Scooby Specialist
 
Member#: 177337
Join Date: Apr 2008
Chapter/Region: South East
Location: OT from 9-5
Vehicle:
2002 0<->0

Default

Mine was the idler pulley. I took the idler pulley off and the belt so I will be without A/C for a couple of days, but it's better than the A/C compressor being the problem and costing way more.
2002Dubx is offline   Reply With Quote
Old 04-25-2011, 10:38 PM   #8
C_Wood
Scooby Newbie
 
Member#: 102234
Join Date: Dec 2005
Chapter/Region: MAIC
Location: Winchester
Vehicle:
03 WRX
WRB 16g

Default

Yep, sounds like the idler pulley. Mine did the same thing.
C_Wood is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ac Compressor squeaks at cold engine temps p8baller07 Service & Maintenance 1 07-25-2007 08:53 PM
A/C Compressor squeak ?? !! Number231 Factory 2.0L Turbo Powertrain 0 01-13-2007 01:05 PM
A/C compressor Squeak??? jaysant1 Factory 2.5L Turbo Powertrain 8 08-23-2006 11:37 AM
Calling the Mechanically Inclined: A/C Compressor Squeak. WRXedUSA Off-Topic 6 11-29-2004 09:27 PM
a/c compressor squeaks? TKRbeast Newbies & FAQs 4 03-21-2004 10:54 PM


All times are GMT -4. The time now is 01:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.