Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-10-2010, 03:20 PM   #1
pookdizzlehtk
Scooby Specialist
 
Member#: 172375
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Spring Valley CA
Vehicle:
2002 ewgVF30'dHybrid
World Rally Blue

Default 2.5L Hybrid Engine Issue

First of my mods are this.

VF30
Sti Pinks
Grimmspeed 38mm EWG kit (currently blocked off)
Grimmspeed EBCS
Grimmspeed AOS
STi TMIC
Stock downpipe on for Smog

Its a 2.5 wrx shortblock bored out for STi internals
OEM 2.5 Headgaskets
2.0 heads, ecu and the rest of the goodies.

My issue is that my idle sits at 1500 and then my CEL P1507 comes on and the revs drop to about 700.

I have changed out the throttlebody, front O2, and checked that the nuetral switch was working with a datalogger.

I am guess that because of the higher compression the idle is higher? What would I need to do to get this fixed? The car is currently unregistered due to it needing to be smogged and the CEL will NOT stay off and comes back 5 seconds after I clear it.

* Registered users of the site do not see these ads.
pookdizzlehtk is offline   Reply With Quote
Old 06-11-2010, 04:54 PM   #2
sense of nature
Scooby Guru
 
Member#: 112759
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: In the V hole!
Vehicle:
?? swapped Bugeye
SexyRP

Default

Try the built motor forms or the factory 2.5 factory turbo powertrain .. might get more replies
sense of nature is offline   Reply With Quote
Old 06-11-2010, 07:12 PM   #3
pookdizzlehtk
Scooby Specialist
 
Member#: 172375
Join Date: Feb 2008
Chapter/Region: SCIC
Location: Spring Valley CA
Vehicle:
2002 ewgVF30'dHybrid
World Rally Blue

Default

I'll try that thanks.
pookdizzlehtk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 WRX wagon 2.5L hybrid w/ Blouch 2.5R turbo triguy Proven Power Bragging 12 10-18-2008 03:09 PM
Subaru issues temporary stop sale on all vehicles equipped with 2.5L turbo engine studebakerdan General Community 7 04-07-2008 06:32 PM
Stock 2.0 ECU OK to run 2.5l hybrid? Cobb says so... Acostafan AccessPort 8 06-28-2007 05:45 PM
Who is using AP 2.0 for a 2.5l hybrid? Acostafan AccessPort 2 06-18-2007 03:14 PM
2.2l legacy engine and 2.5l RS engine jetfan8178 Service & Maintenance 10 04-02-2002 05:47 AM


All times are GMT -4. The time now is 03:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.