Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-12-2010, 09:27 PM   #1
BMXspears
Scooby Newbie
 
Member#: 79339
Join Date: Jan 2005
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2002 EJ257 swap WRX
Midnight Black

Default Problems after STi swap

I just swapped a 2006 EJ257 motor into my 02 WRX and am having what feels like a fuel cut when accelerating hard. I've done some research and it sounds like overboost.

I went with a 2004 ECU and wiring to ease wiring incompatibilities. It just occured to me that the ECU I have is expecting a VF39 turbo, while the 2006 motor has a VF43. Could this be causing my overboosting issues?

Even if not, seems like I'll be needing a custom tune. Can a dealer or tuner change my ECU to 06?
* Registered users of the site do not see these ads.
BMXspears is offline   Reply With Quote
Old 06-12-2010, 11:42 PM   #2
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

06 sti has the vf39,,, vf43 was 07
woodys77 is offline   Reply With Quote
Old 06-12-2010, 11:45 PM   #3
BMXspears
Scooby Newbie
 
Member#: 79339
Join Date: Jan 2005
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2002 EJ257 swap WRX
Midnight Black

Default

Quote:
Originally Posted by woodys77 View Post
06 sti has the vf39,,, vf43 was 07
Not according to the "all knowing" Unabomber...
BMXspears is offline   Reply With Quote
Old 06-13-2010, 09:23 PM   #4
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

you must be referring to this...... http://forums.nasioc.com/forums/show...ht=vf39+06+sti

Well have to have a talk with him on that

try this.....
http://forums.nasioc.com/forums/show...ight=turbo+faq

boost creep is common maybe a couple turns out on your wastegate arm might help.
woodys77 is offline   Reply With Quote
Old 06-13-2010, 11:30 PM   #5
BMXspears
Scooby Newbie
 
Member#: 79339
Join Date: Jan 2005
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2002 EJ257 swap WRX
Midnight Black

Default

Quote:
Originally Posted by woodys77 View Post
you must be referring to this...... http://forums.nasioc.com/forums/show...ht=vf39+06+sti

Well have to have a talk with him on that

try this.....
http://forums.nasioc.com/forums/show...ight=turbo+faq

boost creep is common maybe a couple turns out on your wastegate arm might help.
I see. Well that is a relief as I didn't want to deal with mismatched ecu's. I have a stock dp, catless midpipe (cheaper than repairing worn cat) and stock axle back. Could my catless midpipe be causing the problem?

If I did get a vf43 down the road, would that require a tune?
BMXspears is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems after ej257 swap blkwagon Subaru Conversions 0 11-25-2008 01:06 PM
Problems after GC Swap Jubert69 Newbies & FAQs 6 10-27-2008 09:15 PM
Problem after engine swap....HELP. bjpeppers Factory 2.0L Turbo Powertrain 5 11-05-2007 08:03 AM
Problem after turbo swap 04subyrex Factory 2.0L Turbo Powertrain 6 11-04-2007 11:20 AM
Emissions problem after motor swap jdmgc8 Subaru Conversions 15 09-25-2004 02:56 PM


All times are GMT -4. The time now is 08:04 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.