Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-05-2010, 10:05 PM   #1
choleaoum
Scooby Newbie
 
Member#: 255484
Join Date: Aug 2010
Chapter/Region: SCIC
Location: Long Beach, CA
Vehicle:
2010 EVO
2002 WRX

Default Wierd noise caused when MAF is plugged in..

Hey guys, just changed out my tgv gaskets, and intake manifold gaskets and now I put the manifold back on. It's making a WIERD clicking noise it sounds like its traveling along the manifold. I highly doubt theres a bolt inside the manifold because it would have bent the valve by now.. the throttle body is clean, tmic is clean.. turbo manifold was cleaned. Before I changed the manifold, I made sure to tape all the open holes shut.

Here's the noise, sorry if I was talking too much just aggrovated with the damn car.


Note: I have reason to believe that I have routed the vacuum lines wrong, can someone give me a diagram? The blow off valve seems to be blowing off into my intake? I'm not sure.. but the BOV wasn't going off. (the video might show it's unhooked, but it wasn't working still)


Symptoms: Bad idle, jumps from 800, 300, 1500, 2000 and etc. If I suddenly rev the engine around 5k and let off the gas, it will just shut off. There's fuel and stuff too, there are two hoses that aren't connected and they are on the throttle body, can anyone tell me where those would go?

Note: I also posted this in the Factory 2.0 section but I think I would find better help here.


UPDATE 10/6/2010: So I discovered that whenever I plug the MAF in it sounds like the throttle body clicks? I think it's the butterfly valve shuttering or something I'm not even sure. The idle stays stable when the MAF is disconnected, but drops and dies when i plug it back in. I tried cleaning it, no go.

Last edited by choleaoum; 10-07-2010 at 02:00 AM.
choleaoum is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me ID this new weird new noise during acceleration. jay25RS Transmission (AT/MT) & Driveline 11 03-02-2008 09:19 PM
Anyone wanna help me troubleshoot this clicking noise tomorrow? wrxfactor New England Impreza Club Forum -- NESIC 1 07-16-2006 11:27 AM
ok im sick of this noise, please somebody help me figure this out. BoneStock03 Transmission (AT/MT) & Driveline 2 06-19-2006 02:23 PM
Help me subscribe this ASS to junk mail RacerinLSL Off-Topic 18 09-17-2002 02:02 PM
Am I just an ass? Help me figure this out. Porter South East Region Forum 36 03-20-2002 07:52 PM


All times are GMT -4. The time now is 11:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.