Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-10-2010, 06:35 PM   #1
Chocolates
Scooby Newbie
 
Member#: 212363
Join Date: May 2009
Chapter/Region: NWIC
Location: B'ham
Vehicle:
2003 Impreza 2.5TS
4eat

Default Two leaks: oil and coolant

Hey all-

Finished moving half way across the country, and decided to check on my car to see what needed help before winter comes. 2003 2.5TS.

My first concern (especially after reading up on the failure rate of head gaskets) is the coolant that is leaking. In two places, both by the inlet and outlet of the block. I'm hoping it's just bad hoses, but I shot some pics for reference. My coolant overflow tank is pretty low as well, but I don't see any coolant in the oil or vise versa.

I'm planning to replace the hoses, t-stat, and flush everything and add the subaru "conditioner". Just wondering if it's too late at this point.

Top hose, leaking onto cover below


Bottom hose


The other issues are a couple oil leaks.

Drivers sive half shaft. Boot itself does not appear to be ripped, but the green part is covered in oil. Could this be a seal gone bad?


And upon closer inspection, there is oil of some sort on the passenger side as well


Third, this is a shot of some gunk at the bottom of everything. Any ideas?


Thank you for any help.
Chocolates is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil and coolant lines Chi_San Service & Maintenance 1 08-23-2008 11:13 PM
used vf30 without oil and coolant lines - can i use stock lines? anthonyrb98 Factory 2.0L Turbo Powertrain 2 10-09-2004 10:17 PM
oil and coolant lines scoobyimprza Factory 2.0L Turbo Powertrain 3 07-25-2003 12:01 PM
Turbo missing oil and coolant feed lines? S-1 Factory 2.0L Turbo Powertrain 4 01-04-2003 06:12 PM
Engine is eating Oil and Coolant but not leaking... Need4Boost Factory 2.0L Turbo Powertrain 28 12-12-2002 12:57 PM


All times are GMT -4. The time now is 07:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.