Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-09-2010, 11:07 PM   #11
David920
Scooby Newbie
 
Member#: 168092
Join Date: Jan 2008
Chapter/Region: NWIC
Location: Washington
Vehicle:
2011 WRX 5-Door Prm
Obsidian Black

Default

Quote:
Originally Posted by 09rexwagon View Post
Mine usually does it more in the winter. The dealership replaced the cruise control clutch switch twice. That seemed to fix it but it always came back. I've given up.

FYI, there is someone who posted that they had this issue and the dealership replaced the clutch master cylinder and it never happened again. Who knows.

I agree with Irish....its only normal in the sense that tons of cars do it and the dealerships can't ever figure it out and it doesn't hamper functionality of the clutch etc. I just chalk it up to "it's what makes a Subaru a Subaru" .
Just got a call from service and they are replacing the clutch master cylinder (as you noted on your post). It should be ready Thurs evening. Hoping that fixes it as well.
David920 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch pedal clicking noise GeLLo_Boi Newbies & FAQs 6 03-01-2008 09:37 PM
Clutch making clicking / ticking type noise t3ch9 Transmission (AT/MT) & Driveline 2 05-25-2006 03:25 PM
Clutch making a clicking noise popnfresh Transmission (AT/MT) & Driveline 0 06-10-2005 02:28 PM
Weird clicking noise when I put in first and let go of clutch m u f a s i s Transmission (AT/MT) & Driveline 22 02-20-2004 02:06 PM
Click noise when releasing clutch? NicGordon Transmission (AT/MT) & Driveline 0 10-24-2002 01:07 AM


All times are GMT -4. The time now is 10:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.