Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-09-2011, 12:53 AM   #1
rallyvovo
Scooby Newbie
 
Member#: 167738
Join Date: Dec 2007
Default Clutch Issue - Help!

I believe my throwout bearing has been making noise - a little rattle with clutch out and then silence when in. Also, the other day the little clutch pedal helper spring broke (dont know that this is related)

Tonight I go to drive and it is VERY hard to select gears. They go but with some force, more than normal. Then comes a point where the car acts as if the clutch is engaged when the pedal is pressed. Turn car off. 15min later i go to hobble home in ghetto mode and start it in reverse and some gas. Then when i put clutch in to select 1st it seems like its back to fine. Drives home as it did before problem arose.

Once at home it did seem a little hard to select the gears again. Obviously there is an issue, but why would it go away briefly?
rallyvovo is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with clutch issues notraceready Transmission (AT/MT) & Driveline 8 04-24-2008 12:34 AM
Need help with clutch issues notraceready Transmission (AT/MT) & Driveline 0 03-26-2008 08:46 AM
clutch engagement issue...help quick please 6lug Transmission (AT/MT) & Driveline 1 11-13-2006 04:20 AM
Help! Clutch issues on a 285hp 2003 WRX Balantz Transmission (AT/MT) & Driveline 24 12-25-2005 08:00 AM
HELP!!! more clutch issues...soooo mad! IMPREZAmike New England Impreza Club Forum -- NESIC 1 01-15-2001 12:58 AM


All times are GMT -4. The time now is 12:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.