Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-15-2011, 02:02 AM   #1
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default Getting rid of CEL P0519

I just bought a swapped 2000 rs coupe. The only thing that is stopping me from passing inspection is the cel code P0519, it doesnt come up when your scanning the car with just a regular obd 2 scan tool but as soon as it gets plugged in to the emissions computer it pulls this code and stops me from passing. If you have any questions about the car just ask, I just barely bought it so I am still figuring things out about it. Its on utec on a stage 2 map. I need to get rid of this code so I can pass.
* Registered users of the site do not see these ads.
Tglazed is offline   Reply With Quote
Old 02-15-2011, 02:03 AM   #2
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

O and I have been told a couple things from people. I was told I need to adjust the idler on the utec with a laptop. Anyone know anything about this?
Tglazed is offline   Reply With Quote
Old 02-15-2011, 09:18 AM   #3
medamullet
Scooby Guru
 
Member#: 99442
Join Date: Oct 2005
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2006 SGM STI
I'm on CORN YO!

Default

I found this, i guess it's as good as any place to start trouble shooting

Quote:
DTC P0519 - IDLE CONTROL SYSTEM MALFUNCTION (FAIL-SAFE)

DTC DETECTING CONDITION:
Immediately at fault recognition

TROUBLE SYMPTOM:
Engine keeps running at higher revolution than specified idling revolution.

--------------------------------------------------------

Here are the steps if you want to do the step-by-step inspection yourself before taking it in. If you recently changed your air filter, check your air box and see if it is seated correctly. It can be that easy or adjustment of throttle cable, loose or cracked vacuum lines, cracked gaskets or worst - idle air control solenoid.

1. Check for loose installation of intake manifold - particularly the unit that house the air filter

2. Check for cracks on intake manifold

3. Check for cracks on gasket of throttle body

4. Check for cracks on gasket of idle air control solenoid valve

5. Any vacuum hose disconnected or leaking?

6. Check throttle body cable for excessive play

7. Check the bypass air line for foreign particles that can clogged the system
medamullet is offline   Reply With Quote
Old 02-15-2011, 09:56 AM   #4
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

I would go into your factory ECU and turn off that code just for a temporary fix until you get that problem fixed.

Surprised to see somebody using the UTEC, Didn't know that still existed. Ever thought about ditching it and going open source? It would be a lot easier.
bhhamblin is offline   Reply With Quote
Old 02-15-2011, 11:27 AM   #5
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Open Source FTW!!!!
Mush04 is offline   Reply With Quote
Old 02-15-2011, 11:50 AM   #6
aclver1
Scooby Specialist
 
Member#: 114177
Join Date: May 2006
Chapter/Region: RMIC
Location: SLC utah
Vehicle:
2004 Impreza 2.5rs
70 Datsun Fairlady

Default

I just got that code on sunday so i've been researching it. I found that it sometimes can be your nutral position sensor freaking out and sending the wrong voltage to the ecu making it think it's in gear or out when it's not so it's trying to adjust the idle. If you have a good scan tool plug it and and move your shifter back and forth but not into gear. The scan tool will show it going in and out of gear even though it's not in gear.
aclver1 is offline   Reply With Quote
Old 02-15-2011, 12:45 PM   #7
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

Well I bought the car with utec. Personally I like open source I had my 06 done by logan. How can I go into my ecu to turn off that code just as a temporary fix? So I can get my car to pass emissions. Its not on when I drive or idle or anything, only when it gets plug into the obd 2 thing for emissions.
Tglazed is offline   Reply With Quote
Old 02-15-2011, 02:24 PM   #8
subtech02
Scooby Newbie
 
Member#: 215613
Join Date: Jun 2009
Default

two things! one do you use the trans to slow you down on off ramps or whenever. two its an issue with the nuetral position switch on the side of the trans depending on the components in the swap. delete the code
subtech02 is offline   Reply With Quote
Old 02-15-2011, 02:28 PM   #9
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

Yes I downshift, should I not? How do i delete the code, can someone tell me how or help me do it.
Tglazed is offline   Reply With Quote
Old 02-15-2011, 02:53 PM   #10
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

I would assume someone with an open source type thing could delete it, but I have been told if you use the motor to slow down it just wears your clutch and everything out quicker, I would rather replace brake pads myself haha but I will say that I still do it from time to time.
Mush04 is offline   Reply With Quote
Old 02-15-2011, 05:25 PM   #11
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

Anyone close local that could come delete it for me. I could drive to you.
Tglazed is offline   Reply With Quote
Old 02-15-2011, 05:32 PM   #12
aclver1
Scooby Specialist
 
Member#: 114177
Join Date: May 2006
Chapter/Region: RMIC
Location: SLC utah
Vehicle:
2004 Impreza 2.5rs
70 Datsun Fairlady

Default

are you just trying to delete it or mask the code and keep it from showing up? you can just disconnect your battery to delete it but if there really is a problem it will come back, also that will set all your I/M stuff to NOT READY. Do you have a code reader?
aclver1 is offline   Reply With Quote
Old 02-15-2011, 05:37 PM   #13
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

Ya I have been borrowing my friends code reader. There was no check engine light though. Also, when you plug in a code reader it will come up clear but the emissions computer pulls the code, thats how I figured out I had it.
Tglazed is offline   Reply With Quote
Old 02-15-2011, 05:51 PM   #14
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

I couldn't pass for awhile either this last year and I just had Jason "make" it clear haha that's why I love open source haha, do like Brody said and ditch the utec and go OS! but I'm sure there are ways to get yours to pass too GL
Mush04 is offline   Reply With Quote
Old 02-15-2011, 06:24 PM   #15
aclver1
Scooby Specialist
 
Member#: 114177
Join Date: May 2006
Chapter/Region: RMIC
Location: SLC utah
Vehicle:
2004 Impreza 2.5rs
70 Datsun Fairlady

Default

I didn't think a pending code would keep you from passing emissions. I would just get someone /Medamullet to do an open source tune for you and have them turn off that trouble code. I wish i had the option, instead if have to actually fix codes and run a piggyback controller for my tuning. Open source is nice.
aclver1 is offline   Reply With Quote
Old 02-15-2011, 07:08 PM   #16
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

is there no open source for N/A car's? I figured you could haha
Mush04 is offline   Reply With Quote
Old 02-15-2011, 07:53 PM   #17
Tglazed
Scooby Newbie
 
Member#: 231216
Join Date: Nov 2009
Chapter/Region: RMIC
Location: South Jordan, Utah
Default

Just passed. just deleted the code, drove exactly 50 miles, and took it in and it passed. I was so happy haha
Tglazed is offline   Reply With Quote
Old 02-16-2011, 12:39 PM   #18
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

well that's a good thing!! no more tickets!!
Mush04 is offline   Reply With Quote
Old 02-16-2011, 02:19 PM   #19
medamullet
Scooby Guru
 
Member#: 99442
Join Date: Oct 2005
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2006 SGM STI
I'm on CORN YO!

Default

Quote:
Originally Posted by aclver1 View Post
are you just trying to delete it or mask the code and keep it from showing up? you can just disconnect your battery to delete it but if there really is a problem it will come back, also that will set all your I/M stuff to NOT READY. Do you have a code reader?
Did you get yours to pass?
medamullet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help getting rid of CEL ToxicCrucible Newbies & FAQs 9 01-05-2011 03:14 PM
no cat. how get rid of cel 2.5racer Normally Aspirated Powertrain 3 08-10-2002 07:58 PM
How do you reset the ECU to get rid of a CEL? Jasno999 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 05-19-2002 01:54 PM
So what is the best way to get rid of those damned Cats without triggering CEL? IncubusDude Newbies & FAQs 9 04-18-2002 02:11 PM
does someone in Ventura county has obd2 reader to get rid of my CEL? scoobypuff Southern California Impreza Club Forum -- SCIC 8 03-19-2002 05:02 PM


All times are GMT -4. The time now is 01:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.