Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-01-2011, 05:13 PM   #376
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
06 R1 50th Anniv.

Default

Like i said plans changed. Gonna go back to stock header with aftermarket up-pipe. Not gonna be drag racing much anymore so i dont need the higher rpm flow. I lost a little spool and low end grunt when i went with the header. A little quicker spool will work for the few autoX and rally cross events i will be about to get permission to go to. lol Hell if someone offered me a good price and TMIC i would trade the FMIC.
* Registered users of the site do not see these ads.
Brando5185 is offline   Reply With Quote
Old 02-01-2011, 05:24 PM   #377
tribalwrx
Scooby Specialist
 
Member#: 32993
Join Date: Feb 2003
Chapter/Region: AKIC
Location: anchorage,alaska
Vehicle:
vf39 Best trap 110
Best ET 12.51 Dale tuned

Default

HOW MUCH?


just askin at the moment
tribalwrx is offline   Reply With Quote
Old 02-01-2011, 05:26 PM   #378
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
06 R1 50th Anniv.

Default

For the FMIC? shoot me pm
Brando5185 is offline   Reply With Quote
Old 02-01-2011, 05:41 PM   #379
retrac
Scooby Specialist
 
Member#: 217208
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Alaska
Vehicle:
996 Porsche 911
Seal Gray

Default

Quote:
Originally Posted by tribalwrx View Post
i think Trox still has a invidia divorced downpipe for sale
I snapped that one up.
retrac is offline   Reply With Quote
Old 02-01-2011, 05:51 PM   #380
tribalwrx
Scooby Specialist
 
Member#: 32993
Join Date: Feb 2003
Chapter/Region: AKIC
Location: anchorage,alaska
Vehicle:
vf39 Best trap 110
Best ET 12.51 Dale tuned

Default

Quote:
Originally Posted by retrac View Post
I snapped that one up.


ah ok i wasn't sure if that one was taken or not,
tribalwrx is offline   Reply With Quote
Old 02-01-2011, 07:50 PM   #381
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

The stock boost control solenoid may work with a restrictor pill and with some wastegate adjustment. I'm not 100% positive until I try it on your car.

Worst case scenario we use a 3 port after market solenoid(runs around $80 or less). It is also possible your existing aftermarket solenoid can be wired and used with the stock ECU. Most boost solenoids are the same two wire setups.


Quote:
Originally Posted by Brando5185 View Post
Ok i still have the stock boost controller mounted just need to plug it an and route the hoses. But i would need a retune to let the ecu control the boost correct? Is the stock unit able to handle 21+ psi on the 20G?
P3Auto is offline   Reply With Quote
Old 02-01-2011, 07:53 PM   #382
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

@Brando,
I will have a car this year I would like to have you run on the track. I need a good driver to hit the times we want. So if you can get permission to go to the track once or twice this year I would really appreciate it. Sorry to hear your car is going back to stock. I know how it goes, I have four kids myself...lol
P3Auto is offline   Reply With Quote
Old 02-01-2011, 09:10 PM   #383
retrac
Scooby Specialist
 
Member#: 217208
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Alaska
Vehicle:
996 Porsche 911
Seal Gray

Default

Quote:
Originally Posted by Brando5185 View Post
Like i said plans changed. Gonna go back to stock header with aftermarket up-pipe. Not gonna be drag racing much anymore so i dont need the higher rpm flow. I lost a little spool and low end grunt when i went with the header. A little quicker spool will work for the few autoX and rally cross events i will be about to get permission to go to. lol Hell if someone offered me a good price and TMIC i would trade the FMIC.
Sounds like you need a sleeper Legacy instead of an STi...
retrac is offline   Reply With Quote
Old 02-02-2011, 11:56 AM   #384
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
06 R1 50th Anniv.

Default

Quote:
Originally Posted by P3Auto View Post
@Brando,
I will have a car this year I would like to have you run on the track. I need a good driver to hit the times we want. So if you can get permission to go to the track once or twice this year I would really appreciate it. Sorry to hear your car is going back to stock. I know how it goes, I have four kids myself...lol
I am sure getting a couple of track days shouldnt be too hard. Just let me know. Car isnt gonna go back to stock. Just go a little milder then it sits now.
Brando5185 is offline   Reply With Quote
Old 02-04-2011, 09:27 PM   #385
kjoons
Scooby Newbie
 
Member#: 272937
Join Date: Feb 2011
Chapter/Region: AKIC
Location: AK/EAFB and NorCal.
Vehicle:
2002 2.5 RS
Silver

Default

i have a feeling i'll be asking you a lot of questions regarding to modifications. but first i have to make a purchase. lol.
kjoons is offline   Reply With Quote
Old 02-06-2011, 04:25 PM   #386
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
06 R1 50th Anniv.

Default

Which aftermatket EBC do you recommend? Would i need restrictor pill with those?
Brando5185 is offline   Reply With Quote
Old 02-10-2011, 01:33 PM   #387
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

Sorry for late response. Grimmspeed 3-port works great and you use it in whats called "interupt" style so you need no pills.
P3Auto is offline   Reply With Quote
Old 02-17-2011, 03:08 AM   #388
Brando5185
Scooby Specialist
 
Member#: 189926
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Goldsboro,NC
Vehicle:
HEMI Jeep GC
06 R1 50th Anniv.

Default

Would a grimmspeed EBCS or MBC work better?
Brando5185 is offline   Reply With Quote
Old 02-17-2011, 01:27 PM   #389
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

EBCS.

Quote:
Originally Posted by Brando5185 View Post
Would a grimmspeed EBCS or MBC work better?
P3Auto is offline   Reply With Quote
Old 02-17-2011, 02:17 PM   #390
06gtleg
Scooby Specialist
 
Member#: 197928
Join Date: Dec 2008
Chapter/Region: AKIC
Location: anchorage
Vehicle:
95 Outback
Green

Default

Quote:
Originally Posted by Brando5185 View Post
Would a grimmspeed EBCS or MBC work better?

Here is a thread you should read.

http://forums.nasioc.com/forums/show....php?t=2135421
06gtleg is offline   Reply With Quote
Old 02-17-2011, 03:05 PM   #391
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

I'm going to have to disagree with the statements about boost spool increase using an MBC. If you experience that then the EBC wasn't tuned or plumbed correctly to start.

Spool time is not ever a function of the boost control solenoid. The only exception is rare and I have not seen it work with most Subaru applications. The exception is cracking the wastegate a small amount prior to onset of boost which can help, again this is rare.

Simplified answer...The waste gate should remain closed until the onset of desired boost or at least very close to it. This means that the waste gate solenoid is effectively out of the picture until boost target is close. Claiming a boost solenoid can speed up spool times makes no sense. If there is a resulting effect it was because of plumbing or tuning of the original setup causing the lag.

Spool time may change depending on how you plumb your solenoid (manual or electronic). Two basic options bleed style (stock way) and interupt style. Interupt style is much faster to respond and doesn't bleed air off exactly so less loss. There are other methods as well but the top two are the main ones used with our cars.
P3Auto is offline   Reply With Quote
Old 02-28-2011, 01:34 PM   #392
jonmorris555
Scooby Newbie
 
Member#: 267974
Join Date: Dec 2010
Chapter/Region: South East
Location: TN
Vehicle:
2008 Legacy 2.5i
OBP

Default

Just added oil to my engine a week ago, when i took off the engine cap I heard a loud noise like a great amount of pressure escaping from somewhere. When i got in my car to drive it, I noticed a loud whistle sound when i accelerate, is this a boost leak and why would adding oil to the engine cause it?
jonmorris555 is offline   Reply With Quote
Old 02-28-2011, 05:41 PM   #393
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

If you took the oil cap off while the engine is running then yes there is crank case pressures. This is normal and this is why there are 3 or more crank case and valve cover vents.

The loud whistle could be a lot of things. Turbo going bad, air filter issue, boost leak, etc.

I doubt it is related to the oil cap unless you left off or forgot the rubber oring around the cap, even that would not cause and loud whistle I think.
P3Auto is offline   Reply With Quote
Old 03-02-2011, 10:53 AM   #394
jonmorris555
Scooby Newbie
 
Member#: 267974
Join Date: Dec 2010
Chapter/Region: South East
Location: TN
Vehicle:
2008 Legacy 2.5i
OBP

Default

Quote:
Originally Posted by P3Auto View Post
If you took the oil cap off while the engine is running then yes there is crank case pressures. This is normal and this is why there are 3 or more crank case and valve cover vents.

The loud whistle could be a lot of things. Turbo going bad, air filter issue, boost leak, etc.

I doubt it is related to the oil cap unless you left off or forgot the rubber oring around the cap, even that would not cause and loud whistle I think.
No, I let the engine cool down before i took off the cap, I took it to my local subaru dealership and they said it was a leak but have been unable to find it so far.
jonmorris555 is offline   Reply With Quote
Old 03-07-2011, 03:00 AM   #395
kayetealynn
Scooby Specialist
 
Member#: 253304
Join Date: Jul 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2001 Impreza 2.5RS
Plus MOAR

Default

Okay subaru techies - I need brainstorming ideas on a misfire issue..

Car - 2001 2.5RS
Codes: p0136, p0303, p0302

Stock drive train. As some of you know, bought the car in WA last month.

When I was down there I had a local shop do a 30k servicing which included spark plugs.

Compression check was good when I bought the car.

Heads were rebuilt approximately 10k miles ago, and the injectors have also been replaced.

First misfire code on cylinder 3 happened north of seattle after pulling in a gas station. Drove the car all the way through Canada with no more misfires, and since getting back it has thrown two more misfire codes on cylinders 2 and 3.

No power loss or hesitation during driving, but I have noticed that after warming up if it sits idling for awhile it tends to idle on the rough side - I think this is where it is misfiring.

I was thinking about trying spark plugs and coils/wires next - any other ideas or thoughts about what it could be?
kayetealynn is offline   Reply With Quote
Old 03-07-2011, 03:10 AM   #396
P3Auto
NASIOC Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

Plugs and wires would be a good step..Check fuel pressure at idle. Think simple first.
P3Auto is offline   Reply With Quote
Old 03-13-2011, 03:20 AM   #397
kayetealynn
Scooby Specialist
 
Member#: 253304
Join Date: Jul 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2001 Impreza 2.5RS
Plus MOAR

Default

Quote:
Originally Posted by P3Auto
Plugs and wires would be a good step..Check fuel pressure at idle. Think simple first.
Okay - now it overheated today at idle..

Fans aren't running.

Stop acting up Buck!
kayetealynn is offline   Reply With Quote
Old 03-13-2011, 03:51 AM   #398
Carter
Scooby Specialist
 
Member#: 156708
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Palmer, AK
Vehicle:
2004 Mini Cooper S
Invader 125 Shifter Kart

Default

Check your grounds! I replaced my fuel pump, fuel filter, plugs, plug wires, and miscellaneous other things in search of a cure for my misfires and CL/OL hesitation. It was a loose ground on the frame by the battery! Bolted it back up, and problem solved!

At least I got new stuff out of it.
Carter is offline   Reply With Quote
Old 03-13-2011, 07:44 AM   #399
kayetealynn
Scooby Specialist
 
Member#: 253304
Join Date: Jul 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2001 Impreza 2.5RS
Plus MOAR

Default

Misfire issue was fixed. Bad injector connection.

It is possible that there is something wrong with the grounding - because the fuel gauge is acting up too. One minute full - the next minute it is showing empty with the gas light on. Plus - apparently there was an issue with the keyless entry constantly locking/unlocking indefinitely when within 5 feet of the previous owners garage. All I know right now is that the car has balls and I like driving it. It's extremely difficult for me to do anything by myself because I have neither the tools, space, or experience to do anything outside what I learned in my basic auto class. I guess this car is going to give me a run for my money in the learning department. Thanks Buck.

BTW Carter - stop messing with my car in the parking lot! I don't notice until I'm already driving and I hate pulling over in the freezing cold and fixing whatever you decided to displace.

I know what you drive too ya know!

Last edited by kayetealynn; 03-13-2011 at 10:10 AM.
kayetealynn is offline   Reply With Quote
Old 04-05-2011, 12:26 AM   #400
newtothescene
Scooby Specialist
 
Member#: 222368
Join Date: Sep 2009
Chapter/Region: VIC
Location: Tri-Cities
Vehicle:
2006 Cone Dodger
CGM

Default Help with logs

Pleassssse help me with my log. Just did a log - do you see any issues? I see there is some neg feedback knock correction.

Car: 2006 WRX, Cobb catted DP, STI catback. All other parts are stock.

Cheers and thanks!!

https://spreadsheets.google.com/ccc?...thkey=CLm36poG
newtothescene is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tuner FAQ: How to pick one, what to ask of them, and how to prepare for a tune Unabomber Engine Management & Tuning 12 05-05-2014 05:18 PM
Bend, Oregon Tuners Carartist North West Impreza Club Forum -- NWIC 52 10-05-2010 10:07 PM
Tuner is asking me what compression I am using. Ryan314 Built Motor Discussion 7 04-24-2010 05:44 PM
('93-'01) sorry to ask if asked, how do u search ? christurismohk Impreza Forum 1 06-07-2001 10:11 PM


All times are GMT -4. The time now is 04:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.