Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-16-2011, 10:05 PM   #1
RoninSTI
Scooby Specialist
 
Member#: 49278
Join Date: Nov 2003
Chapter/Region: NESIC
Location: New England
Vehicle:
11 STI
SWP

Default Fixing the GR 2400-3000rpm stumble with Accessport

DISCLAIMER: This is not a "how-to", this is documentation on how I used information on the interwebs to solve the 2400-3000 rpm low load acceleration stumble on my 2011 STI. YOU are responsible for any changes you make to your maps.

The issue:
The GR stumble is an issue that is not detrimental to the car, just annoying to deal with. It happened to me just about everyday when driving normally. Under light load, partial throttle (at about 2800 rpm) the car would hiccup or stumble for a moment. After doing tons of searches on here, IWSTI and Rom raider, I took existing information and eliminated the stumble on my car. The result is beautifully smooth, low rpm, partial throttle acceleration.

Reference material:

I read, and re-read every post in the following threads...

http://www.iwsti.com/forums/ecu-tuni...-using-ap.html
http://www.romraider.com/forum/viewt...ff6e4726adba13

Tools Required:
1) The spreadsheet located here
http://www.romraider.com/forum/viewt...hp?f=32&t=5483

2)Cobb Accessport
3)Windows Based Excel (I used Excel 2007 on a virtualized version of windows XP on a mac)
4)Basic excel data manipulation abilities
5)Accesstuner Race (free download from cobb's website)
6)Ability to Datalog using Accessport

The Datalog:

I logged the following parameters:
A/F Correction 1
A/F Learning 1
A/F Sens 1 Ratio
Boost
MAF Voltage
RPM
Throttle Position

Also the "live" parameter I made note of while logging was the barometric pressure. I need that number for the spreadsheet. I logged for at least an hour or so of highway driving. I went through most of the rpm range from 2000-4000 in 4th, 5th, and 6th. I dwelled for a while at each rpm for each gear. I spent a couple minutes around 55mph, 60mph and so on. I needed enough data points for the spreadsheet to get enough of a sample to size to make the averages.

Data Manipulation:

1) Once I had my log, I renamed the headers of each column to EXACTLY the same as the spreadsheet. I saved in csv format.
2) I opened the romraider spreadsheet, made sure I enabled macros, and clicked "clear and get data". I located my modified header csv file. I entered the barometric pressure into the box. (for me 14.5 psi).

This is where it gets a bit complicated, but once I was in the files it made sense...

3) I opened my Stage 1 OTS map from cobb (Stage 1 93 octane boost select). I opened the sensor calibration folder and opened the table labeled "load compensation (cruise)"
4) I copied the first row (the headers) and copied into a blank spreadsheet. I then made the following conversion to each number. Note the header title is a pressure in BAR. I called the header number X. The barometric pressure I logged was Y. The conversion is: (X*Y)-Y. The conversion makes a new row of headers. I copied that row as new headers into the tab labeled "ROM". The ROM tab is just used for the pivot table. Now the pivot table that the spread sheet generates matches the numbers in my cobb table.
5) I went back to the input tab and clicked filter. After the calculation was complete, the pivot table generated is on the EL comp tab. Its the top table labeled average correction.
6) notice the pivot table is full of bold, grey and empty cells. The empty cells had no data, the gray cells didn't have enough samples for an average, and the bold cells are valid data. I didn't worry that not all the cells had data, most did, I think it might be next to impossible to get data for EVERY cell.
7) I copied the entire load comp cruise table into a new spreadsheet, rpm titles and headers included.
8)Next to it on the same spreadsheet, I copied the pivot table, I made sure to line up the pivot table on the appropriate rpm row. The pivot table doesn't have data for every corresponding cell on the cobb table. It's only concerned with a certain portion of the table. So I made the pivot table equal in rows and columns as the cobb map, i simply made every empty cell 0, and every cell with a gray number 0.
9)So now i had two tables, with the same headers and row labels, the exact same size, side by side. One table is the table from the cobb map, one table is the pivot table with a bunch of zeros added to make it the same size as the cobb table.
10) I made a third table under the cobb table, same headers and rpm labels. I made the first cell equal to the value of the first cell on the cobb table PLUS the value of the first cell from the pivot table. I then dragged the formula across the row, then down the columns. (please reference excel for dummies lol).
11) I copied the new table into access tuner race (values only).
12) I Repeated the process for the accel table. (get the new headers, do the conversion, paste new values into ROM table, filter data, get new pivot table, add pivot table to existing map, paste new map into access tuner).
13) I saved the map with a new name
14) I flashed the new map, went for a cruise and voila! NO STUMBLE.

I think this may be an iterative process, I may perform all these steps again to see if anything changes, or just datalog again and look at the graphs in the spreadsheet to ensure there are no outliers anymore.

Hopefully this documentation will help others diagnose and fix the same issue on their car. FYI, this was the first time I changed any of the tables in access tuner and it couldn't have been easier.

I'm still re-reading the reference material to determine exactly why this eliminates the stumble.

RoninSTI is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did you pass OBD-II test with Accessport stage 2 and upipe resistor fix? MO REX Engine Management & Tuning 4 11-24-2004 07:12 PM
Are fixes required with AccessPORT REX Tuner Engine Management & Tuning 5 04-06-2004 09:14 AM
Stumbling with ECUtek Part 2 wRxbeater11 Engine Management & Tuning 1 03-27-2003 05:25 PM
Stumbling with ECUtek wRxbeater11 Engine Management & Tuning 16 03-23-2003 03:17 AM
Anyone with Borla header and CEL, did the ECU recall fix the CEL? Suba_Roo Normally Aspirated Powertrain 14 01-25-2003 12:53 AM


All times are GMT -4. The time now is 05:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.