Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-17-2011, 04:06 PM   #1
rbriggs2
Scooby Newbie
 
Member#: 242678
Join Date: Mar 2010
Chapter/Region: South East
Vehicle:
2005 Legacy
Pearl White

Default HELP!!! Low Idle 05 Legacy 2.5i

So I have had my Legacy for about 3 years now and it has run fine up until about 6 months ago when the CEL came on. I took it to Autozone and they ran the computer and said the airflow sensor was out. I bought a new airflow sensor took it to a local car place and they replaced it. When I got it back from them, the idle was running way low and every time I come to a stop the idle chugs down almost to zero (doesn't stall but gets close) and then goes back up and continues the process until I start accelerating again. I have noticed that other year Subarus get the IACV gunked up and it can be helped by cleaning could this be my problem?
rbriggs2 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Legacy 2.5i Subaaaru Member's Car Gallery 2 03-03-2007 06:43 PM
05 Legacy 2.5i Notyab Private 'Wanted' Classifieds 0 08-11-2006 10:03 PM
Rotor help 05 Legacy 2.5i Fabius Brakes, Steering & Suspension 1 10-12-2005 01:41 PM
Just got an 05 legacy 2.5i (bl) XanTium Legacy Forum 1 04-03-2005 04:10 AM
05 Legacy 2.5i Review Diabolical1 CC News & Rumors 6 10-27-2004 01:42 PM


All times are GMT -4. The time now is 01:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.