Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-25-2011, 05:52 PM   #11
smeerone
Scooby Specialist
 
Member#: 249068
Join Date: Jun 2010
Chapter/Region: South East
Location: Miami, Fl.
Vehicle:
2010 WRX
DGM Phatbotti Tuned

Default

Quote:
Originally Posted by jockeygolfs
Time has come! Engine is dead. Even on a conservative map. i was running at 21.5 PSI max. My mechanic says 19 is the max on OEM pistons. Currently waiting to be towed. I'm in the middle of nowhere. Just south of the city of Okeechobee in FL. Car was sounding awesome and then sputtering. The car was making weird sounds like playing cards in bike spokes.

So I pulled off the road and called Gustavo at TAV racing. He told me to check the oil. It is all gone. The oil light would come on when I pumped the clutch but then disappear. The oil temp reached 240. The car is going to be towed to the dealership but I have a feeling I will be screwed on the warranty, obviously.

The wife is going to go ballistic when she finds out warranty is gone lol.

Already have a quote to ship the car down to TAV. $175. Not bad. Build motor will be $400 by Bertune. $1500 to install. Hopefully no hang ups and we should be good. I am still missing a timing belt, head studs, gaskets and bearings though so that should all add up to about $800. So roughly $3000 total.
What!!!!! Sorry man.
smeerone is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forged Performance: 2011 STi Sedan MONSTER Build **check back often** Forged Performance NASIOC Project Cars 456 08-10-2014 11:46 PM
Will it fit: 2011 STi Sedan exhaust on 2010 WRX Sedan btr22 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 38 04-21-2014 04:11 PM
Fast Motorsports Prototype 08+ wrx sedan and 2011+ sti sedan catback! first pics! IMPORTIMAGE Vendor Announcements 4 05-02-2011 10:50 PM
Comparing 2011 STi Sedan to 2011 WRX Sedan DasWRX Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 12-21-2010 08:09 AM
new with a question about 2011 STI sedan vs. previous STI sedans tommygsubie Newbies & FAQs 37 11-02-2010 01:16 PM


All times are GMT -4. The time now is 09:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.