Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-19-2009, 08:53 PM   #76
Machine
Scooby Newbie
 
Member#: 39306
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Woodstock, MD
Vehicle:
2010 WRX STI Hatch
New Toy!

Default

<Gotta do my own walk of shame>
I've had the car for 5 years. I noticed the switch a long time ago when I was looking for the Hazards while pulled over getting a ticket on a backroad <sigh>, but never got around to figuring out what it was.

The funny thing is, it happened just like chitwood said - I took the car to a carwash for the first time ever and the lights were on since then. I was beginning to suspect the water had shorted something out. Pulled the fuse, thought about it a while, then went out and read the manual. My only saving grace is that I figured out the answer myself before having to look it up on here or (god forbid) post a question.

It's good to be humble!
Bill
* Registered users of the site do not see these ads.
Machine is offline   Reply With Quote
Old 06-04-2009, 09:30 AM   #77
mAdatee
Scooby Specialist
 
Member#: 87922
Join Date: May 2005
Chapter/Region: South East
Location: Jacksonville
Vehicle:
2002 Impreza WRX
Jasper Greeeeeeen

Default

I just fell for this.. thank god for the search button..



Owners manual? wat...
mAdatee is offline   Reply With Quote
Old 06-23-2009, 11:37 PM   #78
mikescar
Scooby Newbie
 
Member#: 214832
Join Date: Jun 2009
Chapter/Region: SWIC
Location: Your GF's Sisters Lesbians pad
Default

Sweet, thanks !
mikescar is offline   Reply With Quote
Old 06-30-2009, 08:54 PM   #79
ridexstraight
Scooby Specialist
 
Member#: 177384
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: yoooooper
Vehicle:
2002 impreza wrx
hella flush wrb yall

Default

haha so i manage a car audio place and we do remote starts and we always get dumb people that come back after we install one with something that doesn't work in there car "that the remote start messed up" i.e horn, lights, heater, power seats, you name it its been blamed on the r/s,, so we did a remote start on a wrx like a year ago, and they called in like a month ago being all craby saying that the damn remote start caused the parking lights to stay on haha so some one made them an appointment and i noticed it was on schedule and i say to my coworker that i bet i can fix this in under ten seconds after opening door, he says i bet i can too! so they come in and by coworker take s a stab at it haha and by that i mean under dash out remote start pulled down testing wires and stuff haha, im kinda mean sometimes so i let him suffer haha, so finally hes all pissed and told me there was no way i could fix it, must have a bad r/s brain and blah blah so i sit in the seat and set my finger on the steering column and flip the little rocker switch off goes the lights ahhaha my coworker almost shat ahah i told him to check the p/l switch he no listen ahha kk im done thats my funny story
ridexstraight

Last edited by ridexstraight; 06-30-2009 at 08:59 PM.
ridexstraight is offline   Reply With Quote
Old 07-05-2009, 04:30 PM   #80
(B)rex07
Scooby Specialist
 
Member#: 197217
Join Date: Dec 2008
Chapter/Region: NWIC
Location: Pacific North Fresh
Vehicle:
2007 WRX LTD
Muddy w/ a dash of UGM

Default

i was going crazy thank god for nasioc and the search feature
(B)rex07 is offline   Reply With Quote
Old 07-05-2009, 09:40 PM   #81
cool kid eli
Scooby Specialist
 
Member#: 127142
Join Date: Sep 2006
Chapter/Region: MAIC
Location: Washington, D.C.
Vehicle:
2004 bone w|a hint
of magenta WRX

Default

This is the best sticky on nasioc....today. lol. I just recently got my car out of the shop & my mechanic had no idea why the lights wouldn't turn off & I haven't driven my car in so long I didn't even bother checking it out since I'm still piecing it back together. The battery died & it was eating @ me that I didn't have an issue with the lights til they got their hands on it, then I read this. I ran outside & saw the little red part sticking out from when the lights are in the on position & rejoiced.....til I remembered the battery is still dead, sonuvabitch.
cool kid eli is offline   Reply With Quote
Old 08-30-2009, 04:23 PM   #82
bigpatskize
Scooby Newbie
 
Member#: 210691
Join Date: May 2009
Chapter/Region: SWIC
Location: Yuma, AZ
Vehicle:
04 WRX STi
Java Black

Default

Oh thank Jesus for this thread I was on a date last night and my parking lights where on, and for the life of me I did not know what was up. After I read this thread I literally slaped my head then followed shortly by a .
bigpatskize is offline   Reply With Quote
Old 11-05-2009, 01:12 PM   #83
formula91
Scooby Specialist
 
Member#: 102984
Join Date: Dec 2005
Chapter/Region: MWSOC
Location: Northbrook, IL
Vehicle:
2005 2.5RS 4EAT
Platinum Silver

Default

My car salesman told me about this first thing when I bought my car.
formula91 is offline   Reply With Quote
Old 11-15-2009, 08:22 PM   #84
sayiwont
Scooby Newbie
 
Member#: 218432
Join Date: Jul 2009
Chapter/Region: NWIC
Location: Pendleton, OR
Vehicle:
2004 WRX
Silver

Default

hahaha
sayiwont is offline   Reply With Quote
Old 02-01-2010, 12:30 AM   #85
OoBUGEYEoO
Scooby Newbie
 
Member#: 228832
Join Date: Nov 2009
Chapter/Region: RMIC
Location: Orem, Utah
Vehicle:
2002 Outback Sport
Silver

Default

Okay so this is how stupid I am... When I first bought my car (Used with no manual) I took it out for a test drive and came back and they were on. I asked the previous owner why they wouldn't turn off and told him I didn't want to buy a car if it had electrical problems. He showed me the switch and so I bought the car. A week later I did the Fog Light Mod and Daytime Driving Delete and somewhere while under there messing with wires turned that switch on again. Well for some ungodly reason (probably stoned...) I forgot that the switch was even there and got PISSED that they wouldn't turn off and didn't want to go back through all my wiring to see where I effed up. I started searching on here since that's where I found the previous mod threads and came across this thread and then planets aligned in my mind once again... DUH!! The switch... The damn switch... Gets you every time.
OoBUGEYEoO is offline   Reply With Quote
Old 02-06-2010, 07:21 PM   #86
Primathon
Scooby Newbie
 
Member#: 234703
Join Date: Jan 2010
Chapter/Region: NWIC
Vehicle:
2007 Outback Sport
Special Edition; Silver

Default

I left town for a week and let my brother take my 94 Legacy while I was gone. He returned it three days before I got back and left the parking lights on. First thing I saw when I pulled into the driveway, of course, but managed to start the car up without too much trouble... Had to explain that one to him when I saw him the next day.
Primathon is offline   Reply With Quote
Old 03-19-2010, 12:52 PM   #87
miker104
Scooby Newbie
 
Member#: 236422
Join Date: Jan 2010
Location: N KY
Vehicle:
99 OBW 2.5L DOHC
White

Default

I got a mini knife set/leatherman for knowing the answer to that question at new subie owners meeting after I got mine. I read the manual!
miker104 is offline   Reply With Quote
Old 03-30-2010, 11:46 AM   #88
rednoise
Scooby Newbie
 
Member#: 242672
Join Date: Mar 2010
Default

hahaha I had been told about this switch when I bought mine, then forgot about it only to "rediscover" it a couple years later.... remembered in about an hour
rednoise is offline   Reply With Quote
Old 07-16-2010, 12:17 AM   #89
STInfection
Scooby Newbie
 
Member#: 133192
Join Date: Nov 2006
Vehicle:
2007 STi
UGM

Default

AHAHAHAHAHA.................I'm an idiot, nuf said lol
STInfection is offline   Reply With Quote
Old 07-28-2010, 02:44 AM   #90
btothefnrock
Scooby Newbie
 
Member#: 237978
Join Date: Feb 2010
Chapter/Region: South East
Location: Blacksburg, VA 24060
Vehicle:
02 WRX
PSM

Default

i think atleast 50% of scooby owners have done this, whether or not they will admit it... lol
btothefnrock is offline   Reply With Quote
Old 11-29-2010, 11:10 AM   #91
wrxkyle
Scooby Specialist
 
Member#: 199635
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Provo, UT
Vehicle:
02-4 rSTI
White

Default

another thing i would like to see in the first posts if anyone is willing to edit is that if the switch is missing then you won't have any taillights except when you hit the brakes or blinkers. i had this problem, took me to ever to figure out that the switch is tied to both the always on parking lights and the rear driving lights
wrxkyle is offline   Reply With Quote
Old 04-09-2011, 06:16 PM   #92
Obababoy
Scooby Newbie
 
Member#: 158888
Join Date: Sep 2007
Chapter/Region: MAIC
Location: Baltimore area
Vehicle:
2011 STi EFR 7163!
07 GT30 WRX sold :/

Default

Hahahaha...so I just had this happen to me...I just got car back from body shop and this morning my battery was drained...turned out to be the power switch/wire for my amp wasnt hooked up...then I get home and clean my dash and the lights wouldnt turn off! I checked fuses, took rear seat out again, thennnnnn I searched here! Like many others I have had the car for almost 4 years now, put in a new turbo and everything and forgot this.
Obababoy is offline   Reply With Quote
Old 04-22-2011, 09:13 PM   #93
Griever423
Scooby Newbie
 
Member#: 118749
Join Date: Jun 2006
Chapter/Region: TXIC
Location: Fort Worth, TX
Vehicle:
2013 BRZ
WRB

Default

Gotta love the search feature. Here I was thinkin I'd have to shell out some serious money for an electrical problem...my best friend thought it was hilarious...
Griever423 is offline   Reply With Quote
Old 05-15-2011, 05:56 PM   #94
ukwrxsti
Scooby Newbie
 
Member#: 282836
Join Date: May 2011
Location: NKY
Vehicle:
2005 Impreza WRX STi
Bluee

Default

I just bought my car yesterday and the guy warned me about this lol
ukwrxsti is offline   Reply With Quote
Old 06-18-2011, 05:27 PM   #95
StL Dave
Scooby Newbie
 
Member#: 189076
Join Date: Sep 2008
Vehicle:
2002 WRX
Silver

Default

Add me to list of idiots who were glad this was here! tore half the car apart first though!
StL Dave is offline   Reply With Quote
Old 09-10-2011, 10:38 PM   #96
That Guy 2-1
Scooby Newbie
 
Member#: 279479
Join Date: Apr 2011
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2011 Legacy
Ruby Red

Default

okay just found out about this too ... but in my defense I'm new to Subaru's and have just bought this car (bought it with trashed engine and drained battery) and only now put in the fuse and wondered why the hell the parking lights are on and it was probably why the previous owner had the fuse pulled. So, after I read about this, I went back and put the fuse back in and flipped the switch and ... nothing happened, lights were still on. Turned the key on and turned the lights on and off and the switch on and off a couple times and it started working as it should and lights went off ... must have been a stuck relay?
That Guy 2-1 is offline   Reply With Quote
Old 10-01-2011, 08:15 PM   #97
Kulith
Scooby Newbie
 
Member#: 240684
Join Date: Mar 2010
Location: Pittsburgh
Vehicle:
2006 Impreza 2.5i
Black

Default

Man I remember seeing that switch when I first bought the car and I STILL ended up in this thread.
Kulith is offline   Reply With Quote
Old 10-09-2011, 02:01 PM   #98
subi1kenobi
Scooby Newbie
 
Member#: 296605
Join Date: Oct 2011
Chapter/Region: MWSOC
Location: Da Nati
Vehicle:
07 blk N blu STi
AP, TiC Susp, & CF Grill

Default

Haha. I was almost that guy. I couldnt figure it out and read this: duh, I just detailed the inside of the car. scoooooooore!

This is definitely the funniest thread of all time.
subi1kenobi is offline   Reply With Quote
Old 11-03-2011, 05:19 PM   #99
xxxyank
Scooby Newbie
 
Member#: 297148
Join Date: Oct 2011
Default

Kinda pathetic really. About a year ago my mother went out and bought this older Subaru, against me & my fathers wishes (we normally drive Volvos i'm pretty much the appointed work for food family mechanic), cause she always wanted one. Anyways during the first ice storm we had, i busted a hub on my bronco, so i couldn't climb the hill to my house/garage. Here comes mom in her Subaru, I jump in and pass 3 4x4s who were in the ditch climbing this hill, so i could grab my tools to fix the hub on the truck. Now I am seriously impressed!

Then around July the car had been running fine but my mom said to me her parking lights don't turn off. So i walk over, flip the headlights on and off. Figuring it was something in the steering column, i pull the fuse under the hood and say "This time of year you rarely drive in the dark, if you need to put this fuse back in, i got to many projects going on right now."

So this morning i get a call, she said she was in a hurry and forgot to put the fuse cover back on the box and closed the hood. now the hood won't shut all the way, etc and her parking lights are on...

So i go over, pop the hood, put the cover back on... Then mumble walking away, i'll see if i can't fix the lights this week. I go back home, do a quick search on pulling the steering wheel, I've never worked on a Subaru before saw nothing was funky, regular puller would do. Then typed in the search "My parking lights won't turn off Subaru"...

Talk about feeling like an idiot...

Thanks for the help, I'm sure i will be back. I been thinking of upgradeing my Cross Country to an Outback now
xxxyank is offline   Reply With Quote
Old 07-28-2012, 01:34 PM   #100
somd
Scooby Newbie
 
Member#: 327457
Join Date: Jul 2012
Chapter/Region: MAIC
Location: Southern Maryland
Vehicle:
1990 Legacy L Wagon
Gray

Default

Ok...new user, dumb question time. Tis is a 1990 Legacy question...ALL lighs are stuck on (not just headlights) and all go off hen I pull the 'TAIL CLEARANCE' 10A fuse...I'm a little stumped...

I consider myself a car guyu for sure, but admit elecrics are not my forte...

Ideas?

P.S. - any special award or dispensation for being the 100th pos on this thread?

MEMBER EDIT - Confess this thread is right andd I'm a dolt:
Excuses offered:
1. It's so dang hot outside, I was choosing not to go out to the car
2. I assumed my old Legacy wasn't the same
3. But seriously folks...a separate switch - for decades?

Last edited by somd; 07-28-2012 at 02:25 PM.
somd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My parking lights won't turn off?... Sharky Service & Maintenance 29 03-19-2010 03:55 PM
question of the day: why does my earphones.. iRick. Off-Topic 13 02-03-2009 03:20 AM
Computer guys, why won't my comp. shut off???? Eric SS Off-Topic 36 08-29-2002 03:53 AM
My parking lights won't go off LiquidForce General Community 22 01-06-2002 10:18 PM


All times are GMT -4. The time now is 03:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.