Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-21-2003, 05:55 PM   #1
dead-eye
Scooby Specialist
 
Member#: 43
Join Date: Jun 1999
Chapter/Region: MWSOC
Location: Aurora IL
Vehicle:
1999 2.5RS no T
RBP

Default CEL, Brake, battery lights on and no power steering?

Weird problem. I was exiting from the highway when I noticed the e-brake light and battery light come on and the power steering decreased. The CEL was on but it's always on due to the turbo kit. In any case, the car did not stop running (even though the battery light was on) and I checked the e-brake (it was not pulled up or anything). Could the alarm system be affecting the electronic systems? I'm really worried since I still have to drive home at night. Help!
dead-eye is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake light on and no power steering taketurns Factory 2.0L Turbo Powertrain 1 04-25-2010 11:58 AM
brake and battery light on, but no issues sachilles Normally Aspirated Powertrain 9 07-24-2008 11:35 PM
CEL Flashing P0301 Rough Idle and NO Power WRXerist Factory 2.0L Turbo Powertrain 26 02-05-2008 11:33 PM
abs light on and no AWD TDIpowered Legacy Forum 2 04-04-2007 10:42 PM
Strange!! CEL & Battery light on, then off. btour99 Service & Maintenance 9 01-11-2006 05:03 PM


All times are GMT -4. The time now is 03:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.