Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-07-2012, 11:46 PM   #101
ethernet
Scooby Newbie
 
Member#: 229206
Join Date: Nov 2009
Chapter/Region: RMIC
Location: Springville, UT/Wenatchee, WA
Vehicle:
2012 WRX hatch
SWP beautifulness

Default

Quote:
Originally Posted by JMB1911

Doug smith subaru in american fork utah....it had been there for 2 or 3 months on the showroom floor. Just got it last week.

Now they have a 2012 STI hatch on the showroom floor, the lighter blue one.
Seriously?! That's where I ordered my 2012! Haha oh well... They must not have had it listed online... Bummer.
* Registered users of the site do not see these ads.
ethernet is offline   Reply With Quote
Old 01-07-2012, 11:50 PM   #102
JMB1911
Scooby Newbie
 
Member#: 304803
Join Date: Dec 2011
Location: Alpine Utah
Vehicle:
2011 STi Hatch

Default

Just saw that you are in springville half the time....
JMB1911 is offline   Reply With Quote
Old 01-07-2012, 11:52 PM   #103
ethernet
Scooby Newbie
 
Member#: 229206
Join Date: Nov 2009
Chapter/Region: RMIC
Location: Springville, UT/Wenatchee, WA
Vehicle:
2012 WRX hatch
SWP beautifulness

Default

Must of the time. Haha but anyway, back to stereos?! Haha
ethernet is offline   Reply With Quote
Old 01-07-2012, 11:52 PM   #104
JMB1911
Scooby Newbie
 
Member#: 304803
Join Date: Dec 2011
Location: Alpine Utah
Vehicle:
2011 STi Hatch

Default

Quote:
Originally Posted by ethernet View Post
Seriously?! That's where I ordered my 2012! Haha oh well... They must not have had it listed online... Bummer.

oh ya that is probably what happened then , not online
JMB1911 is offline   Reply With Quote
Old 01-07-2012, 11:54 PM   #105
JMB1911
Scooby Newbie
 
Member#: 304803
Join Date: Dec 2011
Location: Alpine Utah
Vehicle:
2011 STi Hatch

Default

Quote:
Originally Posted by ethernet View Post
Must of the time. Haha but anyway, back to stereos?! Haha
I just solved my BT problem, I went and bought a blueant S4 visor mount bluetooth, works like a CHAMP, uploaded all my contacts, etc.

too bad subaru can't figure that out..wife said she couldn't even tell I was on a bluetooth, even going 50 down state street
JMB1911 is offline   Reply With Quote
Old 01-08-2012, 10:27 PM   #106
CarTuned
Scooby Specialist
 
Member#: 42203
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Hanover, MD
Vehicle:
2011 WRX
WRB

Default

Quote:
Originally Posted by JMB1911

I just solved my BT problem, I went and bought a blueant S4 visor mount bluetooth, works like a CHAMP, uploaded all my contacts, etc.

too bad subaru can't figure that out..wife said she couldn't even tell I was on a bluetooth, even going 50 down state street
Question...wouldn't having the phone connected to the blueant visor device prohibit the phone to play music through the car stereo? I'm only asking cause I play Pandora via the car stereo and my phones BT.
CarTuned is online now   Reply With Quote
Old 01-09-2012, 12:27 AM   #107
JMB1911
Scooby Newbie
 
Member#: 304803
Join Date: Dec 2011
Location: Alpine Utah
Vehicle:
2011 STi Hatch

Default

Quote:
Originally Posted by CarTuned View Post
Question...wouldn't having the phone connected to the blueant visor device prohibit the phone to play music through the car stereo? I'm only asking cause I play Pandora via the car stereo and my phones BT.

sorry not sure, I have never tried that. I would guess that if you pair the phone to the cars bluetooth and the visor bluetooth that would cause problems...at least with the phone part?
JMB1911 is offline   Reply With Quote
Old 01-09-2012, 01:54 AM   #108
CriticalityEvent
Scooby Newbie
 
Member#: 281670
Join Date: May 2011
Chapter/Region: MWSOC
Location: Chicagoland
Vehicle:
2012 WRX
DGM

Default

Quote:
Originally Posted by CarTuned View Post
Question...wouldn't having the phone connected to the blueant visor device prohibit the phone to play music through the car stereo? I'm only asking cause I play Pandora via the car stereo and my phones BT.
I think it depends on your phone. If you're on an Android phone, you can connect to multiple devices. You can select the device options in Settings and choose to connect to the HU with just Media selected and your headset with the Phone option selected.
CriticalityEvent is online now   Reply With Quote
Old 01-09-2012, 10:29 AM   #109
CSVT_2004
Scooby Specialist
 
Member#: 182213
Join Date: Jun 2008
Chapter/Region: MWSOC
Location: Madison
Vehicle:
1999 Contour SVT

Default

Quote:
Originally Posted by CriticalityEvent

I think it depends on your phone. If you're on an Android phone, you can connect to multiple devices. You can select the device options in Settings and choose to connect to the HU with just Media selected and your headset with the Phone option selected.
IIRC from school, BT's range is suppose to be a max of like 20 ft or something like that... so your visor should be just fine for streaming audio. I agree with critcal, I've seen some phones works great, and others suck hardcore. Best thing is just to make sure your radio's BT firmware and your phones software are all up to date. If possible try a demo car/radio before purchasing to make sure your going to be satisfied with the out come of your purchase. In the aftermarket, I know companies like Kenwood have a compatiblity chart for their radios to check if certain phones will work.
CSVT_2004 is offline   Reply With Quote
Old 01-14-2012, 01:34 AM   #110
fatdog1015
Scooby Newbie
 
Member#: 306855
Join Date: Jan 2012
Default

its kindda off topic.but kenwood headunits with Parrot Bluetooth are great.the sounds come in great and the receiving caller never knows it through the car stereo.
fatdog1015 is offline   Reply With Quote
Old 04-02-2012, 12:44 PM   #111
dcorn
Scooby Newbie
 
Member#: 107573
Join Date: Feb 2006
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2012 WRX hatch
Ice Silver

Default

Sorry to dredge up a thread, but add me to the terrible BT quality list. Every person I've ever talked to on it has said they can barely understand me. Almost no point in having it because I hate having to yell and repeat myself all the time.

Not sure if it's due to the excessive road noise or what. My '07 3-series was much quieter inside and the BT worked much better as well. People didn't have a problem hearing me at all.
dcorn is online now   Reply With Quote
Old 04-02-2012, 03:32 PM   #112
ethernet
Scooby Newbie
 
Member#: 229206
Join Date: Nov 2009
Chapter/Region: RMIC
Location: Springville, UT/Wenatchee, WA
Vehicle:
2012 WRX hatch
SWP beautifulness

Default

I haven't had much of a problem with it. Sure I can't be going 80 down the interstate and have people understand me but for around town and slower highway speeds it's great!
ethernet is offline   Reply With Quote
Old 04-03-2012, 01:24 AM   #113
Geerolla
Scooby Specialist
 
Member#: 264827
Join Date: Nov 2010
Chapter/Region: NWIC
Location: WA, USA
Vehicle:
2011 2.5i 5D
DGM

Default

Turning the gain down helped a lot for me. I can actually have conversations with people now, just need to make sure the sun roof is closed at high speeds.
Geerolla is offline   Reply With Quote
Old 08-29-2012, 07:13 PM   #114
desertceltic
Scooby Newbie
 
Member#: 330657
Join Date: Aug 2012
Location: Sahuarita, AZ (near Tucson)
Vehicle:
2012 Impreza Sport
Ice Blue/Silver

Default Reduced bluetooth microphone issues

I just bought a 2012 Impreza Sport Premium and have had issues with the bluetooth microphone. I found this thread and adjusted the gain to 1 with dramatic results, but my wife and kids still thought it sounded like it was raining when calling from the highway. I just installed a piece of Dynamat Extreme (6.5"W x 7"L) in the dome light cavity above the microphone. I also added some foam on the sides. My wife said this modification has made a huge improvement on the quality of the calls.

Hope this helps anyone else out there with the same issues. I am still going to bring it up with my Subaru dealer to see if anything is planned regarding the mic.
desertceltic is offline   Reply With Quote
Old 02-15-2013, 02:09 PM   #115
ScubiSTIle
Scooby Newbie
 
Member#: 314092
Join Date: Mar 2012
Chapter/Region: NWIC
Location: Kirkland
Vehicle:
2012 STI 5dr
ISM

Default

I've had this issue as well. I sent a message to Subaru and here is what I got back. Not super helpful, but at least they responded within a day and seemed fairly genuine although mostly canned:

Thank you for your email received by Subaru of America, Inc. We appreciate you taking the time to contact us.

Congratulations on the purchase of your 2012 Subaru WRX STI model. We very much appreciate that you chose the Subaru brand for your vehicle needs.

You may find the infroamtion listed on page 5-36 of your Owner's Manual helpful. There are very specific situations where it may be difficult for the individual you are calling with hands free to hear you clearly.

We would also recommend bringing your concerns for the bluetooth to the attention of your Subaru dealership. They can check the function of the unit, compare to other like models on their lot and determine whether there is an issue.

We will forward your comments regarding the bluetooth function/clarity to the Product Planning Department. Such information is reviewed and sometimes used when designing future products.

Again, thank you for taking the time to contact us. If you have future comments or questions, please contact us again.
ScubiSTIle is offline   Reply With Quote
Old 02-15-2013, 10:05 PM   #116
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

While the factory mic can be the cause for much of the problem, it can also be due to the RF Bluetooth link between your phone and the HU (which can sound like road noise). Try your phone in different locations inside the car. Hanging the phone too close to the HU could actually make things sound worse. Also test with some other phones.
SVXdc is offline   Reply With Quote
Old 02-18-2013, 02:15 PM   #117
Frank A
Scooby Specialist
 
Member#: 49979
Join Date: Dec 2003
Chapter/Region: MAIC
Location: MD, US
Vehicle:
11 dgm wrx hatch
08 black TA STI

Default

Quote:
Originally Posted by fatdog1015 View Post
its kindda off topic.but kenwood headunits with Parrot Bluetooth are great.the sounds come in great and the receiving caller never knows it through the car stereo.
I did not have this experience when I added a Kenwood (-966 model?) headunit to my wife's truck. The parrot bluetooth was almost as bad as the stock Subaru BT sound. We had the mike mounted on top of the steering column initially, but tried moving it about 6 inches in every direction and couldn't get it to improve. Maybe I'll try attaching it to the ceiling above the driver's head, but honestly, this should be plug-and-play easy. Her truck is a 2002 Avalanche and the road noise with the stock-style tires is better than in my Subaru so that's not it. Also tried two different phones- a Motorola RAZR android phone and a Blackberry. The unit also had a mic gain setting like the Subaru headunit, and I think another setting like squelch or sensitivity- can't remember, but playing with them didn't help much either. Really p*****s me off.
Frank A is offline   Reply With Quote
Old 02-20-2013, 12:06 AM   #118
static_rst
Scooby Specialist
 
Member#: 50155
Join Date: Dec 2003
Default

Anyone have this issue on a 2013 wrx?
static_rst is offline   Reply With Quote
Old 03-04-2013, 02:09 PM   #119
Ninja IRL
Scooby Newbie
 
Member#: 274733
Join Date: Feb 2011
Location: OrYgun
Vehicle:
2010 STi Hatch
Blu

Default

With the terrible stock BT, what model BT have people found to be best aftermarket functionality with less road noise?
Ninja IRL is offline   Reply With Quote
Old 06-24-2013, 07:34 PM   #120
Subaru Mom
Scooby Newbie
 
Member#: 360141
Join Date: Jun 2013
Default

My daughter just bought a 2013 STi Hatch. Great car except for BT. The background noise is terrible and when I talk with her I have to shout. Looks like there have been problems for years. Dealers don't seem to be too responsive. Should she just get a separate headunit?
Subaru Mom is offline   Reply With Quote
Old 06-24-2013, 10:02 PM   #121
CarTuned
Scooby Specialist
 
Member#: 42203
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Hanover, MD
Vehicle:
2011 WRX
WRB

Default

Quote:
Originally Posted by Subaru Mom View Post
My daughter just bought a 2013 STi Hatch. Great car except for BT. The background noise is terrible and when I talk with her I have to shout. Looks like there have been problems for years. Dealers don't seem to be too responsive. Should she just get a separate headunit?
Yes...I went with a Pioneer and haven't looked back. Now, I answer and make calls without issue. It sucks that Subaru never fixed it but since it's not officially a safety issue, I guess it's not necessary to change.
CarTuned is online now   Reply With Quote
Old 07-03-2013, 09:36 AM   #122
apollo_f1
Scooby Newbie
 
Member#: 230535
Join Date: Nov 2009
Location: Mountlake Terrace, WA
Vehicle:
2013 Sport Prem. MT
Dark Grey Metallic

Default

I'm having similar issues, to what everyone else is hearing, in my 2013 Sport. Apparently I can be heard clearly when the car is stopped or on smooth roads, but as soon as the road surface isn't pristine the call quality goes down. I tried putting a bit of pressure on the dome light and that seems to cure the problem, so it must be the plastic vibrating that is the problem.

I'll try a few of the suggestions here and see if they help. Thanks for the ideas everyone.

Edited to add:

I tried turning the gain down to 1, and that seems to be helping.

Last edited by apollo_f1; 07-03-2013 at 12:56 PM.
apollo_f1 is offline   Reply With Quote
Old 04-29-2014, 12:36 PM   #123
mk72206
Scooby Newbie
 
Member#: 382704
Join Date: Feb 2014
Location: Rehoboth, MA
Vehicle:
2014 Impreza Sport

Default

$50? I just spent $21k on a car that has exactly 1 bell and whistle, and that bell does not work. I could have gotten a Civic with every bell and whistle for the same price. The fact that the mic is so terrible is infuriating. The '11 Outback Limited, which my wife has, clearly has a directional mic that works very well. I have no idea why they decided to put an omnidirectional mic in th3 '14 Impreza Sport Premium.
mk72206 is offline   Reply With Quote
Old 06-14-2014, 08:25 PM   #124
esmcblur
Scooby Newbie
 
Member#: 352593
Join Date: Apr 2013
Default

Bump!

Any more info or findings on this? Really bummed on the quality.. especially with hopes of making business calls..
esmcblur is offline   Reply With Quote
Old 09-04-2014, 06:39 AM   #125
Celtmad67
Scooby Newbie
 
Member#: 400733
Join Date: Sep 2014
Default Mic. Croaking noise while driving

Quote:
Originally Posted by esmcblur View Post
Bump!

Any more info or findings on this? Really bummed on the quality.. especially with hopes of making business calls..

G'day everyone,
I'm in Australia and have just purchased a 2015 wrx.
I use my car heavily for business and am on my phone constantly while driving.

People I have been talking to have said that they can hear a croaking sound, a constant vibrating sound. The sound stops when I am stationery and increases as I begin to move. The faster I go, the louder it gets.

After reading this thread, I decided to look behind the map lighting and sunroof control housing.
I could see where the mic attaches to the housing. It attaches with 2 small screws. I tightened them both quite tightly. Put the housing back in place and tested it.

NO more frog croaking noises. My wife said she could easily have a conversation with me. There is still a bit of road/car noise but the wrx isn't the quietest of cars on the road.

There is also a bit of room above the map lighting unit and I do think that filling the space with a bit of sound deadening material will help further.

Hope my experience can help some of you out there in Subaru World!

Cheers
Celtmad67 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 STi bluetooth/phone setup bluebayou Car Audio, Video & Security 10 11-07-2010 11:09 AM
Is it worth keeping the stock headunit? and road noise issues Burnall4 Car Audio, Video & Security 6 07-02-2009 02:47 PM
Rattles, road noise, and other strange noises ggiles@clarionnet.com Car Audio, Video & Security 1 11-15-2001 09:01 AM
WHY DO I HAVE SO MUCH ROAD NOISE PLEASE HELP 2.5rsMI Brakes, Steering & Suspension 8 05-26-2001 03:33 PM
('93-'01) Road Noise after lowering 2.5rsMI Impreza Forum 2 05-21-2001 11:36 AM


All times are GMT -4. The time now is 03:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.