Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 02-24-2012, 03:08 PM   #51
golden_boy
Scooby Newbie
 
Member#: 248620
Join Date: Jun 2010
Chapter/Region: MAIC
Location: New Castle, DE
Vehicle:
2013 BRZ
Dark Grey Metallic

Default

Quote:
Originally Posted by Homemade WRX View Post
your TURBO is overheating?!! Care to explain what you mean there?
Can you give us some description/symptoms of what's going on?
Yesterday when I was driving home from work I smelled some burning and I seemed to have lost boost (from my gauge). I pulled over and sure enough my turbo/heat shield was smoking because the turbo was so hot. I let it cool down then limped back to my house staying off boost.

I could hear the coolant boiling in the top line so I figured I maybe had a blockage so fluid could not flow. This morning I checked the coolant lines and topped off the coolant but there did not seem to be any problems there. I drove real slow to work staying off boost today but it did not seem to heat up as much as yesterday. Maybe it was blocked and when I took of the lines to check them it freed it up.
* Registered users of the site do not see these ads.
golden_boy is offline  
Old 02-24-2012, 03:29 PM   #52
karmaSRT
Scooby Specialist
 
Member#: 231457
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Salisbury MD
Vehicle:
2015 STI
Black

Default

Put some 05 tails on it today I love the look of the rear end now
karmaSRT is offline  
Old 02-24-2012, 03:30 PM   #53
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by golden_boy

Yesterday when I was driving home from work I smelled some burning and I seemed to have lost boost (from my gauge). I pulled over and sure enough my turbo/heat shield was smoking because the turbo was so hot. I let it cool down then limped back to my house staying off boost.

I could hear the coolant boiling in the top line so I figured I maybe had a blockage so fluid could not flow. This morning I checked the coolant lines and topped off the coolant but there did not seem to be any problems there. I drove real slow to work staying off boost today but it did not seem to heat up as much as yesterday. Maybe it was blocked and when I took of the lines to check them it freed it up.
Dude mine does that randomly too. Like when I start my can and leave it sitting for 5 or so mins.

But yester say was by far the worst and I completely understand by the tubes were boiling.
WRX WARRIOR is offline  
Old 02-24-2012, 05:11 PM   #54
ckswanecamp
Scooby Newbie
 
Member#: 299861
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Hanover, PA
Vehicle:
2002 Impreza WRX
Metallic Silver

Default

Got it muddy....
ckswanecamp is offline  
Old 02-24-2012, 07:21 PM   #55
mangostick
Scooby Specialist
 
Member#: 256936
Join Date: Sep 2010
Chapter/Region: MAIC
Location: failginia breach
Vehicle:
2013 FRS
pearl white beetches!

Default

Quote:
Originally Posted by golden_boy View Post
Yesterday when I was driving home from work I smelled some burning and I seemed to have lost boost (from my gauge). I pulled over and sure enough my turbo/heat shield was smoking because the turbo was so hot. I let it cool down then limped back to my house staying off boost.

I could hear the coolant boiling in the top line so I figured I maybe had a blockage so fluid could not flow. This morning I checked the coolant lines and topped off the coolant but there did not seem to be any problems there. I drove real slow to work staying off boost today but it did not seem to heat up as much as yesterday. Maybe it was blocked and when I took of the lines to check them it freed it up.
Is this car tuned? What mods? ...this really does sound like a mixture problem.. not coolant flow.
mangostick is offline  
Old 02-24-2012, 08:06 PM   #56
God&Sme
Scooby Specialist
 
Member#: 256567
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Wake Forest, NC/Richmond, VA
Vehicle:
2002 PSM WRX
StiMikey Tuned

Default

Quote:
Originally Posted by ckswanecamp View Post
Got it muddy....
UUUUGGGGHHHHHHH, i wish everybody would stop posting up their sexy jdm scoops on their bugeyes

haaaaaa i was looking into it last night n not only would i have to invest in the scoop but the splitter n IC, far from a simple investment n its so sexay, want to touch the heiny
God&Sme is offline  
Old 02-24-2012, 10:08 PM   #57
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT....2009 FXT

Default

AVO TBE





acumenhokie is offline  
Old 02-24-2012, 10:20 PM   #58
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by God&Sme

UUUUGGGGHHHHHHH, i wish everybody would stop posting up their sexy jdm scoops on their bugeyes

haaaaaa i was looking into it last night n not only would i have to invest in the scoop but the splitter n IC, far from a simple investment n its so sexay, want to touch the heiny
Just go fmic broooooooo!
WRX WARRIOR is offline  
Old 02-24-2012, 11:13 PM   #59
FastAdams
Scooby Specialist
 
Member#: 280714
Join Date: Apr 2011
Chapter/Region: MAIC
Location: Pennsylvania/Hawaii
Vehicle:
1998 Look below.
98 rs 99 forester

Default

Quote:
Originally Posted by acumenhokie
AVO TBE
Is that at fast? I think it is...
FastAdams is offline  
Old 02-24-2012, 11:40 PM   #60
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT....2009 FXT

Default

Quote:
Originally Posted by FastAdams View Post
Is that at fast? I think it is...
Indeed it is.
acumenhokie is offline  
Old 02-24-2012, 11:50 PM   #61
NutWagon
Scooby Specialist
 
Member#: 230925
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Show Me Ur TT's
Vehicle:
04 WRX Wag Stage 4
06 Impreza 2.5I

Default

We really need a LIKE Button! lol
NutWagon is offline  
Old 02-25-2012, 12:00 PM   #62
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Took it in to Pence for Inspection. Almost time for timing belt and tensioner replacement.
blackfang is offline  
Old 02-25-2012, 01:54 PM   #63
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Replaced my old spark plugs in the WRX with nice new NGK one step colder plugs
Also I have been fighting to install an aftermarket head unit in my OBS, but so far no good.....
EvileyeZ88 is offline  
Old 02-25-2012, 07:02 PM   #64
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Even know I had them for 3 weeks I finally installed my Hellas using an old HID plug and play harness supplied by Mike...

In his garage also!
ppayer38 is offline  
Old 02-25-2012, 09:52 PM   #65
Bald_Wrex
Scooby Specialist
 
Member#: 236005
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
2008 Foz Sports XT
SGM "C6Z"

Default

Traded my 2011 STI for a 08 Forester XT sports
Bald_Wrex is offline  
Old 02-26-2012, 12:41 AM   #66
Turbo18psi
Scooby Specialist
 
Member#: 245835
Join Date: May 2010
Chapter/Region: MAIC
Location: Gaithersburg, Maryland
Vehicle:
07 Sti Limited UGM
05 IS300 Graphite Gray

Default

THE GOOD:

Installed my CF Alternator cover and my Carbon Fiber V-Limited front Lip!!!!

THE BAD:

Taking off the wheels and my wheel lock key broke off inside one of the lugs on the wheel.

THE UGLY:

I only got one wheel off and now I have to some how get the other 3 wheel locks off without a key! F!!!!
Turbo18psi is offline  
Old 02-26-2012, 12:44 AM   #67
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

^Go buy yourself a socket that is a little smaller than the lock and hammer that bitch on there and you have yourself a key
EvileyeZ88 is offline  
Old 02-26-2012, 12:51 AM   #68
Turbo18psi
Scooby Specialist
 
Member#: 245835
Join Date: May 2010
Chapter/Region: MAIC
Location: Gaithersburg, Maryland
Vehicle:
07 Sti Limited UGM
05 IS300 Graphite Gray

Default

Quote:
Originally Posted by EvileyeZ88 View Post
^Go buy yourself a socket that is a little smaller than the lock and hammer that bitch on there and you have yourself a key
Yep! First thing Monday when I get to work. I tried one of the reverse sockets that I have for that pourpose, however the smallest one is just a spec too big... Good thing there is lifetime warranty on all my snap-on tools for when that socket breaks!!! LOL
Turbo18psi is offline  
Old 02-26-2012, 02:32 AM   #69
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by Turbo18psi
THE GOOD:

Installed my CF Alternator cover and my Carbon Fiber V-Limited front Lip!!!!

THE BAD:

Taking off the wheels and my wheel lock key broke off inside one of the lugs on the wheel.

THE UGLY:

I only got one wheel off and now I have to some how get the other 3 wheel locks off without a key! F!!!!
Let me see that carbon **** son.
WRX WARRIOR is offline  
Old 02-26-2012, 08:43 AM   #70
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 ftlb@3k rpm
justablue hatch

Default

painted my side skirts with plasti dip...look and feel nice. bondoed and sanded front lip...3m makes great stuff...years worth of cracks bye bye. prob get color match rattle cans to paint.
mhoerath is offline  
Old 02-26-2012, 11:40 AM   #71
Turbo18psi
Scooby Specialist
 
Member#: 245835
Join Date: May 2010
Chapter/Region: MAIC
Location: Gaithersburg, Maryland
Vehicle:
07 Sti Limited UGM
05 IS300 Graphite Gray

Default

Turbo18psi is offline  
Old 02-26-2012, 11:51 AM   #72
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

What wheels do you have? I can't do the carbon lip I'm too low it wouldn't last a week lol.

The last code was for the front lip again I really wana see that belt cover, did it have the same figment as the stock one?
WRX WARRIOR is offline  
Old 02-26-2012, 12:16 PM   #73
Turbo18psi
Scooby Specialist
 
Member#: 245835
Join Date: May 2010
Chapter/Region: MAIC
Location: Gaithersburg, Maryland
Vehicle:
07 Sti Limited UGM
05 IS300 Graphite Gray

Default

Quote:
Originally Posted by WRX WARRIOR View Post
What wheels do you have? I can't do the carbon lip I'm too low it wouldn't last a week lol.

The last code was for the front lip again I really wana see that belt cover, did it have the same figment as the stock one?
Rota SVN's. Looks like the Volk RE30 without the price tag.
I love my lip and have an OEM one for sale.
Te fitment on the alternator cover is great.
Turbo18psi is offline  
Old 02-26-2012, 12:56 PM   #74
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by Turbo18psi

Rota SVN's. Looks like the Volk RE30 without the price tag.
I love my lip and have an OEM one for sale.
Te fitment on the alternator cover is great.
Hey man nothin wrong with wheels that don't cost 1500$. I mean Volks will curb the same as Rotas. Hell my prodrive p7s have a small rash on them, from previous owner but he did some work on it and I cant even tell haha

I just ordered a carbon exhaust garnish the other day I can't wait to get that lol I was thinking about a carbon trunk with my hood as well.
WRX WARRIOR is offline  
Old 02-26-2012, 01:13 PM   #75
Turbo18psi
Scooby Specialist
 
Member#: 245835
Join Date: May 2010
Chapter/Region: MAIC
Location: Gaithersburg, Maryland
Vehicle:
07 Sti Limited UGM
05 IS300 Graphite Gray

Default

Quote:
Originally Posted by WRX WARRIOR View Post
Hey man nothin wrong with wheels that don't cost 1500$. I mean Volks will curb the same as Rotas. Hell my prodrive p7s have a small rash on them, from previous owner but he did some work on it and I cant even tell haha

I just ordered a carbon exhaust garnish the other day I can't wait to get that lol I was thinking about a carbon trunk with my hood as well.
If it was $1500.00 I'd buy the Volks... It's $860 PER RIM! I got all 4 rotas for $900. LOL! And I was thinking of getting that CF exhaust plate too! Let me see it when you get it?!
Turbo18psi is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 01:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 04:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 01:02 PM


All times are GMT -4. The time now is 12:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.