Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-22-2012, 03:29 AM   #1
BlueFox91
*** Banned ***
 
Member#: 312282
Join Date: Mar 2012
Chapter/Region: MWSOC
Vehicle:
2012 WRX
Plasma Blue Pearl

Default 2012 WRX data logging

I havent been able to find a thread on this but i just bought a tactrix cable with the intention of data logging but i cant get the romraider logger to recognize my ecu. Ive tried all the ecu definitions and logger defs and ecu flash will read my rom but doesnt have the correct defs. Sorry im a noob and im afraid Im overlooking something obvious.
* Registered users of the site do not see these ads.
BlueFox91 is offline   Reply With Quote
Old 03-22-2012, 07:53 AM   #2
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

go back to the romraider forums and read the stickies
Black94Snake is offline   Reply With Quote
Old 03-22-2012, 08:53 AM   #3
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Quote:
Originally Posted by BlueFox91 View Post
Sorry im a noob and im afraid Im overlooking something obvious.
Yes,like reading the instructions...........
quazimoto is offline   Reply With Quote
Old 03-22-2012, 06:10 PM   #4
BlueFox91
*** Banned ***
 
Member#: 312282
Join Date: Mar 2012
Chapter/Region: MWSOC
Vehicle:
2012 WRX
Plasma Blue Pearl

Default

Its ok. If you dont know the answer you dont have to comment,
BlueFox91 is offline   Reply With Quote
Old 03-22-2012, 06:51 PM   #5
noypi09
Scooby Newbie
 
Member#: 245885
Join Date: May 2010
Chapter/Region: MAIC
Location: pikesville maryland
Vehicle:
2009 WRX sedan
obsidian black pearl

Default

download the latest ecu definitions then open romraider logger go to settings then click the logger definition location then open it there that should help.
noypi09 is offline   Reply With Quote
Old 03-22-2012, 10:45 PM   #6
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Quote:
Originally Posted by BlueFox91 View Post
Its ok. If you dont know the answer you dont have to comment,
I gave you the answer. You didn't read or follow the instructions. Was I not correct? It's not that hard. Read the instructions,then follow them. You need to make sure you have the defintions for the 2012's in Ecuflash.

http://www.romraider.com/Documentati...ortedECUs#toc1

"This is a list of all Subaru ECUs currently supported by the latest RomRaider ECU definitions (0.8.3.1b 10–07–09). Make sure you have the latest ECU definitions which may be newer than those bundled with the RomRaider download. A ROM ID marked with an asterisk(*) indicates the 32-bit ECU, whereas no asterisk indicates the 16-bit ECU. The transmission is also listed (AT = automatic, MT = manual, MT/AT = supports either).
ROM ID with a trailing pound(#) indicates that the ROM is not officially supported in the latest release but an EXPERIMENTAL definition is available which may not be complete or accurate.

Note: Model year and trim are supplied by the users submitting the ROMs. If not given, an educated guess is made as there is no known method of determining this from the ROM itself. As such, the model year and trim listed may not be accurate in all cases.

Last edited by quazimoto; 03-22-2012 at 10:52 PM.
quazimoto is offline   Reply With Quote
Old 03-23-2012, 02:57 AM   #7
BlueFox91
*** Banned ***
 
Member#: 312282
Join Date: Mar 2012
Chapter/Region: MWSOC
Vehicle:
2012 WRX
Plasma Blue Pearl

Default

It seems that all you do is tell people that they havent done research and point them to the noob forums or a vague post rather than giving a direct answer. Everyone could ignore every post you have ever made and get their answer faster. Isnt a forum designed to answer questions quickly without having to sift through your irrelevant rants. I relieve you of any obligation you may feel to comment on any of my future posts as you are truly useless.
BlueFox91 is offline   Reply With Quote
Old 03-23-2012, 08:21 AM   #8
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Oh......I see. Your part of the "spoonfeed me information/instant gratification" generation. I'm sure you used to having your hand held every step of the way. I know,following instructions is tough and reading directions just takes to much time. It's easier just to post a question on an internet forum and sit and wait,and wait,and wait for someone to give you the answer. Even though the answer is right in front of you or has been asked and answered many,many times already. I believe in the philosophy "Give a man a fish,he eats for a day. Teach a man to fish,he eats for a life time" I'm teaching people to fish.
quazimoto is offline   Reply With Quote
Old 03-23-2012, 12:45 PM   #9
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

Quote:
Originally Posted by quazimoto
Oh......I see. Your part of the "spoonfeed me information/instant gratification" generation. I'm sure you used to having your hand held every step of the way. I know,following instructions is tough and reading directions just takes to much time. It's easier just to post a question on an internet forum and sit and wait,and wait,and wait for someone to give you the answer. Even though the answer is right in front of you or has been asked and answered many,many times already. I believe in the philosophy "Give a man a fish,he eats for a day. Teach a man to fish,he eats for a life time" I'm teaching people to fish.
In the words of Morpheus. "I can only show you the door. YOU must walk through it."
Black94Snake is offline   Reply With Quote
Old 03-23-2012, 12:53 PM   #10
fulltimeW.O.T.
Scooby Specialist
 
Member#: 120414
Join Date: Jul 2006
Chapter/Region: Tri-State
Location: North Jersey
Vehicle:
2009 WRX 5Dr DGM
Stage 2+Meth

Default

Quote:
Originally Posted by Black94Snake View Post
In the words of Morpheus. "I can only show you the door. YOU must walk through it."
I can definitely admit that I am also a big matrix geek.

I can honestly say that I have learned everything I kno about tuning over at the romraider forums. For anything tune and ecu related, that is the place to go to first. Without a doubt.
fulltimeW.O.T. is offline   Reply With Quote
Old 03-23-2012, 01:48 PM   #11
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Quote:
Originally Posted by Black94Snake

In the words of Morpheus. "I can only show you the door. YOU must walk through it."
Nice!
quazimoto is offline   Reply With Quote
Old 04-01-2012, 11:52 PM   #12
simplystockwrx
Scooby Newbie
 
Member#: 314737
Join Date: Mar 2012
Chapter/Region: SCIC
Location: CA
Vehicle:
2012 WRX
SWP

Default

according to romraider link there is no USDM 2012 WRX definitions? Odd though there is USDM 2012 STi def's.
simplystockwrx is offline   Reply With Quote
Old 04-02-2012, 12:23 AM   #13
BlueFox91
*** Banned ***
 
Member#: 312282
Join Date: Mar 2012
Chapter/Region: MWSOC
Vehicle:
2012 WRX
Plasma Blue Pearl

Default

I tried everything over again on a different laptop and I havent had any troubles since. Except learning view says it doesnt support my ECU ID.
BlueFox91 is offline   Reply With Quote
Old 04-02-2012, 02:18 AM   #14
throttlehappy
Scooby Newbie
 
Member#: 313497
Join Date: Mar 2012
Chapter/Region: International
Location: Australia
Vehicle:
2012 S206
White

Default

Learning View has not been updated in around 12 months, thus no support for a recent ECU(or numerous other ECU's)

Quote:
Originally Posted by quazimoto View Post
I gave you the answer. You didn't read or follow the instructions. Was I not correct? It's not that hard. Read the instructions,then follow them. You need to make sure you have the defintions for the 2012's in Ecuflash.

http://www.romraider.com/Documentati...ortedECUs#toc1

"This is a list of all Subaru ECUs currently supported by the latest RomRaider ECU definitions (0.8.3.1b 100709). Make sure you have the latest ECU definitions which may be newer than those bundled with the RomRaider download. A ROM ID marked with an asterisk(*) indicates the 32-bit ECU, whereas no asterisk indicates the 16-bit ECU. The transmission is also listed (AT = automatic, MT = manual, MT/AT = supports either).
ROM ID with a trailing pound(#) indicates that the ROM is not officially supported in the latest release but an EXPERIMENTAL definition is available which may not be complete or accurate.

Note: Model year and trim are supplied by the users submitting the ROMs. If not given, an educated guess is made as there is no known method of determining this from the ROM itself. As such, the model year and trim listed may not be accurate in all cases.
FYI: If you read the question, the OP is trying to DATALOG his car...

EcuFlash or RomRaider ECU definitions are irrelevant.
throttlehappy is offline   Reply With Quote
Old 04-03-2012, 03:14 PM   #15
Xtreme.
Scooby Newbie
 
Member#: 292380
Join Date: Aug 2011
Default

You can get your ROM name using EcuFlash (or romraider) don't remember correctly. Have you asked/researched if your ROM is supported in the latest definitions over at RR forums? I had a similar problem way back with my 07 STi and it was because the definitions that were available at the time did not support my ROM yet, but did support it on their next revision
Xtreme. is offline   Reply With Quote
Old 04-04-2012, 04:30 AM   #16
BlueFox91
*** Banned ***
 
Member#: 312282
Join Date: Mar 2012
Chapter/Region: MWSOC
Vehicle:
2012 WRX
Plasma Blue Pearl

Default

I can log and edit with RR and ecuflash, its no big deal that learning view doesnt work.
BlueFox91 is offline   Reply With Quote
Old 04-08-2012, 11:01 AM   #17
throttlehappy
Scooby Newbie
 
Member#: 313497
Join Date: Mar 2012
Chapter/Region: International
Location: Australia
Vehicle:
2012 S206
White

Default

Also, let me know if you would like the RomRaider SSM coding to access Learning View Info from RomRaider
throttlehappy is offline   Reply With Quote
Old 02-10-2013, 11:33 PM   #18
gianttcr
Scooby Newbie
 
Member#: 108790
Join Date: Feb 2006
Chapter/Region: SCIC
Location: San Diego, but Im over it
Vehicle:
2002 WRX 2.2 Wagon
PSM

Default

Sorry to revive this old thread. However, I have downloaded the latest ECU defs and Logger defs and I can do everything I need to do, so far. I opened up RR Editor and added, applied, and saved the ECU defs to the library, but the thing STILL says I don't have latest definitions, and so, I don't have access to some of the tools. I've tried unzipping them, tried adding the whole file, whatever. No luck. I am computer stupid, born in the early '70s, so I will admit right now that I think it's me. But, I have looked far and near, and whatever the solution is, is not making its way into my brain. Please help. Can someone offer a step by step of exactly how you're supposed to get the latest defs INTO RR? Thank you in advance. BTW, this is for '02 WRX, and on Windows 7. I heard the Windows 7 application sucks on some computers and I certainly think mine is one (VAIO 64-bit). Should I try installing on another, older laptop? Thanks again!
gianttcr is offline   Reply With Quote
Old 02-10-2013, 11:45 PM   #19
nmlittlebigman
Scooby Specialist
 
Member#: 321409
Join Date: May 2012
Chapter/Region: SWIC
Location: Arrey, NM
Vehicle:
2015 WRX LTD
WRB

Default

I am pretty sure you will need to replace folders from windows and not romraider program itself. If I recall correctly you will "point" romraider to where to find the definitions, but editing/updating the definitions folders themselves you will do in windows through explorer. This is done by deleting the subaru folder and replacing it with the new defs. BTW I am running windows 7 with no problems...and I was born in the 60's .

Also have you installed ecuflash too? It has the drivers need for the tactrix cable.

Last edited by nmlittlebigman; 02-10-2013 at 11:54 PM.
nmlittlebigman is online now   Reply With Quote
Old 02-11-2013, 01:11 AM   #20
gianttcr
Scooby Newbie
 
Member#: 108790
Join Date: Feb 2006
Chapter/Region: SCIC
Location: San Diego, but Im over it
Vehicle:
2002 WRX 2.2 Wagon
PSM

Talking

Sorry. Im not sure what you mean by relacing defs in Windows and not RR. Ive downloaded the defs about a dozen times! They show up in my computer. Then, I open RR per instructions, go to manager, and bring that file over. Looks like its good. I dont understand the deleting subaru folder, even though Ive read it before. I see different subaru cars and ecu ids depending on the screen, but not sure they pull over when I bring the file into RR. Hahahah! You guys from the 60s have more patience than us! Any chance you can give me a step by step as to how you did it? I know it tells how on RR website, but I am clearly not understanding the process. Yes, also, I have EcuFlash with all drivers and Tactrix, can read and flash, can log in RR (just dont have access to dyno and other tools), and also have good luck with Learning View. Often, the programs hang up while running (luckily, HASNT happened during a flash!) or will not communicate with car, telling me to check for unplugged cable, even though I was JUST communicating in one of the other programs. Been making sure I back all the way out of each program and only run one car program at a time. Still, issues which drive me batty. Just built my first motor with this 2.1 stroker, so batty comes easy these days! Last thing I want to do, besides spinning a bearing, is brick this ECU being an impatient smarty pants. You know? Thanks again, in advance!
gianttcr is offline   Reply With Quote
Old 02-11-2013, 09:24 AM   #21
nmlittlebigman
Scooby Specialist
 
Member#: 321409
Join Date: May 2012
Chapter/Region: SWIC
Location: Arrey, NM
Vehicle:
2015 WRX LTD
WRB

Default

The problem with being born in the 60's is that I am now getting CRS (can't remember s**t). I recall though that there was a cars def folder that I had to update too. I'll try to put together something and I'll PM you. It may be this afternoon.
nmlittlebigman is online now   Reply With Quote
Old 02-11-2013, 09:51 AM   #22
nmlittlebigman
Scooby Specialist
 
Member#: 321409
Join Date: May 2012
Chapter/Region: SWIC
Location: Arrey, NM
Vehicle:
2015 WRX LTD
WRB

Default

nmlittlebigman is online now   Reply With Quote
Old 02-11-2013, 10:55 PM   #23
gianttcr
Scooby Newbie
 
Member#: 108790
Join Date: Feb 2006
Chapter/Region: SCIC
Location: San Diego, but Im over it
Vehicle:
2002 WRX 2.2 Wagon
PSM

Default

Thanks MUCH, both of you! Havent had a chance to look at link yet, and no PMs received, but I appreciate it and will check out the links now. Right after I take my "you're in your 40s now, so expect to take a leak every 5 minutes" meds.
gianttcr is offline   Reply With Quote
Old 02-11-2013, 11:11 PM   #24
gianttcr
Scooby Newbie
 
Member#: 108790
Join Date: Feb 2006
Chapter/Region: SCIC
Location: San Diego, but Im over it
Vehicle:
2002 WRX 2.2 Wagon
PSM

Default

OK,
So I went back in and looked at my downloads. Sure enough, latest standard defs downloaded 8 times! Went into RR and looked at defs manager, and I have .xml file in there. So, what I am understanding is that this is where I am telling RR to look? Anyway, I got back into ECU DEFS folder, unzipped it, and it just had the ECU DEFS file again, but accessible now, and I even found my 02's cal id, which I copied and pasted into defs manager. I also deleted the original ECU DEFS in there. Still no luck. I am sure it is a WIndows thing I dont understand, I just dont understand it at all.
gianttcr is offline   Reply With Quote
Old 02-11-2013, 11:13 PM   #25
nmlittlebigman
Scooby Specialist
 
Member#: 321409
Join Date: May 2012
Chapter/Region: SWIC
Location: Arrey, NM
Vehicle:
2015 WRX LTD
WRB

Default

Ha...there was/is only one of me posting. I sent the links instead of pm. If you read the links it will tell you to save the cars_def files (.dtd and .xml ) to the folder that contains romraider. So since you are running windows 7 open up:
"C:\Program Files (x86)\RomRaider\"

and drag and drop them in there. Hope it helps. If it doesnt solve you problem, join romraider forum and direct you questions to dschultz.

Post back here what you find. BTW I have not tried to use the road dyno so I don't know if mine is properly set up as well.
nmlittlebigman is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 WRX Data logs...Stage 2 + AEM intake = CEL? kyky489 AccessPort 6 03-26-2012 04:38 PM
2012 WRX Stage 2 Overboosting data log Isoh AccessPort 2 02-24-2012 03:29 AM
2012 WRX Stage 1+SF Data Logs KitKatJim AccessPort 14 02-22-2012 11:45 AM
2012 STi 91 Octane Data Log Analysis kevosti AccessPort 0 02-04-2012 08:21 PM
2011 wrx data log :( mdsubie11 AccessPort 7 08-22-2011 10:38 PM


All times are GMT -4. The time now is 03:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.