Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-28-2012, 12:36 AM   #1
subimp6u08
Scooby Specialist
 
Member#: 15440
Join Date: Feb 2002
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2015 STi
DGM

Default smell from the heater vent

my sti started smell when I turn on the heater for past few months.
I changed the radiator(to used oem) twice due to cracks, and replaced the power steering pump. I smell it randomly when I turn on the heater, but when I turn on the a/c, then it smells less.
Also when I open up the hood after I shut off the car, I can smell it from the radiator section and also on the passenger side of the engine. But the smell that comes into the car vent smells like the one from the engine.
And I found out that my engine's eating up some oil lately, and I just filled 1.5qts after I refilled 1qt about 6 weeks ago.
I also replaced the cabin filter last week, and cleaned up the engine bay with simple green (it smelled good after the wash, but that only lasted a day)
I don't see any leakage around the hose or under the car, so what could be a possible problem? it has 103k miles on it right now.
subimp6u08 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Antifreeze Smell in The Air Vents '02 OBW dimwittedmoose Outback Forum 7 12-13-2010 04:30 PM
A rubber smell from the hood? chansaephanh Newbies & FAQs 15 08-01-2008 11:44 PM
Funky smell from the air condition BroomHandler Newbies & FAQs 13 08-08-2007 07:56 PM
Possible burning smell from the cat...? ZACKARU Newbies & FAQs 10 03-03-2007 06:56 PM
mold/dirty smell from the AC culturedetox Interior & Exterior Modification 13 04-15-2006 11:21 AM


All times are GMT -4. The time now is 12:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.