Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid West Subaru Owners Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid West Subaru Owners Club Forum -- MWSOC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-01-2012, 10:12 PM   #5501
MouseMarine
Scooby Newbie
 
Member#: 312313
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Wadsworth, OH
Vehicle:
2010 WRX Hatchback
White

Default

Quote:
Originally Posted by jrt20

Found out that the rear bushing was not installed properly. I assumed that the bolts for the rear bushing would just thread properly back into their respective holes. Nope. The passenger side bolt cross threaded and what seemed to be fully tightened was only half way threaded. Fml. Well I did my best to fix the cross threading, but the big success is no more rattle. Whew.
That's great to hear. Good job.
* Registered users of the site do not see these ads.
MouseMarine is offline   Reply With Quote
Old 04-02-2012, 02:16 AM   #5502
zpl2
Scooby Newbie
 
Member#: 264713
Join Date: Nov 2010
Location: cleveland
Vehicle:
04 wrx
psm

Default

hey guys I got some new tires 225 40 18 re960 bridgestone that are in really good condition worth probably around 800 if not more new and I also have a extra set of 245 40 18. The wheels are 18x8.5t48 as I posed earlier for sale for 1100 or 1500 with coilovers. Also let me know since Im new to this sub-forum if I should not post stuff like this on here. Just thought Id let y'all know whats available. oh ya these pics are with the old tires

zpl2 is offline   Reply With Quote
Old 04-02-2012, 08:50 AM   #5503
wexneffex
Scooby Specialist
 
Member#: 179216
Join Date: May 2008
Chapter/Region: MWSOC
Location: Cleveland, OH
Vehicle:
2011 SWPSTI 04G35x
Forced4s.com

Default

The ol saabaru is looking clean.. Your making me regret selling it! lol
wexneffex is offline   Reply With Quote
Old 04-02-2012, 11:52 AM   #5504
kered9
Scooby Newbie
 
Member#: 259430
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Cleveland ohio
Vehicle:
2002 wrx
psm

Default

Were any of you guys at the geauga lake auto cross yesterday? I met a guy with a 04-05 blue Sti that said he was selling it and my buddy is interested in it. But I forgot to get his name, the Sti had rota grids on it and he said he also had an evo. His name might have been rob, but I forget. If anyone in here knows him could you pm me his user name so I get a hold of him. Or if any of you know the guy from willowick with a 06-07 blue Sti, rally pigs on the mirrors can you hook me up with his user name, they were friends. Im not trying to be creepy or hunt down the guy, but his Sti was clean as hell and my friend wants to check it out. Thanks!
kered9 is offline   Reply With Quote
Old 04-02-2012, 11:56 AM   #5505
Jovver
Scooby Specialist
 
Member#: 107076
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Richfield, Ohio
Vehicle:
'06 WRX STi (WRB)
'06 Outback LTD (WGO/MGM)

Default

That would be Dirty25RS. He made a post a page back or so and his FB is linked right under his screen name if you need to get a hold of him.
Jovver is offline   Reply With Quote
Old 04-02-2012, 02:10 PM   #5506
silver03rex
Scooby Newbie
 
Member#: 301599
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Parma
Vehicle:
03 WRX
PSM

Default

any one in or near parma good with open source tuning/data logging? my car recently started to run a little rough, could feel it cutting power on the highway and my a/f was tuned to run at 12, now if i run wide open it start at 12.2 then jumps to 13. trying to get an idea of what i can look into.
silver03rex is offline   Reply With Quote
Old 04-02-2012, 02:29 PM   #5507
Dirty25RS
Scooby Specialist
 
Member#: 56731
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Akron, Ohio
Vehicle:
2004 STi, 00 Insight
10 Volvo C30R-d 11 F150

Default

yep, thats me
Dirty25RS is offline   Reply With Quote
Old 04-02-2012, 02:32 PM   #5508
jmikolich
Scooby Newbie
 
Member#: 210165
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Brunswick, OH
Vehicle:
2006 STI
OBP

Default

Quote:
Originally Posted by silver03rex
any one in or near parma good with open source tuning/data logging? my car recently started to run a little rough, could feel it cutting power on the highway and my a/f was tuned to run at 12, now if i run wide open it start at 12.2 then jumps to 13. trying to get an idea of what i can look into.
Are you logging a wideband? When you say highway do you mean in 6th or 5th? What tune do you currently have? Pro tune self tune buddy tune?

Has anything changed? Maintenance?
jmikolich is offline   Reply With Quote
Old 04-02-2012, 02:49 PM   #5509
silver03rex
Scooby Newbie
 
Member#: 301599
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Parma
Vehicle:
03 WRX
PSM

Default

5th gear on the highway, it happens in any gear under full throttle. yes, that going off the wideband. the only thing thats changed is the rear suspension from a small accident. and it's been tuned by the previous owner not a pro, it's ran fine for months.
silver03rex is offline   Reply With Quote
Old 04-02-2012, 03:11 PM   #5510
Dirty25RS
Scooby Specialist
 
Member#: 56731
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Akron, Ohio
Vehicle:
2004 STi, 00 Insight
10 Volvo C30R-d 11 F150

Default

log injector duty cycles, and boost, If you could log fuel pressure that'd help to but i doubt you can.
Dirty25RS is offline   Reply With Quote
Old 04-02-2012, 03:22 PM   #5511
silver03rex
Scooby Newbie
 
Member#: 301599
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Parma
Vehicle:
03 WRX
PSM

Default

do you know of anyone who have a cable that i can do logging with?
silver03rex is offline   Reply With Quote
Old 04-02-2012, 03:29 PM   #5512
jmikolich
Scooby Newbie
 
Member#: 210165
Join Date: Apr 2009
Chapter/Region: MWSOC
Location: Brunswick, OH
Vehicle:
2006 STI
OBP

Default

Quote:
Originally Posted by Dirty25RS
log injector duty cycles, and boost, If you could log fuel pressure that'd help to but i doubt you can.
Bingo that's a good start, how long have you noticed this? Is it confined to this tank of gas or multiple tanks?

I don't know much about the 5sp on the maps, you traditionally just scale overdrive and don't tune due to the rarity of full throttle/high RPM in OD

Also I have a tactrix 2.0 cable but not a laptop I can loan you, should work with the 03s but youd need the reflash connectors which I don't think I have (but I might) if you change the map
jmikolich is offline   Reply With Quote
Old 04-02-2012, 04:05 PM   #5513
silver03rex
Scooby Newbie
 
Member#: 301599
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Parma
Vehicle:
03 WRX
PSM

Default

yeah, i've ran a few tanks of gas on it. I also have laptops that i can use, im going to be getting all the different tunes from the previous owner. I just noticed it within the last 10 days, (3 tanks of gas) even when running half throttle in 3rd or 4th it sits around 12.2 which is ok for 10-13psi, but when running wideopen 22psi (tuned at that) the ratio climbs to 13. when cruising on the highway just maintaining speed it sits at 14.7 which is what it's tuned for.

jmikolich shoot me a text if your going to be in or around strongsville, i pick my kid up from daythere at 5:15 everyday.


thanks
jeremy

Last edited by silver03rex; 04-03-2012 at 01:51 PM.
silver03rex is offline   Reply With Quote
Old 04-02-2012, 05:05 PM   #5514
Dirty25RS
Scooby Specialist
 
Member#: 56731
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Akron, Ohio
Vehicle:
2004 STi, 00 Insight
10 Volvo C30R-d 11 F150

Default

Quote:
Originally Posted by silver03rex View Post
yeah, i've ran a few tanks of gas on it. I also have laptops that i can use, im going to be getting all the different tunes from the previous owner. I just noticed it within the last 10 days, (3 tanks of gas) even when running half throttle in 3rd or 4th it sits around 12.2 which is ok for 10-13psi, but when running wideopen 22psi (tuned at that) the ratio climbs to 13. when cruising on the highway just maintaining speed it sits at 14.7 which is what it's tuned for.

jmikolich shoot me a text if your going to be in or around strongsville, i pick my kid up from daythere at 5:15 everyday.

440-539-7618

thanks
jeremy
1. stock turbo?
2. stock injectors?

22psi on the stock turbo is too high for a WRX, you're just making a lot more heat than airflow, but thats beside the point.

The point is that its my understanding that the stock injectors are just maxed out around 18-19psi.

I bet you find 100% duty cycles when you log.
Dirty25RS is offline   Reply With Quote
Old 04-02-2012, 06:56 PM   #5515
silver03rex
Scooby Newbie
 
Member#: 301599
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Parma
Vehicle:
03 WRX
PSM

Default

it's a stock turbo yes, it's been ported n polished, from what i was told is 850cc injectors, ported polished heads, it's not stock by any means. as soon as i can get some logging done i will post it up in here. i know nothing about tuning or maps.
silver03rex is offline   Reply With Quote
Old 04-02-2012, 07:39 PM   #5516
MouseMarine
Scooby Newbie
 
Member#: 312313
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Wadsworth, OH
Vehicle:
2010 WRX Hatchback
White

Default

Do you notice your Kartboy shifter further forward than the original shifter? Neutral is now like 3rd gear for me now with the new shifter. Still feels great, just different.
MouseMarine is offline   Reply With Quote
Old 04-02-2012, 09:25 PM   #5517
jrt20
Scooby Newbie
 
Member#: 296210
Join Date: Sep 2011
Chapter/Region: MWSOC
Location: Lake County, OH
Vehicle:
2013 STI
WR Blue Pearl

Default

Quote:
Originally Posted by MouseMarine
Do you notice your Kartboy shifter further forward than the original shifter? Neutral is now like 3rd gear for me now with the new shifter. Still feels great, just different.
Ummm not that I noticed. I also did the bushings as well.
jrt20 is offline   Reply With Quote
Old 04-02-2012, 09:37 PM   #5518
MouseMarine
Scooby Newbie
 
Member#: 312313
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Wadsworth, OH
Vehicle:
2010 WRX Hatchback
White

Default

Quote:
Originally Posted by jrt20 View Post
Ummm not that I noticed. I also did the bushings as well.
If I could attach a picture, I would see what you think. Mine just looks awkward.
MouseMarine is offline   Reply With Quote
Old 04-02-2012, 09:41 PM   #5519
jrt20
Scooby Newbie
 
Member#: 296210
Join Date: Sep 2011
Chapter/Region: MWSOC
Location: Lake County, OH
Vehicle:
2013 STI
WR Blue Pearl

Default

Quote:
Originally Posted by MouseMarine

If I could attach a picture, I would see what you think. Mine just looks awkward.
Yea. Attach a picture. If that doesn't work, I will be at Applebee's Thursday.

Last edited by jrt20; 04-02-2012 at 10:10 PM.
jrt20 is offline   Reply With Quote
Old 04-02-2012, 10:37 PM   #5520
MouseMarine
Scooby Newbie
 
Member#: 312313
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Wadsworth, OH
Vehicle:
2010 WRX Hatchback
White

Default


Neutral Position

Everything off.

Last edited by MouseMarine; 04-02-2012 at 10:46 PM.
MouseMarine is offline   Reply With Quote
Old 04-02-2012, 11:07 PM   #5521
jrt20
Scooby Newbie
 
Member#: 296210
Join Date: Sep 2011
Chapter/Region: MWSOC
Location: Lake County, OH
Vehicle:
2013 STI
WR Blue Pearl

Default

Quote:
Originally Posted by MouseMarine
Neutral Position

Everything off.
Well you were not joking. It does seem to be forward. I will take a gander at mine in the morning and try to post pics.
jrt20 is offline   Reply With Quote
Old 04-03-2012, 07:41 AM   #5522
Jovver
Scooby Specialist
 
Member#: 107076
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Richfield, Ohio
Vehicle:
'06 WRX STi (WRB)
'06 Outback LTD (WGO/MGM)

Default

Is the stalk bent or is it straight? What would happen if you rotated it 180 degrees front to back?
Jovver is offline   Reply With Quote
Old 04-03-2012, 08:11 AM   #5523
GromsKillA
Scooby Newbie
 
Member#: 292760
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Ohio
Vehicle:
2005 CGM STi
'02 Impreza OBS

Default

Quote:
Originally Posted by Jovver
Is the stalk bent or is it straight? What would happen if you rotated it 180 degrees front to back?
That's what I was thinking, it looks curved toward the bottom. Maybe it's in backwards? I am used to seeing the 6 speed shifter so I don't know what the 5 speed is supposed to look like. Good luck.
GromsKillA is offline   Reply With Quote
Old 04-03-2012, 08:29 AM   #5524
MouseMarine
Scooby Newbie
 
Member#: 312313
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Wadsworth, OH
Vehicle:
2010 WRX Hatchback
White

Default

It is supposed to be bent backwards. I even did turn it 180 degrees to make sure and it was crazy angled forward in neutral.
MouseMarine is offline   Reply With Quote
Old 04-03-2012, 08:45 AM   #5525
jrt20
Scooby Newbie
 
Member#: 296210
Join Date: Sep 2011
Chapter/Region: MWSOC
Location: Lake County, OH
Vehicle:
2013 STI
WR Blue Pearl

Default

Quote:
Originally Posted by MouseMarine
It is supposed to be bent backwards. I even did turn it 180 degrees to make sure and it was crazy angled forward in neutral.
It's right. I looked at mine and it's the same. The picture just made it look funky.
jrt20 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling All Cleveland Area Scooby owners!!! nick32 Mid West Subaru Owners Club Forum -- MWSOC 21 04-03-2008 04:55 AM
Cleveland Ohio I-Club jayfressh Mid West Subaru Owners Club Forum -- MWSOC 9 04-02-2002 06:44 PM
Vin #11 1998 SOA 2.5L RS at Cleveland Ohio AutoRama!!!! black99gt Member's Car Gallery 4 01-21-2002 10:31 PM
Need WRX-help in Cleveland, Ohio... Shaka Factory 2.0L Turbo Powertrain 3 11-12-2001 10:05 AM
('93-'01) Cleveland, Ohio - A day at the drag strip event! Shaka Impreza Forum 9 10-04-2001 11:58 AM


All times are GMT -4. The time now is 01:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.