Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-05-2012, 11:15 PM   #1
mpristave
Scooby Newbie
 
Member#: 284761
Join Date: Jun 2011
Vehicle:
2012 WRX

Default 12 WRX turn signal always going out.

About to bring my WRX for a 3rd warranty replacement on my left turn signal. Just wondering what could be the cause of this constantly going out? The first time they said that it could have been a kink in the wiring from the factory so they replaced the harness and that fixed it for a time until it went out again.

The light activates when the turn signal is put on but its very dim, looks like only 1 of the 2 filaments inside the light go on. Any ideas?
* Registered users of the site do not see these ads.
mpristave is offline   Reply With Quote
Old 04-07-2012, 11:33 PM   #2
Allen Horton
Scooby Newbie
 
Member#: 315961
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2008 WRX
Dark gray metallic

Default

I am having the same issue, and will be visiting my dealer on monday afternoon. Please let us know if they give you a legitimate reason (doubtful) and I promise to do the same. It wouldnt be such a big deal if it wasnt such an involved job to replace :/
Allen Horton is online now   Reply With Quote
Old 04-08-2012, 12:01 PM   #3
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

It would be a good thing to check the power getting to the light. If the full 12 volts is getting to the lamp when it is on then it means there is a ground connection problem to that lamp. If the voltage is low then there is a problem in the wiring on the power side of the circuit.
Cougar4 is offline   Reply With Quote
Old 04-08-2012, 12:36 PM   #4
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2015 Forester
SWP

Default

Driver side blinker? I thought there was a recall out for this and the fix was to push the plug harder onto the bulb?
infinite012 is online now   Reply With Quote
Old 04-09-2012, 10:04 PM   #5
Allen Horton
Scooby Newbie
 
Member#: 315961
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2008 WRX
Dark gray metallic

Default

Infinite, you would be correct. I just posted a reply in the warranty/ electrical thread. Wires can be pulled to tight during the car building process. Push the base harder... It will work fine, reroute the wires and relieve any tension, in theory, FIXED.
Allen Horton is online now   Reply With Quote
Old 04-24-2012, 08:18 PM   #6
Jon-Preza
Scooby Newbie
 
Member#: 299412
Join Date: Oct 2011
Chapter/Region: TXIC
Location: San Angelo, TX
Vehicle:
2011 Subaru Impreza
Camelia Red Pearl

Default

I just noticed this thread. I just replaced my bulb again for the 2nd time in 6 months of owning the car. I will try this fix and see what happens. It seems to work for me for a few months and then it goes out.
Jon-Preza is offline   Reply With Quote
Old 04-24-2012, 08:28 PM   #7
f1speeder
Scooby Specialist
 
Member#: 138854
Join Date: Jan 2007
Chapter/Region: Tri-State
Default

Here is my Thread on it with some fix it yourself instructions. By the way it's not just the bulb. It's the wiring harness.


http://forums.nasioc.com/forums/show....php?t=2174949
f1speeder is offline   Reply With Quote
Old 04-24-2012, 11:37 PM   #8
Jon-Preza
Scooby Newbie
 
Member#: 299412
Join Date: Oct 2011
Chapter/Region: TXIC
Location: San Angelo, TX
Vehicle:
2011 Subaru Impreza
Camelia Red Pearl

Default

Quote:
Originally Posted by f1speeder
Here is my Thread on it with some fix it yourself instructions. By the way it's not just the bulb. It's the wiring harness.

http://forums.nasioc.com/forums/show....php?t=2174949
Thanks for the link. I did notice when I replaced the bulb that the harness was awfully tight. I will just take it in next weekend and have it fixed for free. Might as well.

Thanks for the help.
Jon-Preza is offline   Reply With Quote
Old 04-27-2012, 04:42 PM   #9
hakira
Scooby Specialist
 
Member#: 74211
Join Date: Nov 2004
Location: 34′33″S 3721
Vehicle:
2011
SSM WRX 4DR

Default

i just pushed in the connector in with more pressure.. for worked me for more than 20k miles now
hakira is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal fuse blowing out repetitively tehhali Electrical & Lighting 7 05-28-2014 10:05 PM
Why do American punk-rock boys always go out with the new-wave hooker girls? Protege Menace Off-Topic 2 10-19-2004 07:38 AM
2004 wrx turn signal bulb 04subaru Electrical & Lighting 3 10-05-2003 03:01 PM
WRX turn signal bulbs??? STEVESblueWRX Newbies & FAQs 2 01-03-2002 10:34 PM
('93-'01) WRX turn signal bulb size?????? BkylnWReX Impreza Forum 0 06-02-2001 06:19 PM


All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.