Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-07-2012, 08:09 PM   #1
chansen42
Scooby Newbie
 
Member#: 305256
Join Date: Dec 2011
Chapter/Region: MWSOC
Location: Geneva, IL
Vehicle:
2004 Wrx
Silver

Default 04 WRX - No power windows, no power locks, no illumination lights!!!

Hey everyone

I've been battle this issue for about a week...

It all started when my fog lights stopped working. Checked the fuse, it was fine... figured it was the relay. I pulled the relay and swapped it with the A/C relay and it was working fine... plugged it back in and then power windows, power locks, and all illumination stopped working... all fuses are in tact.

any help is much appreciated.

thanks
* Registered users of the site do not see these ads.
chansen42 is offline   Reply With Quote
Old 05-07-2012, 09:05 PM   #2
minifreak
Scooby Specialist
 
Member#: 116914
Join Date: Jun 2006
Chapter/Region: VIC
Location: Beautiful British Columbia
Vehicle:
2006 WRX Wagon
Obsidian Black

Default

Did you checked the fuse box besides the steering wheel? Swap out the fuse for a new one. A fuse could be blown even when it looks intact.
minifreak is offline   Reply With Quote
Old 05-07-2012, 09:18 PM   #3
chansen42
Scooby Newbie
 
Member#: 305256
Join Date: Dec 2011
Chapter/Region: MWSOC
Location: Geneva, IL
Vehicle:
2004 Wrx
Silver

Default

replaced the illumination fuse just now and that started working again. the locks work too now... still no windows!
doesn't matter which switches i use, not one window will budge. and i don't hear a click from the relay either

Last edited by chansen42; 05-07-2012 at 09:27 PM.
chansen42 is offline   Reply With Quote
Old 05-08-2012, 07:19 AM   #4
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Fuse SBF-6 in the panel under the hood supplies power to the windows. Use a test light to verify power is getting to both sides of the fuse. If that is ok then check the wiring going to that fuse location is making good connection.
Cougar4 is offline   Reply With Quote
Old 08-08-2014, 04:58 PM   #5
Dcasta9
Scooby Newbie
 
Member#: 339589
Join Date: Dec 2012
Chapter/Region: BAIC
Default

I'm gonna bump this from the dead, I have the same issues right now on my '02 wrx, did you ever figure it out!?
Dcasta9 is offline   Reply With Quote
Old 08-20-2014, 12:02 AM   #6
Anthonym1979
Scooby Newbie
 
Member#: 399460
Join Date: Aug 2014
Location: pittsburgh
Vehicle:
2002 wrx

Default

iam having a similar problem with my 2002 wrx the turn signals and all the power windows don't work I have tracked the problem down to the green/white wire on the coil side of the relay on the dash has no voltage , I can get everything to work with a power probe . I have looked at wiring schematics and I cant find were the green/white wiring is feed from
Anthonym1979 is offline   Reply With Quote
Old 08-20-2014, 12:32 PM   #7
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

Quote:
Originally Posted by Anthonym1979 View Post
iam having a similar problem with my 2002 wrx the turn signals and all the power windows don't work I have tracked the problem down to the green/white wire on the coil side of the relay on the dash has no voltage , I can get everything to work with a power probe . I have looked at wiring schematics and I cant find were the green/white wiring is feed from
That relay is most likely the ignition relay. Data shows that a grn/wht wire is tied to the output side of the relay contacts. A wht/blu wire supplies the power to the relay contact. Verify that those points are getting proper power while the trouble is happening. If there is a problem at the input side there is a connection at connector B62 pin-1 where the problem might be at.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 STI Gauge Cluster into 04 WRX - Brake light? Craigster05 Electrical & Lighting 4 01-11-2010 12:49 PM
WTB: 2000 Legacy Driver Power Window Switch/Doors Lock Assembly eternum Private 'Wanted' Classifieds 0 04-30-2006 05:12 PM
power windows and power door locks zuhi Electrical & Lighting 4 04-23-2005 04:11 PM
04 WRX - Window tint affect reception? IMPRZV1 Car Audio, Video & Security 21 04-21-2004 03:28 AM
Sunroof in 04 WRX - Yes in 04 STi yes or no? TheShadowWRX STi Forum Archive 29 01-08-2003 04:55 PM


All times are GMT -4. The time now is 10:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.