Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-14-2012, 10:12 PM   #11
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2015 Forester
SWP

Default

Did you install anything else or put the car in valet mode or something?
infinite012 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch "clicking" in 2012 wrx STIDAWG Transmission (AT/MT) & Driveline 7 03-16-2013 11:22 PM
Where to ground in 2012 wrx hatch? slowhat Car Audio, Video & Security 3 02-24-2012 11:35 PM
pioneer avh-p4000 install in 06sti nation1979 Car Audio, Video & Security 25 02-26-2009 01:47 AM
Pictures of Hid's installed in '02 WRX :) paultg New England Impreza Club Forum -- NESIC 7 12-16-2001 04:22 PM
Found out a short throw shifter wasn't installed in my WRX.. cout Bay Area Impreza Club Forum -- BAIC 5 05-03-2001 05:59 PM


All times are GMT -4. The time now is 02:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.