Welcome to the North American Subaru Impreza Owners Club Tuesday October 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-18-2012, 07:14 PM   #1
Scooby Specialist
Member#: 132587
Join Date: Nov 2006
Location: Lincoln, NE
2006 JrTuned STi
Stock engine 9.77@147mph

Default JR Tuned **stock block** 2006 GT3582 E85 STi goes 10.83@126mph

**edit** 3/19/13

First of all I really hope this doesn't get deleted as it will soon have track results/dyno numbers in the thread at some point.

I want to post in this section b/c this is where all of the knowledge of Nasioc resides and all of those who I respect regularly post in here running/tuning big setups so I come for help/advice/etc.

Really hoping this turns into a long thread with quite a few replies and can document the progress my car makes, anyways let me get to the point...I am STRUGGLING with the car ever since going rotated. Some of you recall my stock turbo set up being pretty strong and I really never had any problems, well it has been the exact opposite experience with the new setup.

Currently running a treadstone engineering rotated kit that I picked up from a friend at a friend price. Paired it with a Garrett 3582, tial 44, tial q bov, etc. Standard stuff that everybody uses....as far as my fuel system I had a set of 1200cc side feed FiveO Motorsport injectors and still running my trusty walbro 255 in the tank. After the reassembly of the car it ran terribly and was constantly dying and would not idle, hardly wanted to cruise, etc. Nobody could figure it out, I assumed it was all tuning but had 1 then 2 then 3 different people look at it with no results. Finally got the car to idle ok and cruise ok but coming off of cruise it would not transition to idle and would either die or stumble violently until it either killed itself or I shut it down (AFRs pegging rich) on the wideband.

Had numerous people suggest it was the FiveO injectors which were never going to work since they were big sidefeeds. Was talked into going top feeds so I spared no expense on injectors and bought a new set of ID2000s. Got hooked up through a friend on a set of factory wrx rails and FPR and scored a set of TGV deletes from another friend. At this point I was excited and expected the problems to be solved...get it put together and NO CHANGE.

Next chapter, I boost leak tested the car for the 10th time and somehow I all of a sudden had quite a few leaks including the intake to tgv gaskets so I think maybe that is my problem. Tore it all back apart for the 2nd time in a couple days and get it back together and NO CHANGE.

Current chapter, I left the car with one of my EVO friends and he has been playing with it everyday for more hours than I care to know (awesome friend) him and his tuner have been playing around with the car and at this point I don't really care b/c I have the "try whatever, I am out of ideas" attitude. Well the car started to idle ok and cruise really well and it no longer was dying in between transition from cruise to idle but it is still rough to say the least and I will NEVER be happy with it in it's current state. Either way the car got to the point where they were doing some WOT pulls and have worked up to 22psi but when trying to bump it up to 24 psi they noticed it leaning out which indicated maybe a lack of fuel pressure. Sure enough put a fuel pressure gauge on it and it is dropping from about 62psi back to 55psi in the upper RPM range...so another problem...grrrreat.

At first we thought maybe the pump was running out of flow so he put in a Jays Racing 342lph pump he had laying around, no change. Ok so maybe the FPR is bad, changed it out and no change. Lastly maybe the fuel filter is plugged, removed the filter and no change. We are reading fuel pressure right off of the main supply coming into the engine bay near the drivers strut tower. So not sure what to check next...

Now if any of you made it through the novel (which has been 4 months of my life) Here are my questions:

1. What else can I try to solve the fuel pressure drop? I can't imagine we are maxing out the factory fuel lines since we are only at 22psi.

2. What can I do about the terrible driveability?

It is not enjoyable to drive at all, if I was assured I could drop it off at a shop and pick it up in perfect driving condition with only a tune I would trailer this thing anywhere in the country and leave it...but I don't want to fall into a situation where I end up with a $2000 tune due to a million hours on the dyno...any thoughts?


Just wanted to update this first post with some results that can be found later on in the thread (Page 14)

Time slip:

Track Video:

Last edited by C J; 03-19-2013 at 08:18 PM.
C J is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007/2008 STI = Same R180 ? experts please! Team Scream Transmission (AT/MT) & Driveline 9 05-21-2013 03:02 PM
2006 Forester E85 / Mustang Dyno PoZeR Proven Power Bragging 8 06-29-2011 03:51 PM
FS : 2006 Aspen White STI (Ready for E85 conversion) biker921 Private Vehicle 'For Sale' Classifieds 0 08-08-2010 10:43 AM
Cheap quiet RCA's please? Experts, please contribute. ebeck Car Audio, Video & Security 20 11-29-2004 01:22 PM

All times are GMT -4. The time now is 03:14 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.