Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-24-2012, 02:59 PM   #5526
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Quote:
Originally Posted by DirknJirkn13 View Post
How is the quality of the mic? I also have a Pioneer HU and tried mounting it where you did, but people on the other end of the call complained that is sounded terrible. I have it mounted on the dash now above the gauges, but still the same stuff.
My pioneer mic is mouted right inside guage cluster and with windows up works great.
* Registered users of the site do not see these ads.
BWX is offline   Reply With Quote
Old 06-24-2012, 04:09 PM   #5527
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by daigledangle8

I believe it does but I am not 100% positive
Judging from pictures it should be a direct fit. But instead of a coin holder in between the cup holders and the shifter, it's got slots where the SI drive is.
fancyfootwork15 is offline   Reply With Quote
Old 06-24-2012, 06:27 PM   #5528
Daniel208
Scooby Newbie
 
Member#: 318639
Join Date: Apr 2012
Chapter/Region: NWIC
Location: North Idaho
Vehicle:
2010 Impreza 2.5i
Spark Silver

Default

Quote:
Originally Posted by DirknJirkn13 View Post
How is the quality of the mic? I also have a Pioneer HU and tried mounting it where you did, but people on the other end of the call complained that is sounded terrible. I have it mounted on the dash now above the gauges, but still the same stuff.
I haven't tried it with the windows down yet, but it still has a-lot of static but the person on the other line can still hear me. I'm gonna look around and see if I can find a better mic for a good price and try mounting it by the front light in the headliner.
Daniel208 is offline   Reply With Quote
Old 06-24-2012, 06:39 PM   #5529
BSP671
Scooby Newbie
 
Member#: 288190
Join Date: Jul 2011
Location: Guam
Vehicle:
2009 Impreza 2.5i
Spark Silver

Default

Quote:
Originally Posted by daigledangle8
I needed to replace my tail lights anyways and I saw that these were cheaper than OEM replacements so I asked my girlfriend to pick them up for me for my birthday. So far I have zero complaints with them. I will confirm that they are sealed properly after the first rainfall tonight.

http://www.ebay.com/itm/DEPO-08-11-S...#ht_5472wt_954
Shoulda jumped the gun on that. Needed to replace my tails cuz some doucher clipped the passenger side tail and chipped off two pieces and a quote from the stealership was 465.89 for only one piece! So I cheaped out and super glued the pieces back together and vinyl tint wrapped it
BSP671 is offline   Reply With Quote
Old 06-25-2012, 09:55 AM   #5530
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by fancyfootwork15 View Post
Any of you guys know if the 09 Sti center console will fit in a sedan 2.5?
if your talking about the center panel for the stereo and the vents, ill get back to you. Found one in japan for $10.
theoutbackdream is offline   Reply With Quote
Old 06-25-2012, 10:28 AM   #5531
Ogden
Scooby Specialist
 
Member#: 1748
Join Date: Jun 2000
Chapter/Region: NESIC
Location: Boston, MA, USA
Vehicle:
'09 Outback Sport
OBP over DGM

Default

Post Deleted

Last edited by Ogden; 06-25-2012 at 12:32 PM. Reason: Everyone else already pointed out what I was going to say.
Ogden is offline   Reply With Quote
Old 06-25-2012, 12:36 PM   #5532
Ogden
Scooby Specialist
 
Member#: 1748
Join Date: Jun 2000
Chapter/Region: NESIC
Location: Boston, MA, USA
Vehicle:
'09 Outback Sport
OBP over DGM

Default

Quote:
Originally Posted by theoutbackdream View Post
if your talking about the center panel for the stereo and the vents, ill get back to you. Found one in japan for $10.
The roll-top center console will fit, but it mounts a bit differently, so you may need to do some fabricating. I dont' have the detials but somene over on 3gwrx.com did the conversion a while back. THe STI console also has different heated seat switches (if you have heated seats) that are not compatible, so you can't just swap the 2.5i ones for the STI ones.

The previous gen Legacy consoles may also fit. They had the roll-top cup holder as well. I have one, but haven't had a chance to really play with it yet to see. The Legacy console also has incompatible heated seat switches. This is part of the reason that I haven't installed it yet. I need to fabricate some sort of panel to mount the swithces to.
Ogden is offline   Reply With Quote
Old 06-25-2012, 01:11 PM   #5533
fancyfootwork15
Scooby Specialist
 
Member#: 262503
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Minneapolis
Vehicle:
2008 Impreza 2.5i

Default

Quote:
Originally Posted by Ogden

The roll-top center console will fit, but it mounts a bit differently, so you may need to do some fabricating. I dont' have the detials but somene over on 3gwrx.com did the conversion a while back. THe STI console also has different heated seat switches (if you have heated seats) that are not compatible, so you can't just swap the 2.5i ones for the STI ones.

The previous gen Legacy consoles may also fit. They had the roll-top cup holder as well. I have one, but haven't had a chance to really play with it yet to see. The Legacy console also has incompatible heated seat switches. This is part of the reason that I haven't installed it yet. I need to fabricate some sort of panel to mount the swithces to.
Awesome thanks for the info. I'll have to do a test fit.
fancyfootwork15 is offline   Reply With Quote
Old 06-25-2012, 04:25 PM   #5534
RyanChadwick
Scooby Newbie
 
Member#: 319509
Join Date: May 2012
Location: South Glens Falls, New York
Vehicle:
2008 Impreza 2.5i

Default

I have the. 08 2.5i with about 40k on it. The check engine light went on and stayed on so I brought it to the local parts shop and tested it. It's telling me it's miss firing on all 4 cylinders. Any ideas guys?
RyanChadwick is offline   Reply With Quote
Old 06-25-2012, 05:18 PM   #5535
bradyarz
Scooby Newbie
 
Member#: 272381
Join Date: Jan 2011
Chapter/Region: MAIC
Vehicle:
2008 Impreza OBS
Silver

Default

Quote:
Originally Posted by RyanChadwick View Post
I have the. 08 2.5i with about 40k on it. The check engine light went on and stayed on so I brought it to the local parts shop and tested it. It's telling me it's miss firing on all 4 cylinders. Any ideas guys?
Possible things to check:
Coils
Plugs
Wires

It's highly unlikely you have 4 bad plugs, but who knows - stranger things have happened. My grandfather once went back and forth to the parts store with plugs for his old v8 olds. He found at least one bad plug in 7 packs. He returned each set until he finally found 8 good plugs in the 8th pack.
bradyarz is offline   Reply With Quote
Old 06-25-2012, 05:36 PM   #5536
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

RyanChadwick take it to a mechanic... that have real tools.
-oh, ad check fuel filler tube cap.

Last edited by BWX; 06-25-2012 at 05:43 PM.
BWX is offline   Reply With Quote
Old 06-25-2012, 05:46 PM   #5537
RyanChadwick
Scooby Newbie
 
Member#: 319509
Join Date: May 2012
Location: South Glens Falls, New York
Vehicle:
2008 Impreza 2.5i

Default

I'm bringing it in this Friday. I just figured I'd check and see if any one has had similar problems before I pay to figure it out.
RyanChadwick is offline   Reply With Quote
Old 06-25-2012, 06:48 PM   #5538
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Did you have all the 30k mile maintenance done?

It could be just a failed sensor, and the scan tool at parts shop is BS.

Misfire on all four? Doubtful, and I never saw a ''code'' that was a ''misfire on all cylinders''.

He should have given you an actual code that usually have several possibilities, that you can look up and test. I'd call BS on parts store diagnostics and start from scratch.



Check gas cap.
BWX is offline   Reply With Quote
Old 06-25-2012, 07:01 PM   #5539
RyanChadwick
Scooby Newbie
 
Member#: 319509
Join Date: May 2012
Location: South Glens Falls, New York
Vehicle:
2008 Impreza 2.5i

Default

It said miss fire on cylinder 1, misfire on cylinder 2, so on and so forth. I did it my self.
RyanChadwick is offline   Reply With Quote
Old 06-25-2012, 07:02 PM   #5540
RyanChadwick
Scooby Newbie
 
Member#: 319509
Join Date: May 2012
Location: South Glens Falls, New York
Vehicle:
2008 Impreza 2.5i

Default

As far as 30k maintenance I'm not sure I bought it at 32k so I'm assuming the Subaru dealer would know and did it. But i can figure it out.
RyanChadwick is offline   Reply With Quote
Old 06-25-2012, 07:03 PM   #5541
howtypical
Scooby Newbie
 
Member#: 310053
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: Poughkeepsie
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

May or may not have ruined my trunk light trying to wire in some LEDs.
howtypical is offline   Reply With Quote
Old 06-25-2012, 10:45 PM   #5542
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by howtypical
May or may not have ruined my trunk light trying to wire in some LEDs.
How so?
DirknJirkn13 is online now   Reply With Quote
Old 06-26-2012, 12:13 AM   #5543
howtypical
Scooby Newbie
 
Member#: 310053
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: Poughkeepsie
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

Quote:
Originally Posted by DirknJirkn13 View Post
How so?
Well, I went with my best friend (whose into wiring and electronics and such) to Advance to buy some LEDs to replace my dome light with. Long story short, to put them in turned into a "thing", so we tried to do it with the light in the hatch. That too turned into a "thing". We pulled out the little plastic piece that holds the bulb, and removed it, figuring that if we could get the metal parts that actually hold the bulb in place out (in a safe, non-destructive fashion) we could just pop this light in and call it a day. We got one of the metal doo-dads out, but the other wouldn't budge - then it started pouring out of no where. So I put it all back together and popped it back in, but the light wouldn't work. I'm thinking (hoping, really) that we just put something in backwards. Any other thoughts? I'll try to take pictures or something tomorrow.
howtypical is offline   Reply With Quote
Old 06-26-2012, 12:16 AM   #5544
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

did you leave the battery connected? I suspect it could be a short too... needing a new fuse. I had my battery disconnected and I had touched both +/- side very easily.

BTW, what started pouring?
theoutbackdream is offline   Reply With Quote
Old 06-26-2012, 12:22 AM   #5545
howtypical
Scooby Newbie
 
Member#: 310053
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: Poughkeepsie
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

Quote:
Originally Posted by theoutbackdream View Post
did you leave the battery connected? I suspect it could be a short too... needing a new fuse. I had my battery disconnected and I had touched both +/- side very easily.

BTW, what started pouring?
Haha the rain sir; it was on and off all day.

I was thinking it could be a short too. We did leave the batter connected. Was that a stupid thing? How would a get a new fuse and where would I install it? I'm clueless about wiring. I figured putting in some LEDs would be something quick and easy.
howtypical is offline   Reply With Quote
Old 06-26-2012, 12:27 AM   #5546
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by howtypical View Post
Haha the rain sir; it was on and off all day.

I was thinking it could be a short too. We did leave the batter connected. Was that a stupid thing? How would a get a new fuse and where would I install it? I'm clueless about wiring. I figured putting in some LEDs would be something quick and easy.
I see.

Yes, it was a "dumb" thing to do, but hey we all make mistakes. Just go to your local auto store and they should have a fuse to replace. You would put it in your fuse box...??????????
theoutbackdream is offline   Reply With Quote
Old 06-26-2012, 12:27 AM   #5547
howtypical
Scooby Newbie
 
Member#: 310053
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: Poughkeepsie
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

Quote:
Originally Posted by theoutbackdream View Post
I see.

Yes, it was a "dumb" thing to do, but hey we all make mistakes. Just go to your local auto store and they should have a fuse to replace. You would put it in your fuse box...??????????
Sorry, noob here. Thanks man.
howtypical is offline   Reply With Quote
Old 06-26-2012, 01:16 AM   #5548
BSP671
Scooby Newbie
 
Member#: 288190
Join Date: Jul 2011
Location: Guam
Vehicle:
2009 Impreza 2.5i
Spark Silver

Default

Shoulda just bought the dome light led replacements....plug and play for less than 20 bucks lol
BSP671 is offline   Reply With Quote
Old 06-26-2012, 02:40 AM   #5549
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

^now that you say that, i wonder what kind of LEDs he bought. :shocked:
theoutbackdream is offline   Reply With Quote
Old 06-26-2012, 12:48 PM   #5550
howtypical
Scooby Newbie
 
Member#: 310053
Join Date: Feb 2012
Chapter/Region: Tri-State
Location: Poughkeepsie
Vehicle:
2008 Impreza 2.5i
Dark Gray Metallic

Default

Quote:
Originally Posted by BSP671 View Post
Shoulda just bought the dome light led replacements....plug and play for less than 20 bucks lol
That's exactly what these were marketed as at the store. They're plug and play, and were exactly 20 bucks. Problem is though that they look like crap. They plug in using a "mock bulb" that sends the power to this panel of LEDs. The only place to stick the panel is off the center, and it just doesn't look very good; kinda ricey. I'm gonna see if I can return them today, as well as fix that blown fuse. I thought I was saving money by a cheapo LED set from advance, but for cheaper I could have bought these: http://store.ijdmtoy.com/DE3175-DE30...-1-25-s/38.htm
They fit right in like the regular bulb.
Live and learn, I suppose. Right?
howtypical is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM


All times are GMT -4. The time now is 01:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.