Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-30-2012, 04:06 PM   #1
kgounden
Scooby Newbie
 
Member#: 229178
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Toledo, OH
Vehicle:
2010 WRX Hatch
Spark Silver

Default 2010 wrx clutch noise/squeak?


So I have noticed that when i push in the clutch pedal I hear this squeaky noise but it happens only when the car is on. I have been to the dealer and they bled the clutch cylinder (suspected air was in there). However the noise came back after a few days. I went back to the dealer and of course the car didnt make the noise . So they told me that there was not much they can do. The noise still happens at least once a day but it comes at random times. Sometimes its at start-up but other times not .

I did search the forums however the noise that others are getting sound different to mine. The weird thing is that it never happens when the car is off.

Unlike this one by Haohmaru
http://forums.nasioc.com/forums/show....php?t=2343438

Could it be the throwout bearing? I tried greasing the pedal but no luck.

The only mod I have is a grimmspeed MCB which I installed a few weeks ago. I started hearing the noise before the install. Car has ~36K

Any help would be appreciated. Thanks!
kgounden is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 WRX Clutch Chirp & Squeak Haohmaru Transmission (AT/MT) & Driveline 8 04-22-2012 07:42 PM
07 wrx clutch replacement SQUEAK?? NEED HELP!! shocker47 Transmission (AT/MT) & Driveline 3 04-10-2012 07:23 PM
Clutch noise/squeak subasurf Transmission (AT/MT) & Driveline 2 05-06-2011 12:13 PM
2010 WRX crazy noise after clutch install Odin2347 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 06-27-2010 02:42 AM
06 WRX Clutch Pedal Squeaking suBooneru Warranty Issues & SOA Problems 4 02-08-2006 09:56 AM


All times are GMT -4. The time now is 05:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.