Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-17-2012, 09:22 AM   #1
konsept
Scooby Newbie
 
Member#: 262198
Join Date: Oct 2010
Default 2800-3000 RPM Mis-firing in ALL gears!! Help please! :(

Hey all,

Just looking for ideas on what the issue with my car is.

My tuner pulled logs and sent them to COBB for further analysis, however they think it's the Deatschwerks 1000cc injectors.

I don't know the exact details from a technical stand-point, but my tuner said he encountered a similar issue with another STI running ID 1000cc injectors (different brand).


How it happens:

If I'm driving casually / lightly (less than 25% throttle), it'll bog for a very split second between 2800-3000 rpms. Once it's past 3000 rpms, there are no further issues.

If I press the throttle harder than 25% to about 90%, the bogging / misfiring become more evident and VERY frustrating. If I'm WOT, the nose of the car drops when it reaches 2800-3000rpm then picks up and carries on (from an outsider, it'll look like I'm "shifting").



So are there any known issues with running 1000cc injectors with these cars? What should I do next?

Honestly, I can't stand this car anymore with this issue.




Very quick run down of things that are air and fuel related:

- 2011 STI hatch
- Blouch dominator 2.5 xtr turbo
- deatschwerks 1000cc injectors
- 1-step colder spark plugs
- deatschwerks fuel pump (the drop-in one... 65wc or something like that)
- AMR BMI intake
- AMR front mount intercooler
- COBB AccessPort (using SpeedDensity and protuned)
- TGV Deletes (cosworth)


Datalogs:

konsept is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.