Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-28-2012, 10:23 AM   #1
Frank-i-e
Scooby Specialist
 
Member#: 316463
Join Date: Apr 2012
Location: Houston, Texas
Vehicle:
2005 STi
World Rally Blue

Default Oil Light "on" but how?

Hey guys, so I just bought a 2005 STi and the oil like came on. The thing is, he has an AEM Oil pressure gauge and the OEM on is just there plugged in but not screwed into the block. The gauge reads pressure, and the oil level is appropriate. I just parked it back and stayed home hoping someone could share some knowledge and help me out. The light wasn't on for a little over a week since I have had it. So i don't believe it is cause by the OEM one hanging there but I did move it out of the way a few days ago to slightly hide it more.

Anyone have an idea as to why? I am not driving the car to be safe.

Thanks!
Frank-i-e is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.