Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-30-2012, 03:06 PM   #1
kgounden
Scooby Newbie
 
Member#: 229178
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Toledo, OH
Vehicle:
2010 WRX Hatch
Spark Silver

Default 2010 wrx clutch noise/squeak?


So I have noticed that when i push in the clutch pedal I hear this squeaky noise but it happens only when the car is on. I have been to the dealer and they bled the clutch cylinder (suspected air was in there). However the noise came back after a few days. I went back to the dealer and of course the car didnt make the noise . So they told me that there was not much they can do. The noise still happens at least once a day but it comes at random times. Sometimes its at start-up but other times not .

I did search the forums however the noise that others are getting sound different to mine. The weird thing is that it never happens when the car is off.

Unlike this one by Haohmaru
http://forums.nasioc.com/forums/show....php?t=2343438

Could it be the throwout bearing? I tried greasing the pedal but no luck.

The only mod I have is a grimmspeed MCB which I installed a few weeks ago. I started hearing the noise before the install. Car has ~36K

Any help would be appreciated. Thanks!
* Registered users of the site do not see these ads.
kgounden is offline   Reply With Quote
Old 07-07-2012, 08:46 PM   #2
bdkyzer
Scooby Newbie
 
Member#: 265002
Join Date: Nov 2010
Location: Lexington, SC
Vehicle:
2008 WRX
White

Default

Thanks for posting the video. I have the exact same squeak coming from my clutch and it started about 5 days ago. My squeak does occur whenever the care is running or when switched off.

Did you ever find out what was causing the squeak and how to correct it?
bdkyzer is offline   Reply With Quote
Old 07-07-2012, 08:52 PM   #3
Snow Drift
Scooby Specialist
 
Member#: 75071
Join Date: Nov 2004
Chapter/Region: Tri-State
Location: NYC
Vehicle:
4 Train - Subway
Past: 05, 08, 11 Red WRXs

Default

My 2008 had two different types of sounds, here is what I did:

1) Spray the arm of the clutch pedal with WD-40. This stopped mine from making noises (besides the 100% normal high pitched click sound). This sound happened almost every time I used the clutch.

2) I did eventually have a problem where the clutch slave cylinder had to be replaced as it made "vrrrrr" sound. This did not happen every time but often.
Snow Drift is offline   Reply With Quote
Old 07-09-2012, 01:08 AM   #4
dead_eye
Scooby Newbie
 
Member#: 308265
Join Date: Jan 2012
Location: PHL
Vehicle:
2008 WRX

Default

Once in a while my clutch makes the same pedal noise. When it does, if it's very quiet and I put the clutch in I can hear a faint whirring noise. Then after driving for a few minutes it just goes away.

I can't pinpoint when or why. I figured it was just another subaru cold transmission quirk.
dead_eye is offline   Reply With Quote
Old 07-29-2012, 11:35 PM   #5
krnsamiam
Scooby Newbie
 
Member#: 158169
Join Date: Sep 2007
Vehicle:
2008 WRX
Silver

Default

I am also having this squeaking noise coming from my 08 WRX. It only happens when it's hot outside. Should I get the clutch replaced? If I do will this get rid of the noise?
krnsamiam is offline   Reply With Quote
Old 07-29-2012, 11:39 PM   #6
lavid2002
Scooby Specialist
 
Member#: 226864
Join Date: Oct 2009
Location: southern NJ
Vehicle:
2005 PSM WRX
18.5lb. 93 oct, DP, UP

Default

Usually this squeak comes from an accumulation of clutch dust on the clutch fork where it contacts the throw out bearing. I cleaned mine with a wire wheel and greased it when I had my engine out, but now it is squeaking again 10k miles or so later, it is normal, the forester does it as well. That is common for these cars. Unless you hear yours coming from inside the fire wall, go under there with some lithium grease and do work.

P.S. LOL at thinking air in the lines would cause this.
lavid2002 is offline   Reply With Quote
Old 08-07-2012, 11:27 AM   #7
kgounden
Scooby Newbie
 
Member#: 229178
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Toledo, OH
Vehicle:
2010 WRX Hatch
Spark Silver

Default

Quote:
Originally Posted by bdkyzer View Post
Thanks for posting the video. I have the exact same squeak coming from my clutch and it started about 5 days ago. My squeak does occur whenever the care is running or when switched off.

Did you ever find out what was causing the squeak and how to correct it?
Havent found the cause yet...the dealer suggested I come when they have their specialist there so they can look at it. I'll post the outcome when they call me.

Quote:
Originally Posted by lavid2002 View Post
Usually this squeak comes from an accumulation of clutch dust on the clutch fork where it contacts the throw out bearing. I cleaned mine with a wire wheel and greased it when I had my engine out, but now it is squeaking again 10k miles or so later, it is normal, the forester does it as well. That is common for these cars. Unless you hear yours coming from inside the fire wall, go under there with some lithium grease and do work.

P.S. LOL at thinking air in the lines would cause this.

Thanks for the input...i tried greasing parts of the pedal but the noise seems to be coming from behind the dash.
kgounden is offline   Reply With Quote
Old 08-07-2012, 08:55 PM   #8
NICKNICK
Scooby Newbie
 
Member#: 328442
Join Date: Aug 2012
Default

Does it sound different if your car sits for a few days? I was told mine was from corrosion, and I get the most creaking if the car has sat for a week or more.
NICKNICK is offline   Reply With Quote
Old 08-07-2012, 09:35 PM   #9
dave07
Scooby Newbie
 
Member#: 291349
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2013 Mustang GT
Black

Default

Hey man I'm kind of having the squeak that you are.

Now, these cars have had a problem with cracked firewalls causing a squeaky clutch. There are a lot of threads about that. I have checked for welds being cracked underneath my Windshield wiper cowl and they look fine.

http://www.youtube.com/watch?v=AXllb...ature=youtu.be

The noise in the video is coming from under the intercooler. As you can see the Clutch Master Cylinder moves a little bit (but the noise is coming from under the intercooler). Any thoughts on this?

Last edited by dave07; 08-07-2012 at 10:03 PM.
dave07 is offline   Reply With Quote
Old 08-16-2012, 05:10 PM   #10
kgounden
Scooby Newbie
 
Member#: 229178
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Toledo, OH
Vehicle:
2010 WRX Hatch
Spark Silver

Default

Quote:
Originally Posted by bdkyzer View Post
Thanks for posting the video. I have the exact same squeak coming from my clutch and it started about 5 days ago. My squeak does occur whenever the care is running or when switched off.

Did you ever find out what was causing the squeak and how to correct it?
I have been talking to the dealer for the last couple weeks (had issues with them because they were unable to diagnose what was wrong), and took the car to them yesterday. They told me that it was most likely the firewall welds.

Quote:
Originally Posted by krnsamiam View Post
I am also having this squeaking noise coming from my 08 WRX. It only happens when it's hot outside. Should I get the clutch replaced? If I do will this get rid of the noise?
I would take it to the dealer. It may be the firewall and if so then the dealer will repair it under warranty.

Quote:
Originally Posted by NICKNICK View Post
Does it sound different if your car sits for a few days? I was told mine was from corrosion, and I get the most creaking if the car has sat for a week or more.
Before (4 weeks ago) the noise would come and go randomly. Now its there all the time and usually sounds the same. I drive everyday to work so the most it sits is overnight so its hard to tell

Quote:
Originally Posted by dave07 View Post
Hey man I'm kind of having the squeak that you are.

Now, these cars have had a problem with cracked firewalls causing a squeaky clutch. There are a lot of threads about that. I have checked for welds being cracked underneath my Windshield wiper cowl and they look fine.

http://www.youtube.com/watch?v=AXllb...ature=youtu.be

The noise in the video is coming from under the intercooler. As you can see the Clutch Master Cylinder moves a little bit (but the noise is coming from under the intercooler). Any thoughts on this?
This sounds so similar to mine! A buddy and I tried to find if we could hear/see where the noise was coming from but were unsuccessful. It seemed to me like it was behind the intercooler. Like i said earlier, try taking it to the dealer and hopefully they can help.
kgounden is offline   Reply With Quote
Old 08-16-2012, 05:43 PM   #11
dave07
Scooby Newbie
 
Member#: 291349
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2013 Mustang GT
Black

Default

Alright, I was at the beach when I took that video and on my way home the squeak started coming from under the dash!

I ended up taking it to the dealership today. They lubed some stuff up and the squeak was still there. They said they are going to contact the SOA regional rep to see what he has to say. I told them about the broken welds on the firewall and we will have to see how it pans out.

I'm out of warranty and the second owner. Hopefully they will take care of me.
dave07 is offline   Reply With Quote
Old 08-22-2012, 10:41 PM   #12
kgounden
Scooby Newbie
 
Member#: 229178
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Toledo, OH
Vehicle:
2010 WRX Hatch
Spark Silver

Default

So the dealer got back to me and they had said that it was a bad pressure plate that was causing the squeak and NOT the firewall welds. Of course they replace the pressure plate and flywheel under warranty and gave me the option to replace the clutch disk (which was ~50% worn...im at 39k) for just $160 which I did because it was essentially free labor for clutch job

Anyway I got the car back today and it is very nice to have a quiet car again
kgounden is offline   Reply With Quote
Old 08-29-2012, 06:37 PM   #13
QwaktastiK
Scooby Specialist
 
Member#: 219100
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
'09 WRX Premium 5dr
COBB Stg3 336whp/370wtq

Default

Mine is squeaking pretty loud too. Might try and take it to the dealer. Last time I had an issue I wanted covered under warranty they bitched about my mods.
QwaktastiK is offline   Reply With Quote
Old 09-17-2012, 09:32 AM   #14
SparkSilver10NM
Scooby Newbie
 
Member#: 302438
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque
Vehicle:
10 WRX
SS DMrally tuned!

Default

I'm taking mine in today as well. Where did you look for the welds? behind (under) the intercooler? I'd just like to be as prepared as possible....
SparkSilver10NM is offline   Reply With Quote
Old 09-18-2012, 12:53 PM   #15
SparkSilver10NM
Scooby Newbie
 
Member#: 302438
Join Date: Nov 2011
Chapter/Region: SWIC
Location: Albuquerque
Vehicle:
10 WRX
SS DMrally tuned!

Default

An update. Mine is the throw out bearing. Subaru calls it a pressure/release bearing. It's covered under your 3yr/36k warranty as long as your dealership is cooperative and you haven't modded your transmission. Good luck to all with this problem.
SparkSilver10NM is offline   Reply With Quote
Old 10-04-2012, 02:57 AM   #16
n_ac
Scooby Newbie
 
Member#: 284838
Join Date: Jun 2011
Chapter/Region: BAIC
Vehicle:
2014 WRX STI 5Door
Black

Default

The car is in right now getting both the slave and master cylinder changed as well as the clutch hose.
n_ac is offline   Reply With Quote
Old 03-06-2013, 09:48 AM   #17
Rearviewevo
Scooby Newbie
 
Member#: 230594
Join Date: Nov 2009
Chapter/Region: MAIC
Vehicle:
2009 wrx
silver

Default

Any updates on people having this taken care of out of warranty? Is it covered under powertrain or bumper to bumper? I was told by SOA that it was bumper to bumper??? I have 43K miles on my car. The first time I took it to the dealer they just put on some lube and it didn't do anything obviously. Now I am going back prepared.

Also, when I called SOA they said they didn't have any documentation of this happening to the wrx?

I should be more clear- after doing the research it is a cracked firewall where the welds touch. I have a 2009 wrx sedan.

Help please.
Rearviewevo is offline   Reply With Quote
Old 03-06-2013, 04:14 PM   #18
PlasmaBlue518
Scooby Newbie
 
Member#: 347382
Join Date: Feb 2013
Chapter/Region: Tri-State
Location: Albany NY
Vehicle:
2015 WRX
CRYSTAL WHITE PEARL

Default

i have a 2013 and it just started this morning ill be heading to the dealer to get me a rental and have them fix it i spent 25K on a brand new car shouldbt be squeeking what so ever
PlasmaBlue518 is offline   Reply With Quote
Old 04-15-2013, 04:40 PM   #19
stanrc
Scooby Specialist
 
Member#: 266177
Join Date: Dec 2010
Chapter/Region: MAIC
Location: Manassas Park, VA
Vehicle:
2006 MX-5
RED

Default

Quote:
Originally Posted by Rearviewevo View Post
I should be more clear- after doing the research it is a cracked firewall where the welds touch. I have a 2009 wrx sedan.
is this something you can see to verify yourself? Mine just started making this noise today, 2011 with 36k miles.
stanrc is offline   Reply With Quote
Old 04-17-2013, 11:44 AM   #20
davidboies
Scooby Newbie
 
Member#: 304390
Join Date: Dec 2011
Default

I have a 2009 wrx sedan with 113,000 miles on it. It's had a squeaky clutch for as long as I can remember. I didn't think anything about it until I started having trouble putting the car in reverse and 1st, and the brake pedal would move over with the clutch when I presse in the clutch. Took it to the dealer and they adjusted the clutch. It helped for a little while, but then it went right back to what it was doing before. Anyways, its at the Subaru dealer now with a cracked firewall and they say that they won't/can't fix it. 😞
davidboies is offline   Reply With Quote
Old 04-24-2013, 01:52 PM   #21
Subiezilla
Scooby Newbie
 
Member#: 280543
Join Date: Apr 2011
Default

Quote:
Originally Posted by davidboies View Post
I have a 2009 wrx sedan with 113,000 miles on it. It's had a squeaky clutch for as long as I can remember. I didn't think anything about it until I started having trouble putting the car in reverse and 1st, and the brake pedal would move over with the clutch when I presse in the clutch. Took it to the dealer and they adjusted the clutch. It helped for a little while, but then it went right back to what it was doing before. Anyways, its at the Subaru dealer now with a cracked firewall and they say that they won't/can't fix it. dde1e
Besides the 3 welds underneath the windshield wiper assembly are their other places that the firewall may be cracked or broken?
Subiezilla is offline   Reply With Quote
Old 04-24-2013, 01:53 PM   #22
Subiezilla
Scooby Newbie
 
Member#: 280543
Join Date: Apr 2011
Default

Quote:
Originally Posted by davidboies View Post
I have a 2009 wrx sedan with 113,000 miles on it. It's had a squeaky clutch for as long as I can remember. I didn't think anything about it until I started having trouble putting the car in reverse and 1st, and the brake pedal would move over with the clutch when I presse in the clutch. Took it to the dealer and they adjusted the clutch. It helped for a little while, but then it went right back to what it was doing before. Anyways, its at the Subaru dealer now with a cracked firewall and they say that they won't/can't fix it. dde1e
Also FYI There is a class action started by member armyofcase
Quote:
Originally Posted by Armyofcase View Post
Hey guys! I own a 2009 WRX and we launched the proceedings for a Class Action against Subaru for the 08+ Clutch/Firewall breakage issues. If you've experienced this at all, please give Greg Coleman Law a call at 1-800-HURT-NOW. It should only take 10 minutes and hopefully, we can prevent this from happening again. His local number is 865-247-0080. Thank you for your help!
Subiezilla is offline   Reply With Quote
Old 08-02-2013, 01:23 AM   #23
Paul the Peanut
Scooby Newbie
 
Member#: 288632
Join Date: Jul 2011
Chapter/Region: MAIC
Location: Annapolis Md
Vehicle:
2006 Impreza WRX

Default

everyone on here posted a problem with the 08 plus models. my 06 does it. any idea on the cause? or the price? it is annoying.. lol
Paul the Peanut is offline   Reply With Quote
Old 08-05-2013, 03:25 AM   #24
subie 2.5 STI
Scooby Newbie
 
Member#: 175933
Join Date: Mar 2008
Location: Orange County, Ca.
Vehicle:
2008 WRX STI
blue

Default

I got the same issue on mine and I just gave up on it since its off and on. I plan to put WD40 and see if it makes any changes
subie 2.5 STI is offline   Reply With Quote
Old 08-05-2013, 09:34 PM   #25
Subiezilla
Scooby Newbie
 
Member#: 280543
Join Date: Apr 2011
Default

Quote:
Originally Posted by Paul the Peanut View Post
everyone on here posted a problem with the 08 plus models. my 06 does it. any idea on the cause? or the price? it is annoying.. lol
Hmm I found that squeaking is due to clutch slave cylinder needing lube, but lubricating it will solve the nose issue for a few weeks.
Subiezilla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 WRX Clutch Chirp & Squeak Haohmaru Transmission (AT/MT) & Driveline 8 04-22-2012 06:42 PM
07 wrx clutch replacement SQUEAK?? NEED HELP!! shocker47 Transmission (AT/MT) & Driveline 3 04-10-2012 06:23 PM
Clutch noise/squeak subasurf Transmission (AT/MT) & Driveline 2 05-06-2011 11:13 AM
2010 WRX crazy noise after clutch install Odin2347 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 06-27-2010 01:42 AM
06 WRX Clutch Pedal Squeaking suBooneru Warranty Issues & SOA Problems 4 02-08-2006 08:56 AM


All times are GMT -4. The time now is 11:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.