Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-12-2012, 07:47 PM   #1
bajesubaru
Scooby Newbie
 
Member#: 221864
Join Date: Aug 2009
Default H Brace-Alignment After Install??

Hey do you guys know if I will need an alignment after installing a H-Brace? I knew my two front tires were good before the H-Brace install, I changed the rims and tires recently and realised that the inside of the two tires were rubbed down about half inch to an inch into the tire. Think its the H brace or something else?
* Registered users of the site do not see these ads.
bajesubaru is offline   Reply With Quote
Old 09-12-2012, 08:19 PM   #2
sc00by4life
Scooby Guru
 
Member#: 97135
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Bothell
Default

the H-brace doesn't require an alignment, but it sounds like your toe is out of spec which will cause the inside wear.
sc00by4life is online now   Reply With Quote
Old 09-12-2012, 10:12 PM   #3
bajesubaru
Scooby Newbie
 
Member#: 221864
Join Date: Aug 2009
Default

Ok, what would cause that to happen.
bajesubaru is offline   Reply With Quote
Old 09-12-2012, 10:37 PM   #4
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

too wide a wheel and tire.....nothing to do with the brace

and it is likely too low, too
Uncle Scotty is offline   Reply With Quote
Old 09-12-2012, 10:37 PM   #5
sc00by4life
Scooby Guru
 
Member#: 97135
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Bothell
Default

Quote:
Originally Posted by bajesubaru
Ok, what would cause that to happen.
Driving.
sc00by4life is online now   Reply With Quote
Old 09-13-2012, 08:16 AM   #6
bajesubaru
Scooby Newbie
 
Member#: 221864
Join Date: Aug 2009
Default

Quote:
Originally Posted by Uncle Scotty View Post
too wide a wheel and tire.....nothing to do with the brace

and it is likely too low, too
Rims were 17x7 and definitly was not low, its on stock sti springs.
bajesubaru is offline   Reply With Quote
Old 09-13-2012, 09:11 PM   #7
Ernest
Scooby Specialist
 
Member#: 45076
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: Rockland County, NY
Vehicle:
2004 Stg2 Wagon 4eat
Silver

Default

Get yourself an alignment. Nothing todo with hbrace.
Ernest is offline   Reply With Quote
Old 09-14-2012, 02:08 AM   #8
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by bajesubaru View Post
Rims were 17x7 and definitly was not low, its on stock sti springs.
what size tire is on them??
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.