Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-28-2012, 08:44 AM   #1
QwaktastiK
Scooby Specialist
 
Member#: 219100
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
'09 WRX Premium 5dr
COBB Stg3 336whp/370wtq

Default Forge BPV all of a sudden doesn't sound like it's doing its job

Car: 2009 Subaru WRX
Mods:
Cobb Accessport (Stage 2+...low wastegate duty map)
Cobb SF Intake & Airbox Combo
Process West TMIC
Forge BPV
SPT Turbo Heatshield
Turbo XS High Flow Catted Downpipe
Turbo XS Catback Exhaust


The only recent changes have been a change in ambient temps with the end of summer beginning of fall.

Symptoms:
When my engine is cold, the BPV and/or intake do not sound as though they are operating properly. This happened overnight coincidentally with the change in ambient temps. I now have a flutter that I didn't have before. I would describe it as a hesitation, not the normal deep breath in and deep breath out. Although the car FEELS fine. I make a point to stay out of boost until the engine is up to temp, but even staying out of boost I normally hear the intake/BPV sucking/blowing air respectively. Once the engine is warm, and I go into boost, they sound normal and I'm boosting fine. I don't know if at this point is has to do with my stock spark plugs and my power level or whether my intake is in a dire need of a good cleaning or if the BPV spring is failing or what.
Any insight?

My apologies if this is something stupid and obvious, but I'd rather be safe than sorry. Just thought it was alarmingly different in sound and I've been at this same power level for over a year. Last year's change in seasons I did not have the same issue.

TIA.
. . .
matthew
QwaktastiK is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.