Welcome to the North American Subaru Impreza Owners Club Wednesday September 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-26-2012, 10:15 AM   #26
conklin_02
Scooby Specialist
 
Member#: 324190
Join Date: Jun 2012
Chapter/Region: NESIC
Location: Southwick, MA
Vehicle:
2005 wrx STi
PSM

Default

Try cleaning your maf. Reset your Ecu. If its not misfiring, run about a tank of gas through and watch your afr ratios. A, b, c, d should all be +/- 5%. If any are over, than it probably is the maf. Could just be dirty or bad.
* Registered users of the site do not see these ads.
conklin_02 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-27-2012, 05:33 PM   #27
oOIIJoshIIOo
Scooby Newbie
 
Member#: 295983
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Clendenin, WV
Vehicle:
2002 WRX
WRB

Default

Cleaned MAF, reset ECU and checked it with my Snap-On Solus Ultra and no code. I'm thinking a coil.
oOIIJoshIIOo is offline   Reply With Quote
Old 09-27-2012, 05:55 PM   #28
conklin_02
Scooby Specialist
 
Member#: 324190
Join Date: Jun 2012
Chapter/Region: NESIC
Location: Southwick, MA
Vehicle:
2005 wrx STi
PSM

Default

Is it hesitating under heavy loads or sputtering are higher rpms?
conklin_02 is offline   Reply With Quote
Old 09-27-2012, 06:10 PM   #29
oOIIJoshIIOo
Scooby Newbie
 
Member#: 295983
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Clendenin, WV
Vehicle:
2002 WRX
WRB

Default

Sure is.
oOIIJoshIIOo is offline   Reply With Quote
Old 09-27-2012, 06:12 PM   #30
oOIIJoshIIOo
Scooby Newbie
 
Member#: 295983
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Clendenin, WV
Vehicle:
2002 WRX
WRB

Default

Starts at around 4-4500 RPMS and continues from there. Only does it usually at WOT.
oOIIJoshIIOo is offline   Reply With Quote
Old 09-28-2012, 09:24 AM   #31
JMSok8
Scooby Newbie
 
Member#: 309967
Join Date: Feb 2012
Chapter/Region: BAIC
Location: Santa Cruz, CA
Vehicle:
2003 WRX PSM vf34

Default

Another possibility is to find someone local here on the forums to swap out some parts to try and locate the problem. Other than that, with no data logs, videos, or other detail its very hard to determine what your problem is. At this point, you could swap parts with another member, take it to a mechanic, or just not drive WOT.
JMSok8 is offline   Reply With Quote
Old 09-28-2012, 10:17 AM   #32
conklin_02
Scooby Specialist
 
Member#: 324190
Join Date: Jun 2012
Chapter/Region: NESIC
Location: Southwick, MA
Vehicle:
2005 wrx STi
PSM

Default

Probably a bad coil pack is my guess. I recently had a similar problem. At WOT it was hesitating over 5k. I replaced my maf and fuel filter, my afr readings went back to normal, but still hesitating. Bought 4 new coils, it fixed it. Also, check your connections. Maybe a bad wire. I replaced mine because they have never been replaced
conklin_02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.