Welcome to the North American Subaru Impreza Owners Club Sunday February 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-01-2012, 10:58 PM   #1
jvp5051
Scooby Newbie
 
Member#: 286309
Join Date: Jun 2011
Default

Rs been a great car and I love it! I have an issue, when I'm in high rpms I hear it sucking air is the way it sounds to me but it's pretty loud. I'm not sure what it is or could be? Neve did it before until today and it's like a shhhhhhhh while in boost.
* Registered users of the site do not see these ads.

Last edited by jvp5051; 10-01-2012 at 11:03 PM.
jvp5051 is offline   Reply With Quote
Old 10-01-2012, 11:03 PM   #2
cineris
Scooby Newbie
 
Member#: 263329
Join Date: Nov 2010
Chapter/Region: MWSOC
Location: Columbus, OH
Vehicle:
2011 Impreza WRX
DGM

Default

Has the sound always been there?
cineris is offline   Reply With Quote
Old 10-01-2012, 11:15 PM   #3
jvp5051
Scooby Newbie
 
Member#: 286309
Join Date: Jun 2011
Default

Nope just started doing it today
jvp5051 is offline   Reply With Quote
Old 10-01-2012, 11:25 PM   #4
cineris
Scooby Newbie
 
Member#: 263329
Join Date: Nov 2010
Chapter/Region: MWSOC
Location: Columbus, OH
Vehicle:
2011 Impreza WRX
DGM

Default

After I went stage 1 on stock intercooler, the IC to throttle body hose got kinked and started making a whooshing/vacuum noise at peak boost and let off towards redline. Apparently its a common issue in 08+ WRXs.
cineris is offline   Reply With Quote
Old 10-02-2012, 12:43 AM   #5
BigRob74
Scooby Specialist
 
Member#: 305107
Join Date: Dec 2011
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2012 wrx
360/386 E85

Default

Quote:
Originally Posted by cineris View Post
After I went stage 1 on stock intercooler, the IC to throttle body hose got kinked and started making a whooshing/vacuum noise at peak boost and let off towards redline. Apparently its a common issue in 08+ WRXs.
pretty much this. OP you can fix it yourself or just take it to the dealer. my guess is the dealer will not remove those "rubber endcaps" in the hose, so its just gonna happen again..
BigRob74 is offline   Reply With Quote
Old 10-02-2012, 01:41 AM   #6
DurtyB
Scooby Specialist
 
Member#: 292699
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Barboursville VA
Vehicle:
2011 WRX Sedan DGM
Stg1+ SF

Default

Search button....This is extremely common. Take off IC, take end caps out of TB IC hose. Put IC back on. Done.
DurtyB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.