Welcome to the North American Subaru Impreza Owners Club Thursday December 8, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Care & Detailing

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-03-2012, 02:20 PM   #1
XCBatman
Scooby Newbie
 
Member#: 258467
Join Date: Sep 2010
Chapter/Region: NESIC
Location: Maine
Vehicle:
2006 STi M@ tuned
2001 Outback beater

Default Went on Vacation, Came Back to Clearcoat Issues

As the title says, I went on a vacation for just under two weeks and left the car in my parents' driveway. When I returned, I noticed that there were these hazy splotches on the hood, right by the hood scoop. After further inspection, I realized that some of them were quite large, the clear coat was severly peeling, revealing the bare paint. The only thing I could think of is sun damage... but I leave the car in the sun every day for work. There weren't anywhere for birds to sit above the car... My parents said that they didn't do anything differently, and I've had the car sit in that spot in the driveway for extended periods of time before and saw nothing like this. There were 3 other cars in the driveway, nothing like this appears on them. And as far as I can tell, it's isolated to just the hood.

It's an '06 OBP STI.






Does anyone know how this happened? Secondly, does anyone know where I should begin by fixing it? Just remove the clearcoat on the affected areas and follow the other threads on peeling clearcoat?
XCBatman is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.