Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2012, 09:03 AM   #1276
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

It's probably the neutral switch signal not hooked up causing an engine to stall while returning to idle.
* Registered users of the site do not see these ads.
Marnix is offline   Reply With Quote
Old 10-03-2012, 06:29 PM   #1277
Panops145
Scooby Newbie
 
Member#: 200310
Join Date: Jan 2009
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
1999 2.2l-2.5rs conv
silver-dark grey metallic

Default

Quote:
Originally Posted by 2006eg33 View Post
my eg33 swap with a 5speed doesnt stall, or even come close for that matter
How have you set up your neutral switch? judging from the post after you he said this could be the problem?

Where do I check for this and what would I have to do to it in order for this to stop happening?

thanks in advance
Panops145 is offline   Reply With Quote
Old 10-04-2012, 09:59 AM   #1278
dragoontwo
Scooby Newbie
 
Member#: 275500
Join Date: Mar 2011
Location: Clarksville, TN
Vehicle:
1992 SVX

Default

So did you try the ECUTune chip that you already have to see if it works? I can post a pinout of the EG ecu later today. Which version stage 1 chip do you have?
dragoontwo is offline   Reply With Quote
Old 10-09-2012, 08:03 AM   #1279
Jessekrs123
Scooby Specialist
 
Member#: 236927
Join Date: Jan 2010
Chapter/Region: NESIC
Location: Oakville CT
Vehicle:
1993 Legacy Sedan
1984 BRAT

Default

Don't know if this will help anyone here or contribute any information that hasn't already been stated but here is my EG33 swap into my first gen Legacy thread if anyone is interested:

http://forums.nasioc.com/forums/show....php?t=2291028

Very very very very slowly coming along. I can hardly find time to eat/sleep/**** while working and going to school full time. Can't wait to get everything done though!
Jessekrs123 is offline   Reply With Quote
Old 10-09-2012, 08:41 AM   #1280
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

I am in the process of collecting the parts for an EZ30R swap into my first gen Legacy sedan. I already have the engine and exhaust manifolds, I am now saving up for a standalone management (Syvecs or Link).
Marnix is offline   Reply With Quote
Old 10-09-2012, 01:02 PM   #1281
Panops145
Scooby Newbie
 
Member#: 200310
Join Date: Jan 2009
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
1999 2.2l-2.5rs conv
silver-dark grey metallic

Default

Quote:
Originally Posted by dragoontwo View Post
So did you try the ECUTune chip that you already have to see if it works? I can post a pinout of the EG ecu later today. Which version stage 1 chip do you have?
I haven't had time yet but I'm going to try it next time I go to work on it!
Panops145 is offline   Reply With Quote
Old 10-13-2012, 09:19 PM   #1282
Baldturbofreak
Scooby Newbie
 
Member#: 36886
Join Date: May 2003
Location: Honeoye, New York
Vehicle:
2002 WRX,95 Tvette
Black/Red

Default

After all the flippy floppin between the Eg and the EZ, I ended up going with the EG33. It's simply built heavier, far cheaper and was suprisingly easy to get running.
It's an 2002 WRX, 32K miles(long story)
EG33 that I got out of a car w 60k on the odo
6speed with RA ratios (3100rpm @65mph! ack)
Tilton twin disc w light flywheel
MS3x/factory ej20 ECM integrated emissions and all (one last piece and its NYS inspection time)
R180, pink sti arms blah blah.
D2 coilovers that finally ride acceptable with the "big block" under the hood.

and although I havent gotten around to the A/c compressor bracket Im keeping my ac. Im bald. Im fat, I sweat man. lol

Ive got about 400 miles on the combo now, Im pretty much happy with the NA torque and fun factor. Lets not overlook the H6 howl either.

Overall the project's difficulty lies in the electronics side of things, otherwise most of it just bolts together. start to finish waiting at the DMV for plates=7 days

Last edited by Baldturbofreak; 10-13-2012 at 09:27 PM.
Baldturbofreak is offline   Reply With Quote
Old 10-13-2012, 09:40 PM   #1283
ManualOverAuto
Scooby Specialist
 
Member#: 304662
Join Date: Dec 2011
Chapter/Region: MAIC
Vehicle:
2001 Impreza L coupe
Sedona red Pearl

Default

I'd probably kill for a manual tranny, h6 set-up.

You guys make the h6 sound soooo fun.
ManualOverAuto is offline   Reply With Quote
Old 10-14-2012, 10:16 AM   #1284
Baldturbofreak
Scooby Newbie
 
Member#: 36886
Join Date: May 2003
Location: Honeoye, New York
Vehicle:
2002 WRX,95 Tvette
Black/Red

Default

well that link didnt work
Baldturbofreak is offline   Reply With Quote
Old 10-15-2012, 08:04 PM   #1285
legacymaximus
Scooby Newbie
 
Member#: 98451
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Colorado
Vehicle:
94 legacy TW
Silver

Default

So I am finally in a position to start looking into engine management for my ez30d. What systems are people using for the 30d? I have read through this thread and have not seem any definite answer so far. I am going to be staying NA as it is in a rally car.
-Max
legacymaximus is offline   Reply With Quote
Old 10-15-2012, 08:21 PM   #1286
PHATsuby
Scooby Guru
 
Member#: 13617
Join Date: Dec 2001
Chapter/Region: MWSOC
Location: MN
Vehicle:
2001 Legacy GT back
to stock is a project too

Default

Quote:
Originally Posted by legacymaximus View Post
So I am finally in a position to start looking into engine management for my ez30d. What systems are people using for the 30d? I have read through this thread and have not seem any definite answer so far. I am going to be staying NA as it is in a rally car.
-Max
If you are staying NA you could look into just doing a full swap with stock ecu, otherwise I'd say Link or Vipec ecu would be a good choice.

Ben
PHATsuby is offline   Reply With Quote
Old 10-15-2012, 11:31 PM   #1287
legacymaximus
Scooby Newbie
 
Member#: 98451
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Colorado
Vehicle:
94 legacy TW
Silver

Default

Yeah, I have had the swap in for a few years now. It has an old 2.5 J sport intake on it and 2.5 inch exhaust with one hi flow cat. This guy seem to have gotten a ez30d to run on the link G4 using the ez30r trigger settings.
http://www.linkecu.com/forums/G4Forum/159563338
legacymaximus is offline   Reply With Quote
Old 10-16-2012, 10:27 AM   #1288
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

For the Link G4 Extreme there are good base maps available for the EZ30R. If you turn off the active valve control stuff you can make your EZ30D run on it.
Marnix is offline   Reply With Quote
Old 10-19-2012, 07:26 PM   #1289
Purpose_Built
Scooby Newbie
 
Member#: 222879
Join Date: Sep 2009
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2003 WRX 60-1/td06h
Hybrid

Default

How do you still pass emissions with an EZ30? I really want to swap a ez30 into my 03 wrx and still pass inspections. The engine is leagal since its the same year or newer but what about everything else?
Purpose_Built is offline   Reply With Quote
Old 10-21-2012, 03:34 PM   #1290
NCGreasemonkey
Scooby Newbie
 
Member#: 255948
Join Date: Aug 2010
Location: North Davidson Co., NC
Vehicle:
95GC 02 Outback H-6
Burg-GC OffWht-Outback

Default

Ok, just pass the kool-aid or tell me there are spaceships behind the comet. I walk into my driveway and see these two every day and wish they would mate. LOL! I got the GC5 about 4 yrs. ago as abandoned at our shop. $273 for the car. Put a 2.2 in it around 2 yrs. ago (got tired of downshifting when hit the S Main St. hill with the A/C on and in 5th). The L.L. Bean fell into my hands when a customer didn't change their oil for 2x the distance and forgot to check the level also. $1500 for the car. Replaced the engine in it w/ one that had 69K. Just need to get my garage up at the house and stuff big into little. Has anyone tried to do the running gear full swap so ABS / Trac and gauges all work? I know there are differances in balljoints, wb, ww, and the like. Have some machine shops that I work with, just wondering if anyone has tried?


BTW: Do you guys and gal's know just how many adult beverages it take to read all 52 pages of the thread???? Butt loads!!!

Last edited by NCGreasemonkey; 10-21-2012 at 03:53 PM. Reason: adding text
NCGreasemonkey is offline   Reply With Quote
Old 10-24-2012, 11:33 PM   #1291
2006eg33
Scooby Newbie
 
Member#: 315603
Join Date: Apr 2012
Vehicle:
2006 Impreza
CGM

Default

Quote:
Originally Posted by Panops145 View Post
How have you set up your neutral switch? judging from the post after you he said this could be the problem?

Where do I check for this and what would I have to do to it in order for this to stop happening?

thanks in advance

i didnt touch it, it's still connected to the stock ecu, completely seperate from the eg33 stuff.
2006eg33 is offline   Reply With Quote
Old 10-25-2012, 09:14 AM   #1292
Duderotomy
Scooby Newbie
 
Member#: 128726
Join Date: Oct 2006
Chapter/Region: E. Canada
Location: Ontario, Canada
Vehicle:
1990 Nissan Skyline
2007 Forester XT Sports

Default

Quote:
Originally Posted by NCGreasemonkey View Post
Ok, just pass the kool-aid or tell me there are spaceships behind the comet. I walk into my driveway and see these two every day and wish they would mate. LOL! I got the GC5 about 4 yrs. ago as abandoned at our shop. $273 for the car. Put a 2.2 in it around 2 yrs. ago (got tired of downshifting when hit the S Main St. hill with the A/C on and in 5th). The L.L. Bean fell into my hands when a customer didn't change their oil for 2x the distance and forgot to check the level also. $1500 for the car. Replaced the engine in it w/ one that had 69K. Just need to get my garage up at the house and stuff big into little. Has anyone tried to do the running gear full swap so ABS / Trac and gauges all work? I know there are differances in balljoints, wb, ww, and the like. Have some machine shops that I work with, just wondering if anyone has tried?


BTW: Do you guys and gal's know just how many adult beverages it take to read all 52 pages of the thread???? Butt loads!!!

The first-gen EZ30 like that is probably one of the easier H6 swaps. You're best to pull the full harness from the Outback and drop it with the ECU and gauges into the GC. You'd retain full OBD2 that way, and you'd only have to merge in the wiring for the lights, windows, locks, etc.
Duderotomy is offline   Reply With Quote
Old 10-25-2012, 05:34 PM   #1293
NCGreasemonkey
Scooby Newbie
 
Member#: 255948
Join Date: Aug 2010
Location: North Davidson Co., NC
Vehicle:
95GC 02 Outback H-6
Burg-GC OffWht-Outback

Default

Ok, that is the easy part. Not being a dick. I'm talking about the mechanicals. The wheel-base and the wheel width (aka = track) are differant. The ball-joints and the lower a-arms are differant. The splines and the hubs are differant from what I've read. If anyine else has tried the full blown swap I want to chat. I have a '99 2.5 Fozzie in sights if this is imposible. Or might prove imposible wrong and dd the Fozz... LOL I'm hard-headed! Who rules???? Subie's rule!!!!
NCGreasemonkey is offline   Reply With Quote
Old 10-25-2012, 08:53 PM   #1294
2006eg33
Scooby Newbie
 
Member#: 315603
Join Date: Apr 2012
Vehicle:
2006 Impreza
CGM

Default

why bother doing the whole swap?

just toss the motor in.
2006eg33 is offline   Reply With Quote
Old 10-26-2012, 09:14 AM   #1295
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by NCGreasemonkey View Post
If anyine else has tried the full blown swap I want to chat.
I think you'll be hard pressed to find anyone that has done a "full" swap because there just isn't any point in doing it that way. It just adds unnecessary complications.
Patrick Olsen is offline   Reply With Quote
Old 10-26-2012, 09:51 AM   #1296
Duderotomy
Scooby Newbie
 
Member#: 128726
Join Date: Oct 2006
Chapter/Region: E. Canada
Location: Ontario, Canada
Vehicle:
1990 Nissan Skyline
2007 Forester XT Sports

Default

Quote:
Originally Posted by Patrick Olsen View Post
I think you'll be hard pressed to find anyone that has done a "full" swap because there just isn't any point in doing it that way. It just adds unnecessary complications.
Exactly.
Swap over the engine, rad, and transmission (if you're fine with the 4EAT) then the rear diff. Once you got the wiring sorted out then you'd be good to go with a GC/GM/GF Impreza AT driveshaft.
The MY00+ Legacy/Outback chassis uses significantly different rear suspension than Imprezas/Foresters and yes the front hubs are also different.
Duderotomy is offline   Reply With Quote
Old 11-02-2012, 04:02 AM   #1297
PseudoKirby
Scooby Newbie
 
Member#: 203835
Join Date: Feb 2009
Chapter/Region: BAIC
Location: California
Vehicle:
2000 2.5RS
Aspen White

Default

So has anyone found a definitive replacement for cutting the front radiator support in the EG33 swap yet?
PseudoKirby is offline   Reply With Quote
Old 11-02-2012, 06:17 AM   #1298
Purpose_Built
Scooby Newbie
 
Member#: 222879
Join Date: Sep 2009
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2003 WRX 60-1/td06h
Hybrid

Default

This has turned from a resource thread into a it doesnt make sense to do that page. It doesnt make sense to spend 10k on your 3k car but you do it anyway. If you dont have anything useful to post just keep it moving because you are turning this inti lengthy useless thread. Thank you to all the contributors.

Are there any serious ez30r into a gd threads out there? I really want to have a car that can pass the ob2 test. It seems there is nothing i can do short of tearing the whole harness out and splicing it with the gd's own
Purpose_Built is offline   Reply With Quote
Old 11-02-2012, 11:36 AM   #1299
biggreen96
Scooby Specialist
 
Member#: 12535
Join Date: Nov 2001
Chapter/Region: NWIC
Location: Idaho slash Washington
Vehicle:
vf39 93 Legacy Wagon
92 Legacy Rally EG33'd

Default

Quote:
Originally Posted by PseudoKirby View Post
So has anyone found a definitive replacement for cutting the front radiator support in the EG33 swap yet?
Rear mounted radiator.
biggreen96 is offline   Reply With Quote
Old 11-02-2012, 12:26 PM   #1300
Duderotomy
Scooby Newbie
 
Member#: 128726
Join Date: Oct 2006
Chapter/Region: E. Canada
Location: Ontario, Canada
Vehicle:
1990 Nissan Skyline
2007 Forester XT Sports

Default

^Or a 1994 Chrysler Concorde 3.3L radiator mounted directly under the front core support with a new set of rad hoses.

See this thread for a good example of such a setup: http://www.subaruforester.org/vbulle...o-my-sf-70682/
Duderotomy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vag-Com cable resource thread cooleys04 Open Source Reflashes 270 03-31-2014 05:49 PM
The Impreza @$$ Thread - The Beautiful Impreza Backside! PICS! Upscale_Automotive Member's Car Gallery 8 10-03-2007 04:56 AM
The 2008 Impreza Photoshop thread...post them here adizon Member's Car Gallery 307 09-19-2007 11:36 PM
The 2006 Impreza/Impreza WRX/Impreza WRX-STi thread (merged thread) wrxpeed News & Rumors 938 05-16-2005 11:11 PM
Photo - Anders "loving on" the H6 Impreza Fred South East Region Forum 8 02-23-2004 05:04 PM


All times are GMT -4. The time now is 09:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.