Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-30-2012, 08:17 PM   #1
97SubieLegacyOUTL
Scooby Newbie
 
Member#: 313793
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Indiana
Vehicle:
1997 Legacy L Wagon
Glacier white

Unhappy gas tank through back of car

I have a 1997 subaru legacy wagon L and my fuel gauge is reading wrong (big surprise).*
I'd like to get to the fuel tank through the back of the car heard carbon/sulfur clogs the sensors*

I've read subarus of my gen and below have lots of fuel problems I've ran into just about all of them. leaky fuel filler neck I patched with jb weld original its working fine for now. and as i said fuel gauge not working right.

I need a good cheap way of fixing my fuel gauge goes to E and below E and its not coughing or stalling so its still got gas.

I need to way to make it work right with as little money as possible so like a fuel additive or something I've heard techron chevron is good but from looking its like 40 dollars a bottle or I'm looking at the wrong ones, and I've heard lucas is horrible so I don't really even wanna try that and take the chance but, if you have a cheap way that would be awesome.

Also while I'm here there's a burning rubber smell below the hood when its warm, and there is black dust around my "new" re-manufactured alternator and top of the hood I just replaced the belt for it too. I'm assuming its the belt to tight i tried to loosen it up just a bit but than it just kept squealing.

While I'm here how do you get the quarter panels off? Do they have to be cut off or bolted off? they're rusty, looking into getting some new ones in a month or so when I get job right now I'm worried about the mechanical though. I'm not sure if this is the right thread or not sorry if its not.
* Registered users of the site do not see these ads.

Last edited by 97SubieLegacyOUTL; 10-03-2012 at 07:13 PM.
97SubieLegacyOUTL is offline   Reply With Quote
Old 09-30-2012, 11:46 PM   #2
97SubieLegacyOUTL
Scooby Newbie
 
Member#: 313793
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Indiana
Vehicle:
1997 Legacy L Wagon
Glacier white

Default

bought some techron gonna see if it works going to put it in tomorrow
97SubieLegacyOUTL is offline   Reply With Quote
Old 10-01-2012, 06:32 PM   #3
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

Try a few tanks using a bottle of seafoam each time. That burning rubber must be that new belt, sounds like it's rubbing on something. How does a belt "re-tighten" itself? Pop the hood and start the car, observe new alternator.

Also, make paragraphs. They're ever so much easier to read.
yarrgh is offline   Reply With Quote
Old 10-02-2012, 12:52 AM   #4
97SubieLegacyOUTL
Scooby Newbie
 
Member#: 313793
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Indiana
Vehicle:
1997 Legacy L Wagon
Glacier white

Default

Sorry about that, and it didn't I just thought it did. I looked and it doesn't seem to be rubbing. I tried wiggling the pulleys and they didn't move a bit. They spin freely too, and there was tiny black specs on the hood when I bought the car so its been doing it a while.

I have looked all over the engine and can't seem to find out where exactly its coming from but the shavings come off around the alternator and below it so, obviously it has to do with it or something around it. I've looked at the belt and there is no visible ware on the belt still looks brand new. Also on the old belt there was chunks of the ribs missing from it.

I have also looked for rust pits on the pulleys to see if that's causing anything and there's no noticeable pits or anything lodge in them.
97SubieLegacyOUTL is offline   Reply With Quote
Old 10-02-2012, 08:23 AM   #5
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Quote:
Originally Posted by 97SubieLegacyOUTL View Post
i have a 1997 subaru legacy wagon L and my fuel gauge is reading wrong (big surprise).*


id like to get to the fuel tank through the back of the car heard carbon clogs the sensors*

Carbon, in the gas tank, clogging sensors...

ive noticed subarus of my gen and below have lots of fuel problems ive ran into just about all of them.

leaky fuel filler neck i patched with jb weld original its working fine for now.


and as i said fuel gauge not working right.

i need a good cheap way of fixing that my gauge goes to e and below e and its not coughing or stalling so its still got gas but i need to way to make it work right with as little money as possible

Find point where it dies, remember said point.... That was easy..

so like a fuel additive or something ive heard techron chevron is good but from looking its like 40 dollars a bottle or im looking at the wrong ones.

Not going to fix your gage...?? and I get Techtron for 12-15 a bottle..

and ive heard lucas is horrible so i dont even wanna try that and take the chance but if you have a cheap way thatd be awesome.

On YOUR car it wouldn't make a difference in the world..

also while im here theres a burning rubber smell below the hood when its warm. and theres black dust around my new remaned alternator and top of the hood i just replaced the belt for it too.

im assuming its the belt to tight i tried to loosen it up just a bit and it just retightened itself.

How do you know the belt is/was too tight? Have you tried it "tighter"

and as well while im here how do you get the quarter panels off? do they have to be cut off or bolted off?

Front fenders are bolted... rear quarters are part of the car.. so cut

theyre rusty looking into getting some new ones in a month or so when i get job right now im worried about the mechanical though. im not sure if this is the right thread or not sorry if its not.
Wow.... this is what's called a shotgun post... get as many key points in as humanly possible, without a single break to ACTUALLY make it legable....

I had to break it up, just to read the sheit...

I hope you don't talk like this....
Aaron'z 2.5RS is offline   Reply With Quote
Old 10-03-2012, 03:44 PM   #6
97SubieLegacyOUTL
Scooby Newbie
 
Member#: 313793
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Indiana
Vehicle:
1997 Legacy L Wagon
Glacier white

Default

its the internet and subaru forums not grammerpolice.com
97SubieLegacyOUTL is offline   Reply With Quote
Old 10-03-2012, 04:05 PM   #7
zackg
Scooby Newbie
 
Member#: 248581
Join Date: Jun 2010
Chapter/Region: MAIC
Location: Pittsburgh
Vehicle:
2012 STI
WRB

Default

Listen. No one is going to help you when they can't/won't read what you posted. I gave up 1/4 of the way through. You're not doing us a favor, you're doing yourself a favor.
zackg is offline   Reply With Quote
Old 10-04-2012, 10:05 AM   #8
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Quote:
Originally Posted by 97SubieLegacyOUTL View Post
its the internet and subaru forums not grammerpolice.com
This is true, but it's also NOT retard land... so act like you belong to the human race... k thx
Aaron'z 2.5RS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.