Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-27-2012, 09:56 AM   #1
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default 2006 Electrical Problem????

Hello,

Quick, weird question- Don't know if this is an electrical problem, or a door sensor problem?

Here's the scenario- a majority of the time, when I take SHARP, RIGHT TURNS ONLY- my interior light comes on (dome in headliner), and so does the "Vehicles Dynamic Control warning light and vehicle dynamics control OFF indicator light. This light illuminates when the vehicle dynamics control OFF switch is pressed"

It's the Red light- where there's like squiggly tire marks underneath the car.

Any assistance would be greatly appreciated!
* Registered users of the site do not see these ads.
Salvation27 is offline   Reply With Quote
Old 09-27-2012, 11:20 AM   #2
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The switched ground wire for the dome light might be pinched somewhere or a screw is pearcing the insulation possibly. I don't know how that problem could affect the VDC light but it appears it is. When you the dome light trouble hopefully that problem will clear also. Another possible senario is the two circuits are bridging wires together where they shouldn't be. I would recommend you purchase the factory wiring manual to help you find and solve the problem. Ebay is a good source for them.
Cougar4 is offline   Reply With Quote
Old 09-27-2012, 01:35 PM   #3
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

.........
Salvation27 is offline   Reply With Quote
Old 09-27-2012, 01:36 PM   #4
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

Any other suggestions? Also- could it be from when I installed my headunit?
Salvation27 is offline   Reply With Quote
Old 09-27-2012, 01:46 PM   #5
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Did these problems exist before you installed the HU?

VDC = you have an automatic?
Big-E is offline   Reply With Quote
Old 09-27-2012, 01:55 PM   #6
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

No- it's manual, but thats the light that comes on!
Also, it has NEVER happened until recently, all within the past 2-3 weeks.

I did NOT do the HeadUnit or the LED Gauge conversion within that time frame. I did that almost 8 months ago, and problems just started recently

Last edited by Salvation27; 09-27-2012 at 03:12 PM.
Salvation27 is offline   Reply With Quote
Old 09-27-2012, 01:55 PM   #7
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

If it isn't that light, I'll try to get it to happen again- and see which light it is, but I'm almost positive.
Salvation27 is offline   Reply With Quote
Old 09-27-2012, 01:56 PM   #8
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

Also, let me add, that I DID try to do a bulb conversion in my dashboard/ gauges, but ended up just putting the original bulbs back in. (not the color change, just stronger LEDs)
Salvation27 is offline   Reply With Quote
Old 10-01-2012, 08:45 AM   #9
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

Bueller?
Salvation27 is offline   Reply With Quote
Old 10-05-2012, 07:29 AM   #10
Salvation27
Scooby Specialist
 
Member#: 292403
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: In Van Down By Rockaway River
Vehicle:
2006 WRX
Aspen White

Default

Ok- edit/bump- NOT the Dynamic Control light, just the "Door Ajar" light comes on with the dome light, but why? I've slammed all the doors, sensors seem to be ok for each door, yet when making Right Turns ONLY- it still happens?
Salvation27 is offline   Reply With Quote
Old 10-05-2012, 10:14 AM   #11
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Start with the interior lights.

Remove the inner trim where each door-switch is located and check for crimping of the wiring and related.

Remove each switch and test for continuity. Maybe a switch is bad so even if the door is closed, by the body flexing when you take a corner, this may be just enough movement to cause the switch to close, causing the lights to come on.
Big-E is offline   Reply With Quote
Old 10-06-2012, 10:59 AM   #12
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

I would start with the door switch in the driver's side door. It might be making contact in the turn. The switch makes a ground connection when the door is opened to turn on the light. Disconnect the switch and see it the problem clears. If it does, you know you have found the trouble.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.