Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-08-2012, 07:00 PM   #76
Subie_EPiC
Scooby Newbie
 
Member#: 212530
Join Date: May 2009
Default

Thanks Unabomber, very old post, but helped me out today when the airbag light came on.
* Registered users of the site do not see these ads.
Subie_EPiC is offline   Reply With Quote
Old 06-03-2012, 03:35 PM   #77
ryan d
Scooby Newbie
 
Member#: 265870
Join Date: Dec 2010
Chapter/Region: NESIC
Location: Tiverton
Vehicle:
2010 red hatch 2006
r6 raven.. 04 F-350

Default

this is happening to me as well right after i installed my boost, oil press, and air to fuel ratio gauge. is there anything in the dash that could have gotten loosened?? going in for an oil change next week. if not fixed by then ill have the dealer check it out. sorry for bringing an old thread back
ryan d is offline   Reply With Quote
Old 06-06-2012, 12:09 AM   #78
pcxrs
Scooby Newbie
 
Member#: 102538
Join Date: Dec 2005
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1998 Impreza Outback
Green

Default

My airbag light is on sometimes, and off sometimes. I haven't paid too much attention as i've been focused on my check engine light that's very recently off! I could see depending whats on the seat, bumping it, sitting on it could be wiggling the connector on/off. I'll go check it out.

So my 98 OBS doesn't seem to have any yellow connectors under the seats that I could see. Also, my airbag light wasn't staying on.

I'll see what I can find next time it comes on. Any other ideas about the airbag system in my 98 OBS?
pcxrs is offline   Reply With Quote
Old 06-18-2012, 04:30 PM   #79
401sti
Scooby Newbie
 
Member#: 321326
Join Date: May 2012
Chapter/Region: NESIC
Location: ri
Vehicle:
04 sti
silver

Default

Quote:
Originally Posted by Unabomber View Post
Just check the yellow connectors under your seats. Grab each one and smoosh the two sides of the connectors toward each other on the passenger and driver's seats and I'm placing 2:1 odds the light will go off and you will mentally thank someone from VA Beach with the username Unabomber..

dude, you are amazing had my airbag light pop on this morning and after doing all the diagnostic from alldata, watching youtube and ripping my hair out i found this thread and you totally fixed my problem, thanks so much Unabomber
401sti is offline   Reply With Quote
Old 06-18-2012, 04:39 PM   #80
pcxrs
Scooby Newbie
 
Member#: 102538
Join Date: Dec 2005
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1998 Impreza Outback
Green

Default

My airbag light comes on when I turn the steering wheel to either limit. It gets reset when the car turns off.
pcxrs is offline   Reply With Quote
Old 07-12-2012, 07:46 AM   #81
Abgrooms
Scooby Specialist
 
Member#: 298640
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2013 STI SWP
Nitrous Rhodes

Default

Quote:
Originally Posted by Unabomber View Post
Just check the yellow connectors under your seats. Grab each one and smoosh the two sides of the connectors toward each other on the passenger and driver's seats and I'm placing 2:1 odds the light will go off and you will mentally thank someone from VA Beach with the username Unabomber.

Oh and this should go in the Electrical Forum...
^ Worked for me. Searched "Airbag light".
This was the first thread I clicked. Thanks Unabomber.
Abgrooms is offline   Reply With Quote
Old 08-15-2012, 01:07 AM   #82
Kenudo
Scooby Newbie
 
Member#: 329165
Join Date: Aug 2012
Default

Hey guys, im brand new here, looking to purchase an '04 WRX and the one I'm serious about right now has nothing wrong with it except the airbag light comes on from time to time. Is this something that anyone here has experience with in regards to possible repairs besides wire connections? I'd like to know how much money I will possibly have to put into it if theres a legit problem. Right now the price is okay at $9,200 with 120k miles. But I dont wanna have to put another grand into it right off the bat
Kenudo is offline   Reply With Quote
Old 08-15-2012, 01:12 AM   #83
pcxrs
Scooby Newbie
 
Member#: 102538
Join Date: Dec 2005
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1998 Impreza Outback
Green

Default

Does the horn work? Do the other steering wheel controls work? If they work, it's not the roll connector in the steering wheel, if they don't work, it is. The part is between $200-$500.

It could also be as easy as snapping the connectors under the seats together... 5 minutes, free!
pcxrs is offline   Reply With Quote
Old 08-15-2012, 01:24 AM   #84
Kenudo
Scooby Newbie
 
Member#: 329165
Join Date: Aug 2012
Default

Yeah all that works. I'm not gonna be able to see the car until Tuesday so I think I'll give that a try. If it doesn't work, I'm not sure what I'll do
Kenudo is offline   Reply With Quote
Old 08-23-2012, 04:20 PM   #85
Nukinfutz88
Scooby Specialist
 
Member#: 310449
Join Date: Feb 2012
Location: Tri-state
Vehicle:
2004 STI
Aspen White

Default

Thanks mulder!.... Got nervous when my light came on outa nowhere untill I read this ... Fixed it!
Nukinfutz88 is offline   Reply With Quote
Old 08-29-2012, 07:05 AM   #86
rdandy5875
Scooby Newbie
 
Member#: 182475
Join Date: Jun 2008
Default

My drivers seat connector was the culprit. I was getting ready to bend over for the dealer, but this thread saved the day. Thanks OP.
rdandy5875 is offline   Reply With Quote
Old 10-06-2012, 02:21 PM   #87
packerhs
Scooby Newbie
 
Member#: 332866
Join Date: Sep 2012
Vehicle:
2004 WRX
Silver

Default Airbag Light On

I'm a newbie here, just got an 04 WRX with 143K from my son (thanks SLYWRX, you can stay in the will!). Got the airbag light earlier this week and was dreading having to troubleshoot it. SLYWRX researched the forum for me and said there's a lot of incidents with the connectors under the seat coming loose. Well, went out just now, squeezed two connectors under the passenger seat and one under the driver seat, cranked the engine and what do you know - no airbag light. Bottom line - if you get the light, do what the thread says - check the underseat connectors.
packerhs is offline   Reply With Quote
Old 01-28-2013, 12:27 PM   #88
gracerx
Scooby Newbie
 
Member#: 300759
Join Date: Nov 2011
Location: Seattle
Vehicle:
2004 WRX Sport Wagon
Java Black

Default

Thanks again for this Unabomber. This happened to me last night, and when I got to work this morning I quickly did the smoosh technique and presto!

Thanks!
gracerx is offline   Reply With Quote
Old 01-31-2013, 11:49 AM   #89
DownhillSubie
Scooby Newbie
 
Member#: 342985
Join Date: Jan 2013
Chapter/Region: Tri-State
Default

Quote:
Originally Posted by mikercp View Post

Other than that the srs system should see all the plugs connected and clear it on its own...
That is BS.
DownhillSubie is offline   Reply With Quote
Old 03-14-2013, 01:38 PM   #90
Whitehispanic
Scooby Newbie
 
Member#: 336958
Join Date: Nov 2012
Default Hello guys

I just recently bought a Subaru Legacy and the airbag light comes, now i am trying not to go back to the dearlership as my 30 day warranty is over. If i push the connectors together is this going to prevent my airbag from deploying in case i get into an accident?
Whitehispanic is offline   Reply With Quote
Old 03-25-2013, 05:26 PM   #91
Wmartin03
Scooby Newbie
 
Member#: 333797
Join Date: Sep 2012
Chapter/Region: SCIC
Vehicle:
2004 impreza WRX
Silver

Default

Quote:
I just recently bought a Subaru Legacy and the airbag light comes, now i am trying not to go back to the dearlership as my 30 day warranty is over. If i push the connectors together is this going to prevent my airbag from deploying in case i get into an accident?
What? No! These are part of the system, the reason the light is on is that the contact is not happening. If anything the airbag may not deploy if you don't push the connectors back together.
Wmartin03 is offline   Reply With Quote
Old 03-28-2013, 05:03 PM   #92
BJackson
Scooby Newbie
 
Member#: 291902
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Ohio
Vehicle:
2006 Impreza Outback
Silver

Default

I have an 06 Impreza Outback Sport. Airbag light would come on here and there, didn't really think much of it. For the past few months it continuously stays on and the passenger airbag indicator always reads OFF. Took it to the dealer and as typical dealers they told me I had to replace the dash clock. $300 later I left the dealer after they tried to get me to buy a new passenger seat for $600 or some insane number like that. Researching this problem, I've found it's pretty common. I recently put electrical silicone on all the passenger sensor connectors under the seat, in hopes that it would help the connections, but it didn't fix anything. Now I've pretty much turned to finding new seats online since the sensor doesn't seem to be working. Any thoughts?
BJackson is offline   Reply With Quote
Old 04-11-2013, 06:32 PM   #93
RedSubie11
Scooby Newbie
 
Member#: 352553
Join Date: Apr 2013
Chapter/Region: NWIC
Location: Pacific North West
Vehicle:
2004 WRX
Red

Default light is now gone

Quote:
Originally Posted by Unabomber View Post
Just check the yellow connectors under your seats. Grab each one and smoosh the two sides of the connectors toward each other on the passenger and driver's seats and I'm placing 2:1 odds the light will go off and you will mentally thank someone from VA Beach with the username Unabomber.

Oh and this should go in the Electrical Forum...
Thanks a bunch Unabomber, worked right away!
RedSubie11 is offline   Reply With Quote
Old 04-14-2013, 07:13 PM   #94
kylech
Scooby Newbie
 
Member#: 179987
Join Date: May 2008
Chapter/Region: SCIC
Location: a dark cave
Vehicle:
06 sti

Default

I have many reasons to thank you Unabomber, and NASIOC, but I have now tried to smoosh all my connectors together every few months, because I try to find new threads with this problem, and that's all it ever is for 99.9% of the people.

I've taken them apart, tried my best to clean them, compressed air etc. and nothing works.

I pulled my seats out to clean my carpets really well and have had this light on my dash for almost a year now.

Any other ideas before I lose my $$ and sanity to the stealership would be greatly appreciated.

Thanks again for all the technical support over the years.
kylech is offline   Reply With Quote
Old 04-14-2013, 07:33 PM   #95
MD04WRX
Scooby Guru
 
Member#: 72891
Join Date: Oct 2004
Chapter/Region: MAIC
Location: In the blue & hating it!
Vehicle:
2014 Molten ST
98 2.5GT -2014 XV

Default

Quote:
Originally Posted by kylech View Post
I have many reasons to thank you Unabomber, and NASIOC, but I have now tried to smoosh all my connectors together every few months, because I try to find new threads with this problem, and that's all it ever is for 99.9% of the people.

I've taken them apart, tried my best to clean them, compressed air etc. and nothing works.

I pulled my seats out to clean my carpets really well and have had this light on my dash for almost a year now.

Any other ideas before I lose my $$ and sanity to the stealership would be greatly appreciated.

Thanks again for all the technical support over the years.
So you pulled the seats to clean the carpet and the light has been on ever since? Since your car is an 06 you have other possible issues. The 06 up cars also have seat position sensors and the passenger seat has a active weight sensor. If you have checked and rechecked all the connections you need to get the code read. If you are in an accident one the front airbags may fail to deploy if one of those sensors is the problem.
MD04WRX is offline   Reply With Quote
Old 04-14-2013, 08:34 PM   #96
kylech
Scooby Newbie
 
Member#: 179987
Join Date: May 2008
Chapter/Region: SCIC
Location: a dark cave
Vehicle:
06 sti

Default

I know all of that, thank you for your concern of my non passengers.

So besides taking it to the dealership...?
kylech is offline   Reply With Quote
Old 04-14-2013, 08:53 PM   #97
MD04WRX
Scooby Guru
 
Member#: 72891
Join Date: Oct 2004
Chapter/Region: MAIC
Location: In the blue & hating it!
Vehicle:
2014 Molten ST
98 2.5GT -2014 XV

Default

Quote:
Originally Posted by kylech View Post
I know all of that, thank you for your concern of my non passengers.

So besides taking it to the dealership...?
Really?? The concern is for you also. Dealerships are not the only ones that can read airbag codes. You don't have to have them fix it, just read the code. Some charge a minimum 1 hour labor / check out time and really they shouldn't charge more than 1/2 hour just to read a code.
MD04WRX is offline   Reply With Quote
Old 04-14-2013, 09:36 PM   #98
nmlittlebigman
Scooby Specialist
 
Member#: 321409
Join Date: May 2012
Chapter/Region: SWIC
Location: Arrey, NM
Vehicle:
2015 WRX LTD
WRB

Default

Quote:
Originally Posted by MD04WRX View Post
Really?? The concern is for you also. Dealerships are not the only ones that can read airbag codes. You don't have to have them fix it, just read the code. Some charge a minimum 1 hour labor / check out time and really they shouldn't charge more than 1/2 hour just to read a code.
SRS diagnostics are done through a separate connector and not the OBD2. The system is capable of self diagnosis and codes are given through flashing light sequences.
http://www.northursalia.com/techdocs...trical/srs.pdf

Here's how to find the connector, jumper it, read the codes and diagnose:


http://codes.rennacs.com/SRS-Airbag/...ru-Airbags.php


EDIT: I found out that the dealership does go through the OBD2 port for my '11 (I assume everything '08+). They have a specialized netbook with the diagnostic program.

http://www.scoobymods.com/showthread...ght-13849.html

Last edited by nmlittlebigman; 05-04-2013 at 01:53 PM.
nmlittlebigman is offline   Reply With Quote
Old 04-14-2013, 11:19 PM   #99
kylech
Scooby Newbie
 
Member#: 179987
Join Date: May 2008
Chapter/Region: SCIC
Location: a dark cave
Vehicle:
06 sti

Default

Quote:
Originally Posted by MD04WRX View Post
Really?? The concern is for you also. Dealerships are not the only ones that can read airbag codes. You don't have to have them fix it, just read the code. Some charge a minimum 1 hour labor / check out time and really they shouldn't charge more than 1/2 hour just to read a code.
I appreciate the concern. I haven't been able to count a friend on one finger for a few years now and haven't had anyone else in my car for quite a while either, and besides my overbearing mother, nobody has shown any concern for my safety, well being or happiness in years. Thank You! If I can't figure this out, I will be forced to either continue ignoring the light, or take some heavy anxiety meds and hit a dealership. I've been to 4 in my area and they make it a hassle just to buy oil/filter/crush rings.

Quote:
Originally Posted by mnlittlebigman
SRS diagnostics are done through a separate connector and not the OBD2. The system is capable of self diagnosis and codes are given through flashing light sequences.
http://www.northursalia.com/techdocs...trical/srs.pdf

Here's how to find the connector, jumper it, read the codes and diagnose:


http://codes.rennacs.com/SRS-Airbag/...ru-Airbags.php

http://www.scoobymods.com/showthread...ght-13849.html
Thank You! I will have some dash diving to do tomorrow. Some of the instructions are written like a bad translation, but I think I get the idea, as long as I can find that connector/plug.
kylech is offline   Reply With Quote
Old 04-15-2013, 04:50 PM   #100
kylech
Scooby Newbie
 
Member#: 179987
Join Date: May 2008
Chapter/Region: SCIC
Location: a dark cave
Vehicle:
06 sti

Default

Does anyone know where the SRS/airbag test connector is located on an 06, well, 05+?

I read and re read everything I could find, and pulling the dash and fuse box I found where the test connector would be on up to 04's. If you watch the vehix411 video's the test connector is right by or in the same loom as the two little green connectors.

I also read that but couldn't exactly verify that the 05+ requires a special tool that plugs into the regular OBD port, and that it's also really freakin expensive, and those that have them want to make their tool cost back in the first week of usage.

So if it's hidden somewhere else and you know, I and another who PM'd me would love to know where.

My google fingers are worn out from trying all different combinations of airbag, SRS, diagnostic, test harness, and I'm right back where I was.

And I pulled the seats again, triple checked all connections, wiring, etc. and I'm stumped.

Thanks for any and all help suggestions, besides going to the mfdealer.
kylech is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag light is on, aftermarket seats, 4 airbag cords? subierider Interior & Exterior Modification 7 10-26-2008 05:00 PM
Replacing airbag OE seats - airbag light on? fpan Interior & Exterior Modification 4 10-19-2008 10:06 PM
Airbag light having nothing to do with airbags? coloradosti Interior & Exterior Modification 2 06-27-2004 05:02 PM
('93-'01) airbag light on? ferretboy Impreza Forum 3 05-29-2001 10:39 PM


All times are GMT -4. The time now is 03:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.