Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2012, 01:12 PM   #1
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default Where is my coolant going?

I noticed my coolant overflow tank below the MIN line, mixed up some Subaru coolant (50/50) and raised the level to the MAX line in the overflow tank yesterday. Checked again today and it's the same level as yesterday. at the MIN line. Popped open the coolant tank above the turbo and the coolant level is at the top.

Why is coolant disappearing from my overflow tank?
* Registered users of the site do not see these ads.
eurospek is offline   Reply With Quote
Old 10-03-2012, 01:17 PM   #2
tebriel
Scooby Newbie
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 BRP WRX Wagon
2004 JBP WRX

Default

Well it's either leaking out or being burned.
tebriel is offline   Reply With Quote
Old 10-03-2012, 01:20 PM   #3
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Quote:
Originally Posted by tebriel View Post
Well it's either leaking out or being burned.
Looking at my radiator, and the piping going to and from it it looks clean, checked under the turbo heatshield and also looks ok. Where else can I check for leaks?

If it's being burned, it's a sign of what? What's burning it?
eurospek is offline   Reply With Quote
Old 10-03-2012, 01:29 PM   #4
03sportwagon
Scooby Newbie
 
Member#: 252943
Join Date: Jul 2010
Chapter/Region: NWIC
Location: boise id
Vehicle:
2003 wrx sport wagon
silver

Default

Look at exhaust and see,smell. If you got fluid in exhaust u may need new head gasket
03sportwagon is offline   Reply With Quote
Old 10-03-2012, 01:34 PM   #5
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Quote:
Originally Posted by 03sportwagon View Post
Look at exhaust and see,smell. If you got fluid in exhaust u may need new head gasket
Exhaust seems fine, smells fine too.

Just called my mechanic (6 Star Motorsports) and was told the level of coolant will fluctuate in the reservoir tank. Either way, I'll know on Monday for sure about leaks, have scheduled an appointment for then.

I'll keep you guys posted.
eurospek is offline   Reply With Quote
Old 10-03-2012, 04:14 PM   #6
h00z0r
Scooby Newbie
 
Member#: 212540
Join Date: May 2009
Chapter/Region: Tri-State
Location: the 315 (normally)
Vehicle:
2002 WRX Battlewagon
PSM

Default

Check your lower hose's water neck, it cruds up and weeps onto the exhaust manifold and burns away, mine did it and never left a drop on the ground and I could never smell it in the car
h00z0r is offline   Reply With Quote
Old 10-03-2012, 06:00 PM   #7
NFJ79
Scooby Specialist
 
Member#: 90750
Join Date: Jul 2005
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2000 RS EJ207 Hybrid
05 Ducati Monster S2R

Default

Check under intake manifold for leaks. I had a pool of coolant from a leaking hose clamp on top of the block.
NFJ79 is online now   Reply With Quote
Old 10-06-2012, 01:07 AM   #8
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Okay, something's definitely leaking. I can smell the burnt coolant.

Looked around with a flashlight and found a nice coolant puddle under the PCV valve (which was replaced about 20K miles ago with OEM).



Quote:
Originally Posted by NFJ79 View Post
Check under intake manifold for leaks. I had a pool of coolant from a leaking hose clamp on top of the block.
Yup, the coolant pool is definitely on top of the block. I'll confirm tomorrow with daylight once I snoop around some more. How serious of an issue is this to drive around with?

Last edited by eurospek; 10-06-2012 at 01:20 PM.
eurospek is offline   Reply With Quote
Old 10-06-2012, 03:42 PM   #9
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

I'ts not a huge issue.
quazimoto is online now   Reply With Quote
Old 10-06-2012, 03:53 PM   #10
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Quote:
Originally Posted by quazimoto View Post
I'ts not a huge issue.
Safe to say I can take a 100 mile trip tomorrow biking before my visit to the shop on Monday?
eurospek is offline   Reply With Quote
Old 10-08-2012, 04:29 PM   #11
eurospek
Scooby Guru
 
Member#: 96944
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Hampshire, IL
Vehicle:
2005 SAAB 9-2X AERO
4eat Stage 2 Protuned

Default

Got it fixed today and back on the road.

Turns out one of the coolant lines on the throttle body had a weak clamp, along with a cracked line.
eurospek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.