Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-06-2012, 11:52 AM   #1
kev20
Scooby Newbie
 
Member#: 314303
Join Date: Mar 2012
Question sti 2007 rough start/ hesitation

Hi!

I search to find my problem but not find

The problem begin after i got tuned
Im not sure but im think its a scaling issue

modification
cobb sf intake
turboback
header
injector 650cc dw
fuel pump dw
ecutek

The car start fine at cold but when i come to start when the car is hot, the car shake a lot and run really rich 11:1-11.5:1 afr
If i give a little gaz . the car come back to normal 14:5:1afr

The car have alose a little hesitation between 2000-3000rpm BUt not Always
And i can read lean on this spot (15-16:1afr)

But at wot, the car have not hesitation

its like a bad o2 sensor, but i change it 800mile ago

please if you can help me...
* Registered users of the site do not see these ads.
kev20 is offline   Reply With Quote
Old 10-06-2012, 01:44 PM   #2
APM Tuned
NASIOC Vendor
 
Member#: 282460
Join Date: May 2011
Chapter/Region: MWSOC
Location: Villa Park, IL
Vehicle:
2005 Evo-STI
R.R.-WRB

Default

go back and talk to your tuner, this isn't a simple fix for a board...more a touch, feel and see type of thing.

-Mark
APM Tuned is offline   Reply With Quote
Old 10-06-2012, 02:17 PM   #3
kev20
Scooby Newbie
 
Member#: 314303
Join Date: Mar 2012
Default

Yes i know, The tuner is has more than 7 hours of road, that why i wanna know if its really in the tune
kev20 is offline   Reply With Quote
Old 10-06-2012, 03:54 PM   #4
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 45 AMG MB
WHITE /07 STI IS SOLD

Default

its ether the tune or bad dw injectors .
tekfoc is offline   Reply With Quote
Old 10-06-2012, 05:35 PM   #5
kev20
Scooby Newbie
 
Member#: 314303
Join Date: Mar 2012
Default

Quote:
Originally Posted by tekfoc View Post
its ether the tune or bad dw injectors .
There is someone who had some trouble with deatchswerks injectors?
kev20 is offline   Reply With Quote
Old 10-06-2012, 06:47 PM   #6
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 45 AMG MB
WHITE /07 STI IS SOLD

Default

Quote:
Originally Posted by kev20 View Post
There is someone who had some trouble with deatchswerks injectors?
You have to remember that dw are just modified stock used injectors.
Yes their are people out there who has had problems with dw's .
This is my choice I suggest new injectors like ID OR PE INJECTORS .
Bring it back to your tuner let him look over the map .
He should easly be able to see if its his mistake or possible bad injectors .
tekfoc is offline   Reply With Quote
Old 10-06-2012, 07:43 PM   #7
kev20
Scooby Newbie
 
Member#: 314303
Join Date: Mar 2012
Default

Quote:
Originally Posted by tekfoc View Post
You have to remember that dw are just modified stock used injectors.
Yes their are people out there who has had problems with dw's .
This is my choice I suggest new injectors like ID OR PE INJECTORS .
Bring it back to your tuner let him look over the map .
He should easly be able to see if its his mistake or possible bad injectors .
good to know thx, but If the injectors is bad, i dont know why the car start well on cold start
kev20 is offline   Reply With Quote
Old 10-06-2012, 09:28 PM   #8
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 45 AMG MB
WHITE /07 STI IS SOLD

Default

[quote=kev20;38212658]good to know thx, but If the injectors is bad, i dont know why the car start well on cold start[/quote
Don't want to speculate .
Let the tuner look at the tables and scalings.

A good tuner is your friend.

Good luck

Last edited by tekfoc; 10-06-2012 at 09:33 PM.
tekfoc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.