Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-09-2012, 01:41 PM   #1
rosedaleny806
Scooby Specialist
 
Member#: 202070
Join Date: Feb 2009
Chapter/Region: Tri-State
Location: Queens, NYC/East Meadow, NY
Vehicle:
2012 WRX GR WRB
2002 WRX GD PSM

Default Wooshing Noise/BOV builsd up noise coming from BPV Area, Any Help!

So yes im having this loud wooshing/BOV building up sound coming from my BPV area. I installed a Forge BPV recently and it started making that sound so i thought it was maybe the BPV, i put the stock back in and still the same sound. i check my boost gauge and it seems to hit a lb or less of what im suppose to be hitting and it takes forever to hit peak boost. it has to be a boost leak but from where?? i was on Cobb Stage1 hitting about 16.7~ and only hitting about 14-15 and taking forever to hit it and now i divorced the cobb and only hitting about 13~ and again takes forever to get to it and my needle is wobbly at higher rpms (SPT boost gauge)

thanks again in advanced.

Last edited by rosedaleny806; 10-09-2012 at 01:51 PM.
rosedaleny806 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.