Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-10-2012, 01:28 PM   #4501
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

Yea mine has that sensor
* Registered users of the site do not see these ads.
todeswalzer is offline   Reply With Quote
Old 10-10-2012, 01:37 PM   #4502
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

result.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 01:44 PM   #4503
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

i personally am running nearly the same timing on my ej207 as they have mapped in japan. i just have a smoother curve transition and stuff like that. using the s204 avcs and timing map as a reference at least.
WhiteBgeye02 is offline   Reply With Quote
Old 10-10-2012, 01:45 PM   #4504
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default





These are the Sponaugle tables.

John only posted information amounting to a fraction of this table. In it, the engine code numbers are correlated to the piston part number and the versions.
If you want to skip the versions, it's your choice.
Vlad is offline   Reply With Quote
Old 10-10-2012, 01:53 PM   #4505
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Model code numbers are wrong in that table for MY05!
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 01:58 PM   #4506
fastnoypi
Scooby Specialist
 
Member#: 6886
Join Date: May 2001
Chapter/Region: Tri-State
Vehicle:
MY01 EJ207 HTA35r
nothing to see, i'm stock

Default

Quote:
Originally Posted by johnfelstead View Post
Model code numbers are wrong in that table for MY05!
does your source specify the reference market? UK vs JDM?
fastnoypi is offline   Reply With Quote
Old 10-10-2012, 02:02 PM   #4507
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default

In what respect are you saying the model number codes are wrong?
And based on what source?
Vlad is offline   Reply With Quote
Old 10-10-2012, 02:06 PM   #4508
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

Quote:
Originally Posted by johnfelstead View Post
I dont think so.

If the plenum has a temperature sensor in it, then it is at least an MY05. If it doesnt then it's MY04 or earlier.
mine has an 03 stamp under the oil fill and its got the temp sensor under the IC...
PHruska is offline   Reply With Quote
Old 10-10-2012, 02:07 PM   #4509
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by Vlad View Post
In what respect are you saying the model number codes are wrong?
And based on what source?
Based on the big lump of MY05 Widetrack Blobeye JDM Obsidian Black Pearl Goodness sat outside my front door and the chassis plate on that.

Model code for MY05 JDM STi is GDBE4EH, the table has the wrong year code ( which should be E) against the MY05 models in the model code table.

Last edited by johnfelstead; 10-10-2012 at 02:12 PM.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 02:11 PM   #4510
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by PHruska View Post
mine has an 03 stamp under the oil fill and its got the temp sensor under the IC...
Oil fill is on the other side of the engine to the code sticker, you looking at something that isnt the engine code?
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 02:13 PM   #4511
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Excuse me if I'm the only one getting confused by this. What the heck are you talking about when you say "Widetrack Blobeye"????? Did only Europe get this widetrack or Japan too?
25rsti is offline   Reply With Quote
Old 10-10-2012, 02:20 PM   #4512
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by 25rsti View Post
Excuse me if I'm the only one getting confused by this. What the heck are you talking about when you say "Widetrack Blobeye"????? Did only Europe get this widetrack or Japan too?
It was Japan and Europe.

The MY05 Widetrack Blobeye was the last model year before the Hawkeye, it has a wider track at the rear than the MY03/04, 114.3mm PCD hubs, 8x17 wheels, longer wheelbase which matches the spec C, later generation DCCD-A with Yaw and steering wheel position sensors.......

Easiest visual indication of the Widetrack car is the extra blisters fitted to the rear wheel arches, to accomodate the wider track and wider wheels.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 02:21 PM   #4513
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

I'd assume he means the equivalent to the usdm 05 sti, with the fender archers due to the wider track
todeswalzer is offline   Reply With Quote
Old 10-10-2012, 02:25 PM   #4514
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

Quote:
Originally Posted by johnfelstead View Post
Oil fill is on the other side of the engine to the code sticker, you looking at something that isnt the engine code?
on the inside of the oil fill cap there is a stamp with the year the engine was produced.

my timing sticker says ej207dw5cr
PHruska is offline   Reply With Quote
Old 10-10-2012, 02:28 PM   #4515
simon021
Scooby Specialist
 
Member#: 157532
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
2002 MY03 EJ207 E85
Dom 1.5XTR Twinscroll!

Default

Quote:
Originally Posted by johnfelstead View Post
I dont think so.

If the plenum has a temperature sensor in it, then it is at least an MY05. If it doesnt then it's MY04 or earlier.
The MY03 that I have, has this intake sensor in the plenum below the throttlebody.
simon021 is offline   Reply With Quote
Old 10-10-2012, 02:36 PM   #4516
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default

The model numbers are wrong for 05, they should have E in the description, for rev E, in the 4th designator of the code.
The table is still good, other than this.
Vlad is offline   Reply With Quote
Old 10-10-2012, 02:39 PM   #4517
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by simon021 View Post
The MY03 that I have, has this intake sensor in the plenum below the throttlebody.
It's not homologated, i'll take a look at an MY03 Spec C engine at the weekend and see if the homologation sheet is wrong.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 02:50 PM   #4518
Torquey
Scooby Specialist
 
Member#: 175334
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2003 Impreza WRX
JDM v8 EJ207 WRB

Default

Quote:
Originally Posted by johnfelstead View Post
I dont think so.

If the plenum has a temperature sensor in it, then it is at least an MY05. If it doesnt then it's MY04 or earlier.
John.. are we sure about this, cause my engine code is EJ207DW6CR (according to your list it's MY04):






And i do have this IAT sensor on the intake manifold (currently unplugged):

Torquey is offline   Reply With Quote
Old 10-10-2012, 02:51 PM   #4519
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default

The sensor is there since rev C.
Vlad is offline   Reply With Quote
Old 10-10-2012, 02:53 PM   #4520
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Based on that i'd say the homologation sheet is wrong Torquey.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 03:10 PM   #4521
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

trying to move pins on my ecu but the white locks at the top are stuck. dont want to destroy the clips. goddamn it.
PHruska is offline   Reply With Quote
Old 10-10-2012, 03:16 PM   #4522
azscooby
Scooby Specialist
 
Member#: 115297
Join Date: May 2006
Chapter/Region: SWIC
Location: Mesa, AZ
Vehicle:
2002 ej207 vf34
WRB

Default

My V8 EJ207DW5CR has the temp sensor in the plenum (right under throttle body) and the oil filler says 7/03..

I was under the impression mine was a model year 2003/2004.....?

John your new info would suggest mine is a model year 2005, since it has the temp sensor?

I find that confusing if not contradictory to what the date on my oil cap says, though of course its entirely possible its not an original cap.

Last edited by azscooby; 10-10-2012 at 03:25 PM.
azscooby is offline   Reply With Quote
Old 10-10-2012, 03:19 PM   #4523
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

small screw driver and force the locks up. only way to do it. then push them back down and if it make syou fell better put some tape around it or a zip tie. or both!
WhiteBgeye02 is offline   Reply With Quote
Old 10-10-2012, 03:19 PM   #4524
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

What A Cluster **** Of Three Pages Of Info!
WhiteBgeye02 is offline   Reply With Quote
Old 10-10-2012, 03:41 PM   #4525
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

Quote:
Originally Posted by WhiteBgeye02
What A Cluster **** Of Three Pages Of Info!
Seriously.
todeswalzer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ej207 owner wants opinions adbramsay Factory 2.0L Turbo Powertrain 2 02-26-2011 07:29 PM
Ej207 V6 AndrewFD3 Factory 2.0L Turbo Powertrain 10 06-03-2010 04:53 PM
JDM Sti EJ207 V9 crank 75mm or billet crank (K1, Manley) VENDORS ??? L'frise Private 'Wanted' Classifieds 7 06-03-2010 09:24 AM
08 ej207 JDM dual AVCS heads on a built v7 ej207 icev7 Built Motor Discussion 17 02-21-2010 03:21 PM
Ver 8 EJ207 Owners Check In spoolinsuby Factory 2.0L Turbo Powertrain 21 10-17-2005 01:56 AM


All times are GMT -4. The time now is 12:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.