Welcome to the North American Subaru Impreza Owners Club Wednesday June 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-07-2012, 04:56 PM   #1
purdyclevur
Scooby Newbie
 
Member#: 288781
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
2004 Impreza WRX
Red

Default 04 WRX Engine Noise need help!!!

Check out this video:

Its a 2004 Subaru Impreza WRX 2.0L - Does anyone know what this ticking or knock could be? I think it could be something with the valves but I have no idea. Going to do a compression test and take the oil pan off to see what I can find and check the oil for shavings. Any other ideas on what I can check myself? It doesn't overheat and when it idles sometimes the ticking isn't near as loud. Hoping its not a problem with the pistons or engine block.
* Registered users of the site do not see these ads.
purdyclevur is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-07-2012, 09:33 PM   #2
tebriel
Scooby Specialist
 
Member#: 244190
Join Date: Apr 2010
Location: Madison, WI
Vehicle:
2004 WRB WRXes
Sedan and Wagon

Default

I would be surprised if that was anything other than rod knock. Maybe a destroyed valve of some sort?
tebriel is offline   Reply With Quote
Old 10-07-2012, 09:46 PM   #3
Tech5000
Scooby Newbie
 
Member#: 330575
Join Date: Aug 2012
Location: Queens, NY
Vehicle:
05 Subaru WRX
Pearl Blue

Default

Same thing happened to mine last week. Got the same exact noise! Your motor is toast.. Its Rod Knock. Spun Bearing.. Makes me wanna cry every time i hear it.
Tech5000 is offline   Reply With Quote
Old 10-10-2012, 05:19 PM   #4
art@grimmspeed
NASIOC Vendor
 
Member#: 301037
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2004 Forester XT
Aspen White

Default

Yep it is a dead bearing. It was/is a common issue with the 2.0L. Sorry to hear that.
art@grimmspeed is offline   Reply With Quote
Old 10-11-2012, 12:08 PM   #5
kev29
Scooby Newbie
 
Member#: 321425
Join Date: May 2012
Location: New York City
Vehicle:
2002 Impreza WRX
Aspen White

Default

It can also be an idler or timing belt tensioner. Take off your timing belt cover to see if it gets louder or if you can see anything.
kev29 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.