Welcome to the North American Subaru Impreza Owners Club Sunday July 24, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-10-2012, 09:09 PM   #1
jonesy08
Scooby Newbie
 
Member#: 333611
Join Date: Sep 2012
Location: spanaway, wa
Vehicle:
2003 impreza wrx
white

Thumbs down clutch, burning oil and vibration

I just purchased a 2003 wrx with 120,000 miles on it about 2 weeks ago. It had been hit in the front left and wasn't fixed(dealership was just going to wholesale it to a lot, but tried selling it themselves first). For this reason I picked it up for about 3000 under KBB value, figured "fender, bumper and headlight?" not a problem. Have replaced all of that and am now fiding more things, which are going to prove more expensive, I know. Today I noticed it was burning quite a bit of oil when I was in boost in 3rd gear getting on the highway. I don't have a boost gauge(doing that saturday) so I don't know exactly when it started happening in the boost range. Haven't checked turbo for oil coming out of it tonight to rule that it needs that, but thats what I'm thinking. Any other ideas? Are valve seats something I should be thinking about? This is my DD and I can't afford to rip it out to rebuild the heads at this current moment.

Also noticed a whining sound while slowing down, most noticeable in second gear, that goes away when I push the clutch in. The clutch does not slip though.

And last, and hopefully least, while cruising down the road the car seems to have a slight "bounce" to it, idk how else to describe it.

Any and all help on these is greatly appreciated, haven't had time to get to do any troubleshooting on any of this yet.
jonesy08 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.