Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-17-2012, 11:42 AM   #426
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

Quote:
Originally Posted by bjcarter2 View Post
You mail-ordered a wife?
oh man, no but thats a good idea. Do they ship in boxes with those clear plastic fronts so you can see the product before opening?
* Registered users of the site do not see these ads.
Mavrik is offline   Reply With Quote
Old 10-17-2012, 11:58 AM   #427
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Yeah, but there's usually unseen damage anyways.

lol50lbsmail-orderwife
chanomatik is offline   Reply With Quote
Old 10-17-2012, 12:23 PM   #428
AKMUNKIE
Scooby Newbie
 
Member#: 333463
Join Date: Sep 2012
Chapter/Region: AKIC
Location: Anchorage
Default

Well yesterday I replaced my valve cover gaskets and also put on the muffler that came with the car I purchased. Strangely enough now though when my car is running and I push the clutch in or put the car in neutral it revs up to like 2K rpm's and continues to rise. It was "idling" at 3,800rpm at one point. I don't understand what happened. First thought was that it had something to do with my exhaust then after that I thought it might be my throttle positioning sensor. Any ideas on this??
AKMUNKIE is offline   Reply With Quote
Old 10-17-2012, 02:06 PM   #429
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

That's an interesting problem. Search over here at http://bbs.legacycentral.org/
That site is hands down the best 1st gen Legacy site out there.
Dominator is online now   Reply With Quote
Old 10-17-2012, 03:09 PM   #430
coldfiremx
Scooby Specialist
 
Member#: 285848
Join Date: Jun 2011
Chapter/Region: AKIC
Location: Butte/Palmer
Vehicle:
2002 WRX
Black

Default

Quote:
Originally Posted by ridestreet84
Changed out the t-stat in the Sti today
Dang, for cold weather?!?
coldfiremx is offline   Reply With Quote
Old 10-17-2012, 03:15 PM   #431
AKMUNKIE
Scooby Newbie
 
Member#: 333463
Join Date: Sep 2012
Chapter/Region: AKIC
Location: Anchorage
Default

Quote:
Originally Posted by Dominator View Post
That's an interesting problem. Search over here at http://bbs.legacycentral.org/
That site is hands down the best 1st gen Legacy site out there.
Thanks man, I am a member on that site also and searched it and also posted the problem there. Hopefully someone may have some idea about it.
AKMUNKIE is offline   Reply With Quote
Old 10-17-2012, 05:10 PM   #432
snowdrift86
Scooby Newbie
 
Member#: 273920
Join Date: Feb 2011
Chapter/Region: AKIC
Location: Wasilla
Vehicle:
05 Legacy GT
Regal Blue Pearl

Default

Sounds like an intake leak or a sensor issue
snowdrift86 is offline   Reply With Quote
Old 10-17-2012, 07:09 PM   #433
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Perrin FMIC pipes arrived!

cosseywrx is offline   Reply With Quote
Old 10-17-2012, 10:40 PM   #434
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Finally in my possession!


Last edited by _davin; 10-18-2012 at 03:40 AM.
_davin is online now   Reply With Quote
Old 10-18-2012, 01:00 PM   #435
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

So meanwhile, on a car forum thread about doing things to your car...

My new aerodynamic wheel arch extenders with custom ice spats...


Dirty Winter Mode - now studded for your driving pleasure...
Dominator is online now   Reply With Quote
Old 10-18-2012, 09:49 PM   #436
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

2.0l gasket kit arrived! and FMIC core
cosseywrx is offline   Reply With Quote
Old 10-18-2012, 10:46 PM   #437
05GDF
Scooby Newbie
 
Member#: 281488
Join Date: Apr 2011
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2005 STi
OBP

Default

Yesterday I had Paul flushed and filled the rear diff and tranny fluid. Very awesome guy, again thanks!
05GDF is offline   Reply With Quote
Old 10-19-2012, 01:56 AM   #438
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

cosseywrx is offline   Reply With Quote
Old 10-19-2012, 06:04 AM   #439
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

I wired up a PWM (pulse width modulator) for my boost gauge. I got it to to regulate the light output of the LED backlighting of it. Just a cheap kit I got off ebay, but hopefully it does the trick. I'll snap a pic of it tomorrow when I have my camera and access to my server.

It was actually a lot of fun to build. I've never soldered a circuit board. I'm not good at it, but I got better as the kit progressed. I bench tested it and it works, so mission accomplished!
Dominator is online now   Reply With Quote
Old 10-19-2012, 02:24 PM   #440
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

Here are the pictures of the completed PWM kit I put together last night.

This is where I got it. http://www.ebay.com/itm/230844543212




Close-up of my 1st time circuit board soldering job. Not as bad as I thought it would look.
Dominator is online now   Reply With Quote
Old 10-19-2012, 07:18 PM   #441
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Pretty clean right there, Dom.
chanomatik is offline   Reply With Quote
Old 10-19-2012, 07:31 PM   #442
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

Thanks Chano. Now I just need some free time with access to a garage and I'll wire it in.
Dominator is online now   Reply With Quote
Old 10-19-2012, 08:28 PM   #443
mebr89
Scooby Newbie
 
Member#: 319479
Join Date: May 2012
Chapter/Region: AKIC
Vehicle:
2012 WRX
Gray

Default

Today I changed my oil an threw on a Nameless catback (thank you Chano!).
mebr89 is offline   Reply With Quote
Old 10-20-2012, 12:56 AM   #444
05GDF
Scooby Newbie
 
Member#: 281488
Join Date: Apr 2011
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2005 STi
OBP

Default

Changed my radiator! My old one blew this morning.
05GDF is offline   Reply With Quote
Old 10-20-2012, 01:52 AM   #445
Akrexak
NASIOC Supporter
 
Member#: 100607
Join Date: Nov 2005
Chapter/Region: AKIC
Location: Anchorage, AK
Vehicle:
2015 DGM STI-His
'14 FXT Touring-Hers

Default

Quote:
Originally Posted by mebr89 View Post
Today I changed my oil an threw on a Nameless catback (thank you Chano!).
Have you heard perrin catback in person? I heard it was very similar to nameless, you can't really tell in the videos. I'm trying to get someone's opinion on the sounds between the two.
Akrexak is online now   Reply With Quote
Old 10-20-2012, 06:08 AM   #446
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

Quote:
Originally Posted by mebr89 View Post
Today I changed my oil an threw on a Nameless catback (thank you Chano!).
Welcome, sir! I'm glad you enjoy it. It's better than having it sit in my basement, waiting to get experimented on.

Today I ditched the rusty look in place of something more chipper (thanks, Kyle!):

chanomatik is offline   Reply With Quote
Old 10-20-2012, 06:31 AM   #447
hatchin12
Scooby Newbie
 
Member#: 330911
Join Date: Sep 2012
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
2012 WRX COBB STG 1
ISM

Default

Today I installed the Cobb Stage 1 off my AP and installed a Nameless axle back with 5" mufflers. Next to come is a DP from Nameless, TMIC from Process Wext and a Protune.. Stoked!
hatchin12 is offline   Reply With Quote
Old 10-20-2012, 08:37 AM   #448
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Quote:
Originally Posted by hatchin12 View Post
Today I installed the Cobb Stage 1 off my AP and installed a Nameless axle back with 5" mufflers. Next to come is a DP from Nameless, TMIC from Process Wext and a Protune.. Stoked!
Lol, thanks for sharing but this is a local thread. Great taste in mods though, I'm mad jelly of the 5" muffled Nameless.

Here you go.
_davin is online now   Reply With Quote
Old 10-20-2012, 04:16 PM   #449
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

Default

chanomatik is offline   Reply With Quote
Old 10-20-2012, 04:32 PM   #450
bjcarter2
Scooby Specialist
 
Member#: 227288
Join Date: Oct 2009
Chapter/Region: AKIC
Location: Palmer, AK
Vehicle:
2006 MCS JCW
Pepper White

Default

Quote:
Originally Posted by chanomatik View Post
http://farm9.staticflickr.com/8046/8106361080_7f0af76e79_b.jpg
Ah...much better!
bjcarter2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.