Welcome to the North American Subaru Impreza Owners Club Friday April 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-17-2012, 09:50 AM   #1551
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

Quote:
Originally Posted by 79letour View Post
Damn, my seat squeak has returned with a vengeance.
At 5'10" and fairly slim, I find the seats to be a joke. They're fragile, uncomfortable, and reallly seem like they belong on a KIA.
My drivers side is where ALL my rattles and noises come from. The speaker grille on the dash, the steering column, the seat, the passenger rear door panel.
Being that there is rubber under the hooks where the spring attatches to the seatframe, I think its just the crappy spring design that's causing the squeak.
I wish this car didn't consume oil, and possibly coolant. And I wish swapping seats was an option. At all.
holy cow - was your car built on a monday when everyone at the plant was hungover?
* Registered users of the site do not see these ads.
M45 is offline   Reply With Quote
Old 10-17-2012, 10:44 AM   #1552
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Don't know the day. But October 2011. So- I also have had a brake recall.
79letour is offline   Reply With Quote
Old 10-17-2012, 01:13 PM   #1553
ans2k
Scooby Specialist
 
Member#: 315631
Join Date: Apr 2012
Location: Bryant, AR
Vehicle:
2012 Impreza Sport

Default

I think a lot of cars including the legacy, forester and outback had the brake master cylinder recall. Mine also had the recall.
ans2k is offline   Reply With Quote
Old 10-17-2012, 01:39 PM   #1554
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

All of the early adopters had the brake master cylinder recall. You have to realize that most new cars (especially the first off the line) sometimes have issues that need to be worked out. SOA has been very generous with the problems I have had.

79letour, you obviously hate your car. Just sell it. I'm not sure what sort of relationship you have with the dealer, but if they aren't willing to fix your problems call SOA and create a ticket, then go to another dealer. Even if you have to drive a distance.
ST Eye is offline   Reply With Quote
Old 10-17-2012, 01:49 PM   #1555
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Wow- ST, been there, done that!

I frequently check in on the SubaruForester.org site and the fb25's are definitely having some MAJOR oil consumption problems.
http://www.subaruforester.org/vbulle...8/index36.html

Subaru has an oily mess on their hands and as an american consumer I don't appreciate their trying to quietly dismiss the problems and pass them off to me. I expect more for my dollar than an oil burner and a "1200 allowance BS line".
I'm stuck with it at least till this time next year, unless I'm able to find some crazy deal.
If this is the quality I can expect from a Brand New Car, I'd just as soon go back to daily driving my pos GMC truck built 15 years ago.
79letour is offline   Reply With Quote
Old 10-17-2012, 01:59 PM   #1556
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

What does the dealer tell you the threshold is for oil consumption? IIRC you had the dealer do a consumption test?
ST Eye is offline   Reply With Quote
Old 10-17-2012, 02:19 PM   #1557
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by 79letour View Post
No leaks of oil or coolant were evident. I gave it a GOOD look. The castings on the lower portions of the engine are the cheapest crap I've seen in a while. Chinese scooters come with nicer castings than what I saw. Its literally raw, rough casting.
But- no leaks that I can see. The tiny little oil pan is funny knowing that this holds as much oil as some big-block V8's.
do you smell any coolant when you stop the car after driving a while? i have a faint smell. my consumption is slow but i think noticeable. i haven't gone to the dealer yet (too much on my plate, but hope to do a multiple check in for warranty work with them in a couple months to look at this coolant issue, an intermittent flakey passenger front window, and misc rattles)

thankfully, mine hasn't been consuming any noticeable oil. i will try to do an accurate measurement of what comes out when i drain it in december.
nubsub is offline   Reply With Quote
Old 10-17-2012, 02:38 PM   #1558
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

ST- I cat rewrite it all but go back four pages or so. The dealer encouraged me to come in and let them do the consumption test. They then filled the oil an inch and a quarter over the full mark. My receipt says 6qt of 0w30. So- after basically insisting they do the test, they totally botched it, then sent me down the road. After I'd even brought them donuts!
I'm burning roughly a quart every 3000 miles. From my consatant checking.
Takin the bull by the horns, though. No one will ever ever change my oil for me ever again.
79letour is offline   Reply With Quote
Old 10-17-2012, 02:40 PM   #1559
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

On the coolant- I used to notice a faint smell when it was NEW, but I can't say I smelled anything when under it yesterday.
79letour is offline   Reply With Quote
Old 10-17-2012, 03:14 PM   #1560
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by 79letour View Post
On the coolant- I used to notice a faint smell when it was NEW, but I can't say I smelled anything when under it yesterday.
thanks for the info. mine is faint and i definitely have very slow consumption. but in my opinion, while some oil consumption (not 1qt per 1200mi...maybe 1qt every 10k, would be ok by me) is ok, coolant consumption should be zero.

i'll let the dealer check it out with a pressure test when i bring it in.
nubsub is offline   Reply With Quote
Old 10-17-2012, 03:24 PM   #1561
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

man I hope these problems went away on 2013s!
M45 is offline   Reply With Quote
Old 10-17-2012, 03:50 PM   #1562
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I doubt it, as they're still scrambling for replacement parts for the 12's. The third year of the fb in the Foresters and they're still consuming oil... Idk
79letour is offline   Reply With Quote
Old 10-17-2012, 04:11 PM   #1563
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Albany NY
Vehicle:
2012 Sport 5MT
Green/Silver

Default

Quote:
Originally Posted by M45 View Post
man I hope these problems went away on 2013s!
Don't worry, most 2012 Impreza owners are not experiencing these problems.

That does not mean some aren't, just that most aren't.
Zeeper is offline   Reply With Quote
Old 10-18-2012, 08:26 AM   #1564
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: South Jersey
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

7000+ miles and oil level is full. No signs of missing oil.
foghelmut is offline   Reply With Quote
Old 10-18-2012, 09:41 AM   #1565
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Lucky you!
79letour is offline   Reply With Quote
Old 10-18-2012, 05:15 PM   #1566
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

After they overfilled mine by 16mm at 600 miles oil change and requested they drain some, ( they still left it 10ml over ) hasn't noticeably gone down in 4000 miles since the change.

Not sure if it's going to be the same but notice on my '04 Ford Fiesta 1.6 M which I change myself with 5/30w Full synth every 6 months it usually stays at the Full Mark for the first 5000 miles before slowly dropping I presume due to the oil slowly breaking down ? Will be interested to see if the Subi does the same.
John451 is offline   Reply With Quote
Old 10-18-2012, 05:40 PM   #1567
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by John451 View Post
After they overfilled mine by 16mm at 600 miles oil change and requested they drain some, ( they still left it 10ml over ) hasn't noticeably gone down in 4000 miles since the change.

Not sure if it's going to be the same but notice on my '04 Ford Fiesta 1.6 M which I change myself with 5/30w Full synth every 6 months it usually stays at the Full Mark for the first 5000 miles before slowly dropping I presume due to the oil slowly breaking down ? Will be interested to see if the Subi does the same.

i posted pics in the big impreza thread. 5qts will put you to the full dot, 5.3qts will put you over about 1/4"
flyboy1100 is offline   Reply With Quote
Old 10-18-2012, 07:14 PM   #1568
M45
Scooby Newbie
 
Member#: 333446
Join Date: Sep 2012
Chapter/Region: NESIC
Vehicle:
2013 Impreza SL CVT
DGM

Default

Quote:
Originally Posted by flyboy1100 View Post
i posted pics in the big impreza thread. 5qts will put you to the full dot, 5.3qts will put you over about 1/4"
is it bad to actually put in the 5.3 qts?
M45 is offline   Reply With Quote
Old 10-18-2012, 08:24 PM   #1569
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

No. Its bad to put in 6+ quarts.
I've been reading threads on the Scion FR-S forum/site and those guys are having all kinds of qc problems.
But MANY of the fr-s/brz crowd ARE running 5w30 full synthetic and having good results.
79letour is offline   Reply With Quote
Old 10-18-2012, 08:30 PM   #1570
Impreza1228
Scooby Newbie
 
Member#: 325234
Join Date: Jul 2012
Location: NC
Vehicle:
2012 Impreza Pre CVT

Default

Quote:
Originally Posted by M45 View Post
is it bad to actually put in the 5.3 qts?
Yes at least for my my first change. http://forums.nasioc.com/forums/show...2366664&page=2


I made frequent checks of oil level before I changed it and it remained full. I did my first change at 5140 miles. I know many people may disagree with going so many miles for first interval. However, it is synthetic oil and I live in NC where until only recently have we seen high temperatures. I do not consider these miles to be under severe conditions and followed guidelines proscribed in warranty and maintenance booklet provided by subaru. I broke the car in as recommended. The end of July would be 7 months since i bought the car, I decided it was time to change oil now as summer has set in. Now I intend to change oil every 5000 miles or 7 months which ever occurs first from here out. This is ahead of what Subaru recommends.

Now to answer your question when I drained the oil I checked and approximately 5 quarts drained out. So I put back 5 quarts to be on safe side in it was slightly below full level (1/8-1/16") ran car to normal operating temperature and it now shows full it has remained at this level with approximately 5300 miles now on odometer.

I drained the oil on low profile rhino ramps in my garage. Added 5 quarts pulled car off ramps to level concrete garage floor and preceded as described above.


I'm now at approximately 8000 miles 0 % consumption.
Impreza1228 is offline   Reply With Quote
Old 10-18-2012, 08:47 PM   #1571
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Man. Lucky YOU!
I'm hoping 5w oil and a 6000 mile interval will slow or end my woes, at least till its paid off.
79letour is offline   Reply With Quote
Old 10-18-2012, 09:09 PM   #1572
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by 79letour
No. Its bad to put in 6+ quarts.
I've been reading threads on the Scion FR-S forum/site and those guys are having all kinds of qc problems.
But MANY of the fr-s/brz crowd ARE running 5w30 full synthetic and having good results.
I think the 20wt is just too thin. For stone cars it is ok, i just don't think these motors are built to tight enough tolerances to actually spec the 20wt. The end difference between 20 and 30 isn't much, 40 is a huge step however
flyboy1100 is offline   Reply With Quote
Old 10-18-2012, 09:45 PM   #1573
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I agree. I think 0w20 in combination with low tension rings isn't a great idea.
An appealing reason t try the 5w30 synthetic is that there is plenty of selection and its WAY cheaper to buy. Probably gonna go with Kendall, and if it seems to alleviate the oil useage, switch to Amsoil. I just CAN'T see pouring in $10 quart oil if its burning it up.
79letour is offline   Reply With Quote
Old 10-18-2012, 11:07 PM   #1574
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

Subaru suggests 0w-20 because the engineered for that weight oil. That said I am going to keep using the proper weight oil. For 79letour I suppose it's worth giving it a shot though. Did Subaru recommend the heavier oil?
ST Eye is offline   Reply With Quote
Old 10-18-2012, 11:18 PM   #1575
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by ST Eye
Subaru suggests 0w-20 because the engineered for that weight oil. That said I am going to keep using the proper weight oil. For 79letour I suppose it's worth giving it a shot though. Did Subaru recommend the heavier oil?
While i agree partially, i think a large partof the oil recommendation is to milk out that last .5mpg. I am using what i think is acceptable, it is just a little disappointing on a brand new car. When you consider my buick didn't start to use/leak oil until it got up to 160k, and that is a very old engine design with pretty crappy tolerances.
flyboy1100 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 08:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 05:18 PM
('11+) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 12:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 10:36 AM
('11+) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 12:14 PM


All times are GMT -4. The time now is 02:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.