Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-21-2012, 09:13 PM   #1
Kijho
Scooby Newbie
 
Member#: 311882
Join Date: Feb 2012
Chapter/Region: W. Canada
Location: Alberta
Vehicle:
1995 GC8 STI
White

Default Rough Initial Idle 95' sti

I've read over so many threads, gone through the hesitation thread, been all over various forums and still somewhat stuck. Perhaps someone can give me some specific input from the video below.

I've done:
Coilpack conversion
Sparkplugs
Oil change
MAF clean / Checked
Airbox filter clean / checked

Have not done but have read on:
Injectors
IACV



Only happens after it's been sitting overnight or all day in the cold.
Predicting some -20celcius here next week so starting to get worried.

I believe this is my IACV??
Every thread I've read in regards to my problem seems to point towards a guide with a completely different looking IACV above the Throttle body.. which I don't see on mine.


Thank you
Kijho is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.