Welcome to the North American Subaru Impreza Owners Club Friday February 12, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-24-2012, 09:49 PM   #1
Superorb
Scooby Guru
 
Member#: 135252
Join Date: Dec 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2002 WRX Wagon
86% Operational :(

Default Fluid on top of tranny?

I put my old exhaust on the car a few days ago and noticed a fair amount of what looks like tranny fluid all over the top of the tranny where the shift linkage goes into the tranny. You can see the reflective fluid in the pic. What would cause this?

Superorb is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.